nautilus crashed with SIGSEGV in g_type_check_instance_cast()

Bug #187183 reported by Hervé Cauwelier
This bug affects 63 people
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Critical
libgnomeui (Ubuntu)
High
Ubuntu Desktop Bugs

Bug Description

Binary package hint: nautilus

It crashed suddenly, a couple of hours after upgrading libgio (or is it gvfs?).

Brasero crashed a couple of minutes before with the same traceback (see #187182) in the middle of a burning process.

I used nautilus for various and intensive tasks during these two hours, so I was surprised it happened when just opening a text file.

ProblemType: Crash
Architecture: i386
CrashCounter: 1
Date: Wed Jan 30 00:01:52 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/nautilus
NonfreeKernelModules: nvidia
Package: nautilus 1:2.21.90-0ubuntu1
PackageArchitecture: i386
ProcCmdline: nautilus --no-default-window --sm-client-id default2
ProcCwd: /home/herve
ProcEnviron:
 LANGUAGE=fr_FR:fr:en_GB:en
 PATH=/home/herve/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: nautilus
StacktraceTop:
 g_type_check_instance_cast ()
 ?? () from /usr/lib/gtk-2.0/2.10.0/filesystems/libgio.so
 ?? ()
 ?? ()
 ?? ()
Title: nautilus crashed with SIGSEGV in g_type_check_instance_cast()
Uname: Linux xiong 2.6.24-5-generic #1 SMP Thu Jan 24 19:45:21 UTC 2008 i686 GNU/Linux
UserGroups: adm admin audio cdrom dialout dip floppy kvm lpadmin netdev plugdev powerdev scanner vboxusers video

Revision history for this message
Hervé Cauwelier (hcauwelier-deactivatedaccount) wrote :
Revision history for this message
Apport retracing service (apport) wrote : Symbolic stack trace

StacktraceTop:volumes_drives_changed (volume_monitor=0x81b4690, volume=0x853ae98, user_data=0x845e8b0)
IA__g_cclosure_marshal_VOID__OBJECT (closure=0x86edb90, return_value=0x0, n_param_values=2,
IA__g_closure_invoke (closure=0x86edb90, return_value=0x0, n_param_values=2,
signal_emit_unlocked_R (node=0x81da6e8, detail=0, instance=0x81b4690, emission_return=0x0,
IA__g_signal_emit_valist (instance=0xb17db9dc, signal_id=48, detail=0, var_args=0xbfec0c5c "")

Revision history for this message
Apport retracing service (apport) wrote : Symbolic threaded stack trace
Changed in nautilus:
importance: Undecided → Medium
Revision history for this message
Pedro Villavicencio (pedro) wrote :

Thanks for your bug report. This bug has been reported to the developers of the software. You can track it and make comments here: http://bugzilla.gnome.org/show_bug.cgi?id=513082

Changed in nautilus:
assignee: nobody → desktop-bugs
status: New → Triaged
Changed in nautilus:
status: Unknown → New
Revision history for this message
thomasn80 (thomasn80) wrote :

Happened to me too. Have the crash report. It crashed after a successful burn and I checked the close checkbox to make the window go away.

Revision history for this message
Nizar Kerkeni (nizarus) wrote :

I got the same crash message with ubuntu alpha5 (amd64) when mounting my external usb hard disk disk one second after my usb flash disk !!

Revision history for this message
miked (miked11) wrote :

Ubuntu Hardy Heron 8.04 Alpha 5
root@AMD1Ghz-desktop:~#
crash while looking for md5 check integrity file

Changed in nautilus:
status: New → Incomplete
Revision history for this message
Sebastien Bacher (seb128) wrote :

could you try if that's still an issue using the current versions?

Changed in libgnomeui:
status: Triaged → Incomplete
Revision history for this message
Harvey Muller (hlmuller) wrote :

Sebastien:

I experienced this error in the earlier Alpha releases, but have not seen it again. I'm currently running Alpha 6. Historically, I was unable to reproduce this at will.

Harvey

Changed in nautilus:
status: Incomplete → New
Revision history for this message
nanog (sorenimpey) wrote :

I am still getting this bug with updated alpha 6 as of yesterday.

Revision history for this message
Raven (raedwald) wrote :

Upgrade to Beta1.

Revision history for this message
Removed by request (removed1836289) wrote :

Still happening with beta1. AMD64

Changed in libgnomeui:
status: Incomplete → Triaged
Revision history for this message
toobuntu (toobuntu) wrote :

Just happened to me on fully up to date Hardy beta as of 25-Mar-2008. CD appears to be burned properly, though.

Changed in libgnomeui:
milestone: none → ubuntu-8.04
Changed in libgnomeui:
importance: Medium → High
Revision history for this message
Robstarusa (rob-naseca) wrote :

Happened to me as well, but with gnome-panel. I clicked the option to automatically report the bug. I hope that is enough. since the function call was the same one as mentioned here, but for gnome panel, I chose this one.

Revision history for this message
thyultimate (thyultimate) wrote : Re: [Bug 187183] Re: nautilus crashed with SIGSEGV in g_type_check_instance_cast()

i dont even know what that means, i jsut upgraded and it rebooted and
gave me that error but everything seemed to work normally after that
:)

On Fri, Mar 28, 2008 at 6:26 PM, Robstarusa <email address hidden> wrote:
> Happened to me as well, but with gnome-panel. I clicked the option to
> automatically report the bug. I hope that is enough. since the
> function call was the same one as mentioned here, but for gnome panel, I
> chose this one.
>
> --
> nautilus crashed with SIGSEGV in g_type_check_instance_cast()
> https://bugs.launchpad.net/bugs/187183
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

Revision history for this message
toobuntu (toobuntu) wrote :

just happened to me again, but on a different machine, and without having used brasero.

Revision history for this message
Peter T Hayward (energonic) wrote :

Hardy 8.04
Brasero 0.7.1

Same error for me. I burned a DVD and auto closed program. Then put the newly burned DVD back into drive and restarted Brasero. This crash immediately after starting verify.

Revision history for this message
Mskadu (mskadu-deactivatedaccount) wrote :

Hardy v8.04
Rhythmbox 0.11.5
Diskmounter 2.22.0

Mounted my Apple iPod for the first time. Gnome panel just crashed and restarted.

Revision history for this message
Ken Gutkowski (mordak) wrote :

I have had problems umounting my external USB storage drive. It freezes Nautilus for a minute or more when mounting and umounting. It hasn't crashed yet with this USB drive but I do have a persistent icon on the desktop even when the drive is not mounted that I can't remove unless I log out and back in again..

Revision history for this message
Peter T Hayward (energonic) wrote :

My Verify DVD crash is repeatable. Sent a crash report in case it helps.

Revision history for this message
Matthias Klumpp (ximion) wrote :

I tried to connect to an FTP-Server (with Nautilus) and had the same problem.

Revision history for this message
Pedro Villavicencio (pedro) wrote :

Thanks all the bug has been fixed upstream already.

Changed in libgnomeui:
status: Triaged → Fix Committed
Revision history for this message
Saul (creative-balm) wrote :

Have had lots of problems after updating to latest kernal (15) in Hardy - before that (12?) it was very stable. Also the menu option "Other" has disappeared and will not re-introduce itself even when ticked in System>Preference>Menu - which stops me adjusting screen resolution higher than 800X600. When nvidia driver enable the problem is much worse/computer unusable.

Revision history for this message
oozool (korlortar) wrote :

try using Nvidia's own x config server to set your primary (or even if you have a secondary display, like a TV), if you haven't done so already try downloading their drivers, and install them from the root (no GUI, sorry), with the exact command as they wrote on their website (sh nvidia...)
Hopefully it helps...

Revision history for this message
David S. (xxxxxx) wrote : Re: [Bug 187183] Re: nautilus crashed with SIGSEGV in g_type_check_instance_cast()

Greetings!

Yes, I also have problems with the new 2.6.24-14 and -15 Kernel: After
the login the Scre3en remains white, but i still can flipp the cube; no
panlels - no anything but a white screen - the -12 Kernel works just fine.

Mit freundlichen Grüßen
David Schmaranzer

Saul Chambers schrieb:
> Have had lots of problems after updating to latest kernal (15) in Hardy
> - before that (12?) it was very stable. Also the menu option "Other"
> has disappeared and will not re-introduce itself even when ticked in
> System>Preference>Menu - which stops me adjusting screen resolution
> higher than 800X600. When nvidia driver enable the problem is much
> worse/computer unusable.
>
>

Revision history for this message
Wingman (mikywing) wrote :

Hi to all!

It also happened to me while converting some mp3's before burn. I use Hardy since alpha5 and it's fully updated using the latest kernel.

Revision history for this message
Dave Stroud (bigdavesr) wrote :

I have had no more problems since update. May be a hardware problem. I had the resolution problem in 7.10. manually reconfigured and it worked from there on.

Revision history for this message
Sebastien Bacher (seb128) wrote :

those new comments are out of topic there, could you use an user forum rather to ask your questions?

Revision history for this message
*nix (xinu7) wrote :

nautilus crashed with SIGSEGV in g_type_check..

Revision history for this message
yop (yop) wrote :

It just crashed on me, I was opening the nautilus
All up to date

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libgnomeui - 2.22.1.0-0ubuntu1

---------------
libgnomeui (2.22.1.0-0ubuntu1) hardy; urgency=low

  * New upstream version:
   - Cleanups
    - Use Gio for thumbnailing (lp: #203151)
    - Fix several crashes and critical warnings in the gio file chooser backend
      (lp: #187183, #199459, #199942, #201631)
    - Plug a leak
    - Updated translations.
  * debian/patches/90_from_svn_thumbnails_use_gio.patch:
    - dropped, fixed in the new version

 -- Sebastien Bacher <email address hidden> Wed, 09 Apr 2008 14:17:21 +0200

Changed in libgnomeui:
status: Fix Committed → Fix Released
Changed in nautilus:
status: New → Fix Released
Revision history for this message
secure bit (ahmad-hamad-777) wrote : Re: [Bug 187183] Hey,friends!!

You must be a jackass !

On Wed, Jan 7, 2009 at 5:00 PM, thyultimate <email address hidden> wrote:

> Dear,
> Good day!!!
> I would like to introduce a very good company, electronic products
> Wholesale dealer.
> I have bought some products from company,the price was very cheap,
> and the products are very good quality!
> Just have a look at this web page : http://www.hpp9.com/
> I am sure you will could save a lot of money!
> Happy new year!!!!!
> Best regards!!!
> introduction give you of friend!!!
>
> --
> nautilus crashed with SIGSEGV in g_type_check_instance_cast()
> https://bugs.launchpad.net/bugs/187183
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

Revision history for this message
qubitual (qubitual) wrote :

It ain't me, babe - obviously, the bug site has been hacked by some moronic
a-hole.

On Wed, Jan 7, 2009 at 4:52 PM, secure bit <email address hidden>wrote:

> You must be a jackass !
>
> On Wed, Jan 7, 2009 at 5:00 PM, thyultimate <email address hidden>
> wrote:
>
> > Dear,
> > Good day!!!
> > I would like to introduce a very good company, electronic products
> > Wholesale dealer.
> > I have bought some products from company,the price was very cheap,
> > and the products are very good quality!
> > Just have a look at this web page : http://www.hpp9.com/
> > I am sure you will could save a lot of money!
> > Happy new year!!!!!
> > Best regards!!!
> > introduction give you of friend!!!
> >
> > --
> > nautilus crashed with SIGSEGV in g_type_check_instance_cast()
> > https://bugs.launchpad.net/bugs/187183
> > You received this bug notification because you are a direct subscriber
> > of a duplicate bug.
> >
>
> --
> nautilus crashed with SIGSEGV in g_type_check_instance_cast()
> https://bugs.launchpad.net/bugs/187183
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Revision history for this message
vladdrac (caleb-rill) wrote :

*falls off his chair laughing*

Revision history for this message
thyultimate (thyultimate) wrote :

WHAT just happened? People from my address book in gmail received the same message as the one secure bit quoted, but I can find the message here in the comments, how did you quote it?
Jan 7, 2009 at 4:52 PM, secure bit wrote
Jan 7, 2009 at 5:00 PM, thyultimate wrote
Whats with the time?
The message does not appear in my send items or thrash or in the comments here, I am totally confused.....

It ain't me, babe - obviously, the bug site has been hacked by some moronic
a-hole.

^^ but qubitual you arent accused, why justify? Did the same thing happen to you? I mean did the hacked server here do that? In that case why are my contacts from gmail affected?

Revision history for this message
Savvas Radevic (medigeek) wrote :

> The message does not appear in my send items or thrash or in the comments here, I am totally confused.....
The message was removed after my request. The only logical explanation is that they sent it to all your gmail contacts, (yes, launchpad accepts emails and replies directly from your email), they removed it and cleared out the trash gmail folder.

But this is a bug report, it doesn't have to do with the incident, so please keep the replies related to the bug.
If you're still wondering about your spam incident, you can make a question at https://answers.launchpad.net/malone/.

Changed in nautilus:
importance: Unknown → Critical
Revision history for this message
Jonathan Alfonso (alfonsojon1997) wrote :

It looks like this bug is back in 12.10

Revision history for this message
Richard Sellam (richard-sellam) wrote :

Also having this bug in 12.10...

Revision history for this message
adriangoodyer (adriangoodyer) wrote :

Also getting this in 12.10

Although not very often I read a bug report and it amuses me...

Revision history for this message
Quinta Helmer (qhelmer) wrote :

Also getting it in 12.04.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.