keyboard indicator doesn't use number to differenciate variants

Bug #546240 reported by Fabián Rodríguez on 2010-03-24
42
This bug affects 6 people
Affects Status Importance Assigned to Milestone
GNOME Settings Daemon
Fix Released
Medium
libgnomekbd (Ubuntu)
Low
Unassigned
Lucid
Low
Unassigned

Bug Description

Binary package hint: gnome-settings-daemon

In Karmic and previous Ubuntu versions the keyboard indicator applet would show a subscript number for variants of same-language keyboards when cycling through them.

For example having both USA and USA (Alternative International - former us_intl) would show USA and USA(2).

Now it only shows USA no matter which one is active. Hovering over with the mouse cursor shows the appropriate layout is active, but there is no visual clue about it.

ProblemType: Bug
Architecture: i386
Date: Wed Mar 24 14:13:09 2010
DistroRelease: Ubuntu 10.04
InstallationMedia: Error: [Errno 13] Permission denied: '/var/log/installer/media-info'
Package: gnome-settings-daemon 2.29.92-0ubuntu3
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-17.26-generic 2.6.32.10+drm33.1
SourcePackage: gnome-settings-daemon
Uname: Linux 2.6.32-17-generic i686

Fabián Rodríguez (magicfab) wrote :
tags: added: indicator-application regression-potential
Fabián Rodríguez (magicfab) wrote :

I've also added USA LatinAmerican and it also displays as "USA" when in Karmic it displays as LAm.

Sebastien Bacher (seb128) wrote :

Thank you for your bug report. The issue is an upstream one and it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

Changed in gnome-settings-daemon (Ubuntu):
importance: Undecided → Low
tags: removed: indicator-application
Sebastien Bacher (seb128) wrote :

the keyboard indicator is not an application indicator but a notification icon which is an upstream change

summary: - New Lucid keyboard indicator doesn't show keyboard variants
+ keyboard indicator doesn't use number to differenciate variants
Sebastien Bacher (seb128) wrote :
Changed in gnome-settings-daemon (Ubuntu):
status: New → Triaged
affects: gnome-settings-daemon (Ubuntu) → libgnomekbd (Ubuntu)
affects: libgnomekbd (Ubuntu) → gnome-settings-daemon (Ubuntu)
affects: gnome-settings-daemon (Ubuntu) → libgnomekbd (Ubuntu)
affects: libgnomekbd (Ubuntu) → gnome-settings-daemon (Ubuntu)
Sebastien Bacher (seb128) wrote :

The issue is a libgnomekbd one

affects: gnome-settings-daemon (Ubuntu) → libgnomekbd (Ubuntu)
affects: libgnomekbd (Ubuntu) → gnome-settings-daemon (Ubuntu)
Sebastien Bacher (seb128) wrote :

grrrr launchpad and buggy triaging tools, sorry for the reassigning noise...

affects: gnome-settings-daemon (Ubuntu) → libgnomekbd (Ubuntu)
Changed in gnome-settings-daemon:
importance: Undecided → Unknown
status: New → Unknown
Sebastien Bacher (seb128) wrote :

the bug has been fixed upstream now

Changed in libgnomekbd (Ubuntu):
status: Triaged → Fix Committed
Changed in gnome-settings-daemon:
status: Unknown → Fix Released
Mark Rowan (mark-tamias) wrote :

This bug is still present in libgnomekbd4 version 2.30.0-0ubuntu2

Sebastien Bacher (seb128) wrote :

the issue is fixed in the maverick version now

Changed in libgnomekbd (Ubuntu):
status: Fix Committed → Fix Released
Changed in libgnomekbd (Ubuntu Lucid):
importance: Undecided → Low
status: New → Fix Committed
Sebastien Bacher (seb128) wrote :

Accepted libgnomekbd into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Sebastien Bacher (seb128) wrote :

could somebody test the upgrade? the rendering changed slightly there but upstream argue the current way is using the right api and it tradding rendering issues for an another set, they also improved the code and fixed crasher issues and recommend we use the upgrade. out of the rendering different the indicator works correctly there for over a week in the notification area and gnome-screensaver unlock dialog

Mark Rowan (mark-tamias) wrote :

Yes, I've tested it and it's working. The rendering is different for me too, but I've not had a problem after using it for a week.

Martin Pitt (pitti) wrote :

Conversely, I use two different layouts (de, us) which already had intelligible names before. The rendering changed slightly, but otherwise it's still working.

tags: added: verification-done
removed: verification-needed
Fabián Rodríguez (magicfab) wrote :

Tested and works, however this now highlight another problem: the keyboard-shortcut to switch layouts only cycle once through choices. I'll open/chase another bug.

If there's a way to change the rendering (font, size, color) of the indicator I'd like to know about it.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libgnomekbd - 2.30.1-0ubuntu1

---------------
libgnomekbd (2.30.1-0ubuntu1) lucid-proposed; urgency=low

  * New upstream version:
    - "keyboard indicator doesn't use number to differenciate variants"
      is fixed in thi version (lp: #546240)
  * debian/patches/90_git_default_value.patch:
    - the change is in the new version
  * debian/patches/02_layout_crash.patch:
    - upstream change to fix a crasher caused by an unitialized value.
 -- Sebastien Bacher <email address hidden> Tue, 08 Jun 2010 18:09:23 +0200

Changed in libgnomekbd (Ubuntu Lucid):
status: Fix Committed → Fix Released
Changed in gnome-settings-daemon:
importance: Unknown → Medium
Peter Belew (peterbe) wrote :

I just noticed today that this bug has come back in 11.04 natty (alpha1 with updates through today). I sometimes use as many as 4 alternate US layouts, so this is a real inconvenience.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.