Keyboard layout panel indicator ignores theme font color settings

Bug #513152 reported by Andrej Rohaŭ on 2010-01-27
130
This bug affects 24 people
Affects Status Importance Assigned to Milestone
GNOME Settings Daemon
Invalid
Medium
libgnomekbd (Ubuntu)
Low
Sebastien Bacher
Lucid
Low
Sebastien Bacher

Bug Description

Binary package hint: gnome-settings-daemon

The font color is always black which makes it unreadable on dark desktop themes like stock DarkRoom or New Wave.

gnome-settings-daemon 2.29.6-0ubuntu1

Related branches

Andrej Rohaŭ (arohau) on 2010-01-27
description: updated
Andrej Rohaŭ (arohau) wrote :

The issue is still present with the latest 2.29.90-0ubuntu1 version of the package.

Oded Arbel (oded-geek) wrote :

In 2.29.91.1-0ubuntu3 the system tray applet is gone and instead there is a layout indicator in the the "indicator applet". This one obeys the color scheme, but doesn't actually show the current layout :-(

See bug #531173

Sebastien Bacher (seb128) wrote :

the bug is fixed now in lucid

Changed in gnome-settings-daemon (Ubuntu):
importance: Undecided → Low
status: New → Fix Released
Sebastien Bacher (seb128) wrote :

reopening the indicator has other issues and has been postponed to next cycle rather

Changed in gnome-settings-daemon (Ubuntu):
status: Fix Released → Confirmed
Andrej Rohaŭ (arohau) wrote :

Hi,

I've made a clean install of latest Lucid netboot to make sure the issue is present by default and none of my personal settings affect it anyhow. Just check out the attached screenshot to decide if this bug is really of only a low priority to you.

Desktop keyboard layout indicator is just plain unreadable on the new default theme.

Changed in gnome-settings-daemon (Ubuntu):
status: Confirmed → Triaged
Changed in gnome-settings-daemon (Ubuntu Lucid):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
affects: gnome-settings-daemon (Ubuntu Lucid) → libgnomekbd (Ubuntu Lucid)
Changed in libgnomekbd (Ubuntu Lucid):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libgnomekbd - 2.29.92-0ubuntu1

---------------
libgnomekbd (2.29.92-0ubuntu1) lucid; urgency=low

  * New upstream version:
    - GkbdStatus is using gtk/gnome font settings (lp: #513152, #524136)
    - A lot of translations fixed
    - Explicit dbus dependency dropped
  * debian/control.in:
    - dropped dbus dependencies
  * debian/patches/01_requires_private.patch:
    - new version update
 -- Sebastien Bacher <email address hidden> Tue, 09 Mar 2010 11:31:23 +0100

Changed in libgnomekbd (Ubuntu Lucid):
status: Fix Committed → Fix Released
Andrej Rohaŭ (arohau) wrote :

Attached a couple of screenshots to show that problem is still present even after the latest update. Please also notice, that indicator font size has changed and is smaller than system theme set one. It is best noticeable with a smaller font size setting as on the 3rd screenshot.

Andrej Rohaŭ (arohau) on 2010-03-11
Changed in libgnomekbd (Ubuntu Lucid):
status: Fix Released → Confirmed
Sebastien Bacher (seb128) wrote :

the bug has been fixed upstream now

Changed in libgnomekbd (Ubuntu Lucid):
status: Confirmed → Fix Committed
Screatch (screatch) wrote :

Lucid Beta 1, still not fixed.
What should i do to get it fixed?

Screatch (screatch) wrote :

Oh and i got libgnomekbd - 2.29.92-0ubuntu2 installed...

All latest updates are installed.

Oded Arbel (oded-geek) wrote :

I confirm this is still an issue with current Lucid: the font color has changed, from black to slightly lighter gray on my system. I'm using Ambiance where the text color should be white (I think - the "Appearance" dialog doesn't have an option to show/configure the menu colors).

In my particular use case, I moved the system tray to AWN where the default background color is light gray - I was planning to change it to the same color as the panel if not for the fact that then the keyboard indicator would be completely invisible, but with the last change it went from non-conforming but very visible on light gray to non-conforming and not really visible on light gray.

Anders Østerholt (diebels) wrote :

Changing back to Confirmed. The upstream bug fix just says "Done. Please check in git." at 6th of March.

Changed in libgnomekbd (Ubuntu Lucid):
status: Fix Committed → Confirmed
Еггог (sergey-nr) wrote :

I use ubuntu 10.04 beta1 with all updates on 22 Mar 2010 and found a problem with displaying the applet switch keyboard layouts. When using the default theme (ambiance), the font color in the applet merges with the background. Example in the screenshot. In addition, the same problem occurs in the context menu qt4 applications (Skype). Black text on a dark background is not readable

Changed in libgnomekbd (Ubuntu Lucid):
status: Confirmed → Fix Committed
assignee: Ubuntu Desktop Bugs (desktop-bugs) → Sebastien Bacher (seb128)
status: Fix Committed → Confirmed
status: Confirmed → Fix Committed
status: Fix Committed → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libgnomekbd - 2.29.92-0ubuntu3

---------------
libgnomekbd (2.29.92-0ubuntu3) lucid; urgency=low

  * debian/patches/03_git_use_gtkfont.patch:
   - git change to use the correct font and color in the keyboard indicator
     (lp: #513152)
 -- Sebastien Bacher <email address hidden> Tue, 23 Mar 2010 00:56:56 +0100

Changed in libgnomekbd (Ubuntu Lucid):
status: Triaged → Fix Released
Anders Østerholt (diebels) wrote :

I don't think this bug is fixed yet. Posted a screenshot and comment on the upstream bug report.

Anders Østerholt (diebels) wrote :

All fine now with 2.29.92-0ubuntu3. White text on dark background. :-)

Еггог (sergey-nr) wrote :

Now, with 2.29.92-0ubuntu3 all great, thanks !

Ilja Sekler (ilja-sekler-) wrote :

> Now, with 2.29.92-0ubuntu3 all great, thanks !

Not everything, unfortunately. As tested with Lucid daily live CD from 2010-04-02, the keyboard layout indicator uses wrong font anti-aliasing (gray instead of sub-pixel) and probably wrong (medium?) hinting as well. A magnified (400%) screenshot is attached.

Would you prefer to treat this issue here or shall I file a new bug?

Andrej Rohaŭ (arohau) wrote :

Upsteam is aware of the font anti-aliasing issue and has commited a fix in git already.

See: https://bugzilla.gnome.org/show_bug.cgi?id=612371

Please file as a separate bug here so we can link it and test out.

Ilja Sekler (ilja-sekler-) wrote :

> Upsteam is aware of the font anti-aliasing issue and has commited
> a fix in git already.

Is <http://git.gnome.org/browse/libgnomekbd/commit/?id=342b82bfd0308275618180652dc56e7d9b663642> the commit you are speaking about? Could not find any direct reference to anti-aliasing and hinting in the upstream bug, only a more general "font style" mentioned in <https://bugzilla.gnome.org/show_bug.cgi?id=612371#c3>.

> Please file as a separate bug here so we can link it and test out.

Filed <https://bugs.launchpad.net/ubuntu/+source/libgnomekbd/+bug/555156>.

Andrej Rohaŭ (arohau) wrote :

IIRC, the issue is caused by 'toy' Cairo API usage which does not handle hinting settings and scales the label text down. The mentioned commit introduces proper font setup routine. You can check upsteam bug duplicates for direct references.

Sebastien Bacher (seb128) wrote :

the newest git changes don't work great, the label ratio is wrong since their try to use a square indicator and the aliasing has weird effects, the current lucid version will stay as it is for lucid

Changed in gnome-settings-daemon:
status: Unknown → Invalid
Boaz Haberman (bhaberman) wrote :

the text in the keyboard indicator is moderately visible in the default theme, but it is invisible in many other themes, for example ClearLooks and Human.

Changed in gnome-settings-daemon:
importance: Unknown → Medium
status: Invalid → Unknown
Changed in gnome-settings-daemon:
status: Unknown → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.