/usr/bin/gkbd-keyboard-display:11:get_preferred_height_for_width:gtk_widget_query_size_for_orientation:gtk_widget_compute_size_for_orientation:gtk_widget_get_preferred_height_for_width:gtk_box_compute_size_for_orientation

Bug #1721893 reported by errors.ubuntu.com bug bridge on 2017-10-06
70
This bug affects 15 people
Affects Status Importance Assigned to Milestone
libgnomekbd
Confirmed
Medium
libgnomekbd (Ubuntu)
High
Unassigned
Bionic
Undecided
Unassigned
Cosmic
Undecided
Unassigned

Bug Description

* Impact
The keyboard layout preview code segfault in some cases

* Test case
- call "gkbd-keyboard-display -l default", it should displays a keyboard drawing without segfaulting

also check that reports stop for the new version on the error tracker url mentioned below

* Regression potential
check that the right keyboard layout is being drawn (in case where it was segfaulting before, it shouldn't impact on cases which were working)

---------------------------------

The Ubuntu Error Tracker has been receiving reports about a problem regarding libgnomekbd. This problem was most recently seen with package version 3.26.0-2, the problem page at https://errors.ubuntu.com/problem/7523168870802b9f73ecbee36701129263dcfaaa contains more details, including versions of packages affected, stacktrace or traceback, and individual crash reports.
If you do not have access to the Ubuntu Error Tracker and are a software developer, you can request it at http://forms.canonical.com/reports/.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libgnomekbd (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :
Changed in libgnomekbd (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
Changed in libgnomekbd:
importance: Unknown → Medium
status: Unknown → Confirmed
description: updated
Changed in libgnomekbd (Ubuntu):
status: Triaged → Fix Committed
Sebastien Bacher (seb128) wrote :

(the fix has been uploaded in Debian, which means disco is going to be fixed once autosyncs from Debian are turned back on)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libgnomekbd - 3.26.0-4

---------------
libgnomekbd (3.26.0-4) unstable; urgency=medium

  * debian/patches/bugzilla_invalid_layout_segfault_fix.patch:
    - backport a patch available on bugzilla to fix a segfault in the
      keyboard layout preview code. The most common case seems to be g-c-c
      trying to preview a 'default' layout which was working before some
      other fixes landed, that fixes the regression. (lp: #1721893)

 -- Sebastien Bacher <email address hidden> Thu, 22 Nov 2018 17:07:01 +0100

Changed in libgnomekbd (Ubuntu):
status: Fix Committed → Fix Released

Hello errors.ubuntu.com, or anyone else affected,

Accepted libgnomekbd into cosmic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/libgnomekbd/3.26.0-3ubuntu0.18.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-cosmic to verification-done-cosmic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-cosmic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in libgnomekbd (Ubuntu Cosmic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-cosmic
Brian Murray (brian-murray) wrote :

Hello errors.ubuntu.com, or anyone else affected,

Accepted libgnomekbd into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/libgnomekbd/3.26.0-3ubuntu0.18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in libgnomekbd (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed-bionic
Sebastien Bacher (seb128) wrote :

Using 3.26.0-3ubuntu0.18.10.1 the command from the testcase shows the layout without segfault, also trying with the IPA ibus method works now, marking as verified for cosmic

tags: added: verification-done-cosmic
removed: verification-needed-cosmic
Sebastien Bacher (seb128) wrote :

3.26.0-3ubuntu0.18.04.1 resolves the segfault/shows the correct keymap as well

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libgnomekbd - 3.26.0-3ubuntu0.18.10.1

---------------
libgnomekbd (3.26.0-3ubuntu0.18.10.1) cosmic; urgency=medium

  * debian/patches/bugzilla_invalid_layout_segfault_fix.patch:
    - backport a patch available on bugzilla to fix a segfault in the
      keyboard layout preview code. The most common case seems to be g-c-c
      trying to preview a 'default' layout which was working before some
      other fixes landed, that fixes the regression. (lp: #1721893)

 -- Sebastien Bacher <email address hidden> Thu, 22 Nov 2018 17:07:01 +0100

Changed in libgnomekbd (Ubuntu Cosmic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for libgnomekbd has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libgnomekbd - 3.26.0-3ubuntu0.18.04.1

---------------
libgnomekbd (3.26.0-3ubuntu0.18.04.1) bionic; urgency=medium

  * debian/patches/bugzilla_invalid_layout_segfault_fix.patch:
    - backport a patch available on bugzilla to fix a segfault in the
      keyboard layout preview code. The most common case seems to be g-c-c
      trying to preview a 'default' layout which was working before some
      other fixes landed, that fixes the regression. (lp: #1721893)

 -- Sebastien Bacher <email address hidden> Thu, 22 Nov 2018 17:07:01 +0100

Changed in libgnomekbd (Ubuntu Bionic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.