Writing in xournal lags or doesn't complete and selection boxes render incorrectly

Bug #284530 reported by Ed K on 2008-10-16
38
This bug affects 6 people
Affects Status Importance Assigned to Milestone
libgnomecanvas (Ubuntu)
Undecided
Joe Smith
Nominated for Intrepid by Ed K
libgnomecanvas (openSUSE)
Fix Released
Unknown
xournal (Ubuntu)
Undecided
Unassigned
Nominated for Intrepid by Ed K

Bug Description

Binary package hint: xournal

This may be a similar issue to https://bugs.launchpad.net/ubuntu/+source/xournal/+bug/199999, however the proposed workarounds (disabling xinput and discard core events) do not work. The writing lags, and when writing is rendered the display is only updated in choppy blocks. The writing actually inside the blocks doesn't appear jagged, it is rendered smoothly.

I've attached some screenshots which show the rendering errors. They are taken of the same document, and show both the incorrect rendering of strokes and selection boxes.

Description: Ubuntu intrepid (development branch)
Release: 8.10

xournal:
  Installed: 0.4.2.1-0.1ubuntu1
  Candidate: 0.4.2.1-0.1ubuntu1
  Version table:
 *** 0.4.2.1-0.1ubuntu1 0
        500 http://mirror.umoss.org intrepid/universe Packages
        100 /var/lib/dpkg/status

The output of Xournal itself is fairly uninteresting:

xxx@xxx:~$ xournal

(xournal:13089): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated

(xournal:13089): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated

Ed K (ekohlwey) wrote :
Hugh Eaves (hugh-hugheaves) wrote :

I have the same problem. For me, the problem only happens when the drawing area (page) is sized to be smaller than the xournal application window. If I resize the application window to be smaller than or the same size as the page, then xournal works correctly. Also, resizing the page (page zoom in or out) causes all the missing strokes to appear. It appears the strokes are being captured correctly, they're just not being rendered.

 I tried rebuilding xournal from source and disabling "ENABLE_XINPUT_BUGFIX", but it didn't help.

Vincenzo Ciancia (vincenzo-ml) wrote :

If I click with the mouse (not the pen) on the xournal window while the drawing area is smaller than the window, then it blocks and starts eating all my memory eventually trashing my system. If i use the pen I can't see this bug. Are you using the pen or the mouse? Are you using xinput or not?

Denis Auroux (auroux) wrote :

This is actually a problem not with xournal, but with libgnomecanvas -- I'm assuming there was a faulty update to libgnomecanvas in Ubuntu. This bug has first affected various versions of OpenSUSE, where it was first evidenced, then fixed, then reappeared...

https://bugzilla.novell.com/show_bug.cgi?id=425710
https://bugzilla.novell.com/show_bug.cgi?id=430785

The immediate solution is to get the libgnomecanvas packagers for Ubuntu to *not* include a patch called libgnomecanvas-no-tearing.diff, or to include an updated patch that can be found attached to the latter of the two bug-reports mentioned above.

Thanks,
Denis

Vincenzo Ciancia (vincenzo-ml) wrote :

Thanks to Denis (he is the upstream developer). Confirming in libgnomecanvas but I think we should leave the bug opened in xournal to prevent dupes.

Changed in libgnomecanvas:
status: New → Confirmed
Changed in libgnomecanvas:
status: Unknown → Fix Released
Ed K (ekohlwey) wrote :

Rebuilding libgnomecanvas with the aforementioned patch (https://bugzilla.novell.com/show_bug.cgi?id=430785) solved the issue for me. Simply replace the contents of 90_upstream_correctly_update.3.patch with the contents of the link.

Joe Smith (yasumoto7) wrote :

I'll see about whipping together a debdiff.

Changed in libgnomecanvas:
assignee: nobody → yasumoto7
laurentp (laurentpotvin) wrote :

How do you rebuild libgnomecanvas? The bug is still there. Sorry for the noob question, but I'm not really familiar in patching packages on Ubuntu. Thank you.

Sara (sfauzia) wrote :

This bug only effects me when I use maximus and window-picker applet from the official Netbook Remix PPA. If I use the ones in default Ubuntu repositories (for Intrepid) I don't have this problem.

Changed in libgnomecanvas:
status: Fix Released → Confirmed
Changed in libgnomecanvas:
status: Confirmed → Incomplete
Changed in libgnomecanvas:
status: Incomplete → In Progress
Changed in libgnomecanvas:
status: In Progress → Fix Released
Changed in libgnomecanvas:
status: Fix Released → Confirmed
Changed in libgnomecanvas (openSUSE):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.