package libglvnd-dev 1.0.0-2ubuntu2.1 failed to upgrade: trying to overwrite '/usr/lib/x86_64-linux-gnu/libGLESv1_CM.so', which is also in package nvidia-340 340.107-0ubuntu0~gpu18.04.1

Bug #1791542 reported by henczati on 2018-09-09
36
This bug affects 6 people
Affects Status Importance Assigned to Milestone
libglvnd (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned
nvidia-graphics-drivers-340 (Ubuntu)
High
Alberto Milone
Bionic
High
Alberto Milone

Bug Description

SRU Request:

[Impact]

The new libgles1 conflicts with nvidia-340 which ships it's own copy of libGLESv1_CM.so

[Test case]

Enable proposed, install libgles1 and nvidia-340, they should install fine.

[Regression potential]

none, just fixes a file conflict

--

Looks like I had a similar problem on 18.04.1 than https://bugs.launchpad.net/ubuntu/+source/libglvnd/+bug/1728352, just with nvidia-340 from https://launchpad.net/~graphics-drivers/+archive/ubuntu/ppa .

Apt output:
```
$ sudo apt dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following NEW packages will be installed:
  libgles1
The following packages will be upgraded:
  libegl1 libgl1 libgles2 libglvnd-core-dev libglvnd-dev libglvnd0 libglx0 libopengl0
8 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 268 kB of archives.
After this operation, 66,6 kB of additional disk space will be used.
Do you want to continue? [Y/n]
Get:1 http://archive.ubuntu.com/ubuntu bionic-proposed/main amd64 libglvnd-dev amd64 1.0.0-2ubuntu2.2 [3 408 B]
Get:2 http://archive.ubuntu.com/ubuntu bionic-proposed/main amd64 libglvnd-core-dev amd64 1.0.0-2ubuntu2.2 [12,9 kB]
Get:3 http://archive.ubuntu.com/ubuntu bionic-proposed/main amd64 libgles2 amd64 1.0.0-2ubuntu2.2 [17,4 kB]
Get:4 http://archive.ubuntu.com/ubuntu bionic-proposed/main amd64 libgl1 amd64 1.0.0-2ubuntu2.2 [84,8 kB]
Get:5 http://archive.ubuntu.com/ubuntu bionic-proposed/main amd64 libglx0 amd64 1.0.0-2ubuntu2.2 [28,1 kB]
Get:6 http://archive.ubuntu.com/ubuntu bionic-proposed/main amd64 libopengl0 amd64 1.0.0-2ubuntu2.2 [31,3 kB]
Get:7 http://archive.ubuntu.com/ubuntu bionic-proposed/main amd64 libegl1 amd64 1.0.0-2ubuntu2.2 [31,9 kB]
Get:8 http://archive.ubuntu.com/ubuntu bionic-proposed/main amd64 libglvnd0 amd64 1.0.0-2ubuntu2.2 [46,6 kB]
Get:9 http://archive.ubuntu.com/ubuntu bionic-proposed/main amd64 libgles1 amd64 1.0.0-2ubuntu2.2 [11,2 kB]
Fetched 268 kB in 0s (1 575 kB/s)
(Reading database ... 141610 files and directories currently installed.)
Preparing to unpack .../0-libglvnd-dev_1.0.0-2ubuntu2.2_amd64.deb ...
Unpacking libglvnd-dev:amd64 (1.0.0-2ubuntu2.2) over (1.0.0-2ubuntu2.1) ...
dpkg: error processing archive /tmp/apt-dpkg-install-Gq7kQI/0-libglvnd-dev_1.0.0-2ubuntu2.2_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/x86_64-linux-gnu/libGLESv1_CM.so', which is also in package nvidia-340 340.107-0ubuntu0~gpu18.04.1
Preparing to unpack .../1-libglvnd-core-dev_1.0.0-2ubuntu2.2_amd64.deb ...
Unpacking libglvnd-core-dev:amd64 (1.0.0-2ubuntu2.2) over (1.0.0-2ubuntu2.1) ...
Preparing to unpack .../2-libgles2_1.0.0-2ubuntu2.2_amd64.deb ...
Unpacking libgles2:amd64 (1.0.0-2ubuntu2.2) over (1.0.0-2ubuntu2.1) ...
Preparing to unpack .../3-libgl1_1.0.0-2ubuntu2.2_amd64.deb ...
Unpacking libgl1:amd64 (1.0.0-2ubuntu2.2) over (1.0.0-2ubuntu2.1) ...
Preparing to unpack .../4-libglx0_1.0.0-2ubuntu2.2_amd64.deb ...
Unpacking libglx0:amd64 (1.0.0-2ubuntu2.2) over (1.0.0-2ubuntu2.1) ...
Preparing to unpack .../5-libopengl0_1.0.0-2ubuntu2.2_amd64.deb ...
Unpacking libopengl0:amd64 (1.0.0-2ubuntu2.2) over (1.0.0-2ubuntu2.1) ...
Preparing to unpack .../6-libegl1_1.0.0-2ubuntu2.2_amd64.deb ...
Unpacking libegl1:amd64 (1.0.0-2ubuntu2.2) over (1.0.0-2ubuntu2.1) ...
Preparing to unpack .../7-libglvnd0_1.0.0-2ubuntu2.2_amd64.deb ...
Unpacking libglvnd0:amd64 (1.0.0-2ubuntu2.2) over (1.0.0-2ubuntu2.1) ...
Selecting previously unselected package libgles1:amd64.
Preparing to unpack .../8-libgles1_1.0.0-2ubuntu2.2_amd64.deb ...
Unpacking libgles1:amd64 (1.0.0-2ubuntu2.2) ...
dpkg: error processing archive /tmp/apt-dpkg-install-Gq7kQI/8-libgles1_1.0.0-2ubuntu2.2_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/x86_64-linux-gnu/libGLESv1_CM.so.1', which is also in package nvidia-340 340.107-0ubuntu0~gpu18.04.1
Errors were encountered while processing:
 /tmp/apt-dpkg-install-Gq7kQI/0-libglvnd-dev_1.0.0-2ubuntu2.2_amd64.deb
 /tmp/apt-dpkg-install-Gq7kQI/8-libgles1_1.0.0-2ubuntu2.2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
```

ProblemType: Package
DistroRelease: Ubuntu 18.04
Package: libglvnd-dev 1.0.0-2ubuntu2.1
ProcVersionSignature: Ubuntu 4.15.0-34.37-generic 4.15.18
Uname: Linux 4.15.0-34-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.20.9-0ubuntu7.3
Architecture: amd64
Date: Sun Sep 9 21:21:58 2018
DpkgTerminalLog:
 Preparing to unpack .../0-libglvnd-dev_1.0.0-2ubuntu2.2_amd64.deb ...
 Unpacking libglvnd-dev:amd64 (1.0.0-2ubuntu2.2) over (1.0.0-2ubuntu2.1) ...
 dpkg: error processing archive /tmp/apt-dpkg-install-Gq7kQI/0-libglvnd-dev_1.0.0-2ubuntu2.2_amd64.deb (--unpack):
  trying to overwrite '/usr/lib/x86_64-linux-gnu/libGLESv1_CM.so', which is also in package nvidia-340 340.107-0ubuntu0~gpu18.04.1
ErrorMessage: trying to overwrite '/usr/lib/x86_64-linux-gnu/libGLESv1_CM.so', which is also in package nvidia-340 340.107-0ubuntu0~gpu18.04.1
InstallationDate: Installed on 2018-09-05 (4 days ago)
InstallationMedia: Lubuntu 18.04.1 LTS "Bionic Beaver" - Release amd64 (20180903)
Python3Details: /usr/bin/python3.6, Python 3.6.5, python3-minimal, 3.6.5-3ubuntu1
PythonDetails: /usr/bin/python2.7, Python 2.7.15rc1, python-minimal, 2.7.15~rc1-1
RelatedPackageVersions:
 dpkg 1.19.0.5ubuntu2
 apt 1.6.3ubuntu0.1
SourcePackage: libglvnd
Title: package libglvnd-dev 1.0.0-2ubuntu2.1 failed to install/upgrade: trying to overwrite '/usr/lib/x86_64-linux-gnu/libGLESv1_CM.so', which is also in package nvidia-340 340.107-0ubuntu0~gpu18.04.1
UpgradeStatus: No upgrade log present (probably fresh install)

henczati (henczati) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libglvnd (Ubuntu Bionic):
status: New → Confirmed
Changed in libglvnd (Ubuntu):
status: New → Confirmed
Changed in nvidia-graphics-drivers-340 (Ubuntu Bionic):
status: New → Confirmed
Changed in nvidia-graphics-drivers-340 (Ubuntu):
status: New → Confirmed
Changed in nvidia-graphics-drivers-340 (Ubuntu):
status: Confirmed → In Progress
Changed in nvidia-graphics-drivers-340 (Ubuntu Bionic):
status: Confirmed → In Progress
Changed in nvidia-graphics-drivers-340 (Ubuntu):
importance: Undecided → High
Changed in nvidia-graphics-drivers-340 (Ubuntu Bionic):
importance: Undecided → High
Changed in nvidia-graphics-drivers-340 (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
Changed in nvidia-graphics-drivers-340 (Ubuntu Bionic):
assignee: nobody → Alberto Milone (albertomilone)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-graphics-drivers-340 - 340.107-0ubuntu2

---------------
nvidia-graphics-drivers-340 (340.107-0ubuntu2) cosmic; urgency=medium

  * debian/templates/nvidia-graphics-drivers.postrm.in,
    debian/templates/nvidia-graphics-drivers.preinst.in,
    debian/templates/nvidia-graphics-drivers.prerm.in:
    - Use diversions for "libGLESv1_CM.so" "libGLESv1_CM.so.1" (LP: #1791542).

 -- Alberto Milone <email address hidden> Mon, 10 Sep 2018 15:11:35 +0200

Changed in nvidia-graphics-drivers-340 (Ubuntu):
status: In Progress → Fix Released
Timo Aaltonen (tjaalton) on 2018-09-11
description: updated
description: updated

Hello henczati, or anyone else affected,

Accepted nvidia-graphics-drivers-340 into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/nvidia-graphics-drivers-340/340.107-0ubuntu0.18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in nvidia-graphics-drivers-340 (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-bionic
tags: added: verification-done-bionic
removed: verification-needed-bionic
ADFH (adfh) wrote :

I downloaded the nvidia-340 package from the link provided, dpkg -i'd it and then was able to "apt --fix-broken install" the updates to the gles packages that had been broken..

Thanks :)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers