package libglvnd-dev 1.0.0-2ubuntu2.1 failed to upgrade: trying to overwrite '/usr/lib/x86_64-linux-gnu/libGLESv1_CM.so', which is also in package nvidia-340 340.107-0ubuntu0~gpu18.04.1

Bug #1791542 reported by henczati on 2018-09-09
666
This bug affects 151 people
Affects Status Importance Assigned to Milestone
libglvnd (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned
nvidia-graphics-drivers-340 (Ubuntu)
High
Alberto Milone
Bionic
High
Alberto Milone

Bug Description

SRU Request:

[Impact]

The new libgles1 conflicts with nvidia-340 which ships it's own copy of libGLESv1_CM.so

[Test case]

Enable proposed, install libgles1 and nvidia-340, they should install fine.

[Regression potential]

none, just fixes a file conflict

--

Looks like I had a similar problem on 18.04.1 than https://bugs.launchpad.net/ubuntu/+source/libglvnd/+bug/1728352, just with nvidia-340 from https://launchpad.net/~graphics-drivers/+archive/ubuntu/ppa .

Apt output:
```
$ sudo apt dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following NEW packages will be installed:
  libgles1
The following packages will be upgraded:
  libegl1 libgl1 libgles2 libglvnd-core-dev libglvnd-dev libglvnd0 libglx0 libopengl0
8 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 268 kB of archives.
After this operation, 66,6 kB of additional disk space will be used.
Do you want to continue? [Y/n]
Get:1 http://archive.ubuntu.com/ubuntu bionic-proposed/main amd64 libglvnd-dev amd64 1.0.0-2ubuntu2.2 [3 408 B]
Get:2 http://archive.ubuntu.com/ubuntu bionic-proposed/main amd64 libglvnd-core-dev amd64 1.0.0-2ubuntu2.2 [12,9 kB]
Get:3 http://archive.ubuntu.com/ubuntu bionic-proposed/main amd64 libgles2 amd64 1.0.0-2ubuntu2.2 [17,4 kB]
Get:4 http://archive.ubuntu.com/ubuntu bionic-proposed/main amd64 libgl1 amd64 1.0.0-2ubuntu2.2 [84,8 kB]
Get:5 http://archive.ubuntu.com/ubuntu bionic-proposed/main amd64 libglx0 amd64 1.0.0-2ubuntu2.2 [28,1 kB]
Get:6 http://archive.ubuntu.com/ubuntu bionic-proposed/main amd64 libopengl0 amd64 1.0.0-2ubuntu2.2 [31,3 kB]
Get:7 http://archive.ubuntu.com/ubuntu bionic-proposed/main amd64 libegl1 amd64 1.0.0-2ubuntu2.2 [31,9 kB]
Get:8 http://archive.ubuntu.com/ubuntu bionic-proposed/main amd64 libglvnd0 amd64 1.0.0-2ubuntu2.2 [46,6 kB]
Get:9 http://archive.ubuntu.com/ubuntu bionic-proposed/main amd64 libgles1 amd64 1.0.0-2ubuntu2.2 [11,2 kB]
Fetched 268 kB in 0s (1 575 kB/s)
(Reading database ... 141610 files and directories currently installed.)
Preparing to unpack .../0-libglvnd-dev_1.0.0-2ubuntu2.2_amd64.deb ...
Unpacking libglvnd-dev:amd64 (1.0.0-2ubuntu2.2) over (1.0.0-2ubuntu2.1) ...
dpkg: error processing archive /tmp/apt-dpkg-install-Gq7kQI/0-libglvnd-dev_1.0.0-2ubuntu2.2_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/x86_64-linux-gnu/libGLESv1_CM.so', which is also in package nvidia-340 340.107-0ubuntu0~gpu18.04.1
Preparing to unpack .../1-libglvnd-core-dev_1.0.0-2ubuntu2.2_amd64.deb ...
Unpacking libglvnd-core-dev:amd64 (1.0.0-2ubuntu2.2) over (1.0.0-2ubuntu2.1) ...
Preparing to unpack .../2-libgles2_1.0.0-2ubuntu2.2_amd64.deb ...
Unpacking libgles2:amd64 (1.0.0-2ubuntu2.2) over (1.0.0-2ubuntu2.1) ...
Preparing to unpack .../3-libgl1_1.0.0-2ubuntu2.2_amd64.deb ...
Unpacking libgl1:amd64 (1.0.0-2ubuntu2.2) over (1.0.0-2ubuntu2.1) ...
Preparing to unpack .../4-libglx0_1.0.0-2ubuntu2.2_amd64.deb ...
Unpacking libglx0:amd64 (1.0.0-2ubuntu2.2) over (1.0.0-2ubuntu2.1) ...
Preparing to unpack .../5-libopengl0_1.0.0-2ubuntu2.2_amd64.deb ...
Unpacking libopengl0:amd64 (1.0.0-2ubuntu2.2) over (1.0.0-2ubuntu2.1) ...
Preparing to unpack .../6-libegl1_1.0.0-2ubuntu2.2_amd64.deb ...
Unpacking libegl1:amd64 (1.0.0-2ubuntu2.2) over (1.0.0-2ubuntu2.1) ...
Preparing to unpack .../7-libglvnd0_1.0.0-2ubuntu2.2_amd64.deb ...
Unpacking libglvnd0:amd64 (1.0.0-2ubuntu2.2) over (1.0.0-2ubuntu2.1) ...
Selecting previously unselected package libgles1:amd64.
Preparing to unpack .../8-libgles1_1.0.0-2ubuntu2.2_amd64.deb ...
Unpacking libgles1:amd64 (1.0.0-2ubuntu2.2) ...
dpkg: error processing archive /tmp/apt-dpkg-install-Gq7kQI/8-libgles1_1.0.0-2ubuntu2.2_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/x86_64-linux-gnu/libGLESv1_CM.so.1', which is also in package nvidia-340 340.107-0ubuntu0~gpu18.04.1
Errors were encountered while processing:
 /tmp/apt-dpkg-install-Gq7kQI/0-libglvnd-dev_1.0.0-2ubuntu2.2_amd64.deb
 /tmp/apt-dpkg-install-Gq7kQI/8-libgles1_1.0.0-2ubuntu2.2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
```

ProblemType: Package
DistroRelease: Ubuntu 18.04
Package: libglvnd-dev 1.0.0-2ubuntu2.1
ProcVersionSignature: Ubuntu 4.15.0-34.37-generic 4.15.18
Uname: Linux 4.15.0-34-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.20.9-0ubuntu7.3
Architecture: amd64
Date: Sun Sep 9 21:21:58 2018
DpkgTerminalLog:
 Preparing to unpack .../0-libglvnd-dev_1.0.0-2ubuntu2.2_amd64.deb ...
 Unpacking libglvnd-dev:amd64 (1.0.0-2ubuntu2.2) over (1.0.0-2ubuntu2.1) ...
 dpkg: error processing archive /tmp/apt-dpkg-install-Gq7kQI/0-libglvnd-dev_1.0.0-2ubuntu2.2_amd64.deb (--unpack):
  trying to overwrite '/usr/lib/x86_64-linux-gnu/libGLESv1_CM.so', which is also in package nvidia-340 340.107-0ubuntu0~gpu18.04.1
ErrorMessage: trying to overwrite '/usr/lib/x86_64-linux-gnu/libGLESv1_CM.so', which is also in package nvidia-340 340.107-0ubuntu0~gpu18.04.1
InstallationDate: Installed on 2018-09-05 (4 days ago)
InstallationMedia: Lubuntu 18.04.1 LTS "Bionic Beaver" - Release amd64 (20180903)
Python3Details: /usr/bin/python3.6, Python 3.6.5, python3-minimal, 3.6.5-3ubuntu1
PythonDetails: /usr/bin/python2.7, Python 2.7.15rc1, python-minimal, 2.7.15~rc1-1
RelatedPackageVersions:
 dpkg 1.19.0.5ubuntu2
 apt 1.6.3ubuntu0.1
SourcePackage: libglvnd
Title: package libglvnd-dev 1.0.0-2ubuntu2.1 failed to install/upgrade: trying to overwrite '/usr/lib/x86_64-linux-gnu/libGLESv1_CM.so', which is also in package nvidia-340 340.107-0ubuntu0~gpu18.04.1
UpgradeStatus: No upgrade log present (probably fresh install)

henczati (henczati) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libglvnd (Ubuntu Bionic):
status: New → Confirmed
Changed in libglvnd (Ubuntu):
status: New → Confirmed
Changed in nvidia-graphics-drivers-340 (Ubuntu Bionic):
status: New → Confirmed
Changed in nvidia-graphics-drivers-340 (Ubuntu):
status: New → Confirmed
Changed in nvidia-graphics-drivers-340 (Ubuntu):
status: Confirmed → In Progress
Changed in nvidia-graphics-drivers-340 (Ubuntu Bionic):
status: Confirmed → In Progress
Changed in nvidia-graphics-drivers-340 (Ubuntu):
importance: Undecided → High
Changed in nvidia-graphics-drivers-340 (Ubuntu Bionic):
importance: Undecided → High
Changed in nvidia-graphics-drivers-340 (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
Changed in nvidia-graphics-drivers-340 (Ubuntu Bionic):
assignee: nobody → Alberto Milone (albertomilone)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-graphics-drivers-340 - 340.107-0ubuntu2

---------------
nvidia-graphics-drivers-340 (340.107-0ubuntu2) cosmic; urgency=medium

  * debian/templates/nvidia-graphics-drivers.postrm.in,
    debian/templates/nvidia-graphics-drivers.preinst.in,
    debian/templates/nvidia-graphics-drivers.prerm.in:
    - Use diversions for "libGLESv1_CM.so" "libGLESv1_CM.so.1" (LP: #1791542).

 -- Alberto Milone <email address hidden> Mon, 10 Sep 2018 15:11:35 +0200

Changed in nvidia-graphics-drivers-340 (Ubuntu):
status: In Progress → Fix Released
Timo Aaltonen (tjaalton) on 2018-09-11
description: updated
description: updated

Hello henczati, or anyone else affected,

Accepted nvidia-graphics-drivers-340 into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/nvidia-graphics-drivers-340/340.107-0ubuntu0.18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in nvidia-graphics-drivers-340 (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-bionic
tags: added: verification-done-bionic
removed: verification-needed-bionic
ADFH (adfh) wrote :

I downloaded the nvidia-340 package from the link provided, dpkg -i'd it and then was able to "apt --fix-broken install" the updates to the gles packages that had been broken..

Thanks :)

Brian Talbot (beta2071) wrote :

Same here. New package from link above fixed the dependency issue with gles package.

Nish Aravamudan (nacc) on 2018-09-20
tags: added: verification-done
removed: verification-needed

Ran into the same issue, installed linked package for nvidia-340, then ran apt --fix-broken install and it worked. Thank you!

tvap (teemupa) wrote :

After installing the proposed nvidia-370.107 package, while running got few errors:

Setting up nvidia-340 (340.107-0ubuntu0.18.04.1) ...
dpkg: error: version '-' has bad syntax: revision number is empty
dpkg: error: version '-' has bad syntax: revision number is empty

Installation finished ok thought.

That is ok. It's not a regression, and it doesn't affect anything else.

On Fri, 21 Sep 2018 at 07:16, tvap <email address hidden> wrote:

> After installing the proposed nvidia-370.107 package, while running got
> few errors:
>
> Setting up nvidia-340 (340.107-0ubuntu0.18.04.1) ...
> dpkg: error: version '-' has bad syntax: revision number is empty
> dpkg: error: version '-' has bad syntax: revision number is empty
>
> Installation finished ok thought.
>
> --
> You received this bug notification because you are a bug assignee.
> https://bugs.launchpad.net/bugs/1791542
>
> Title:
> package libglvnd-dev 1.0.0-2ubuntu2.1 failed to upgrade: trying to
> overwrite '/usr/lib/x86_64-linux-gnu/libGLESv1_CM.so', which is also
> in package nvidia-340 340.107-0ubuntu0~gpu18.04.1
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/libglvnd/+bug/1791542/+subscriptions
>
> Launchpad-Notification-Type: bug
> Launchpad-Bug: distribution=ubuntu; sourcepackage=libglvnd;
> component=main; status=Confirmed; importance=Undecided; assignee=None;
> Launchpad-Bug: distribution=ubuntu;
> sourcepackage=nvidia-graphics-drivers-340; component=restricted; status=Fix
> Released; importance=High; <email address hidden>;
> Launchpad-Bug: distribution=ubuntu; distroseries=bionic;
> sourcepackage=libglvnd; component=main; status=Confirmed;
> importance=Undecided; assignee=None;
> Launchpad-Bug: distribution=ubuntu; distroseries=bionic;
> sourcepackage=nvidia-graphics-drivers-340; component=restricted; status=Fix
> Committed; importance=High; <email address hidden>;
> Launchpad-Bug-Tags: amd64 apport-package bionic verification-done
> verification-done-bionic
> Launchpad-Bug-Information-Type: Public
> Launchpad-Bug-Private: no
> Launchpad-Bug-Security-Vulnerability: no
> Launchpad-Bug-Commenters: adfh beta2071 henczati janitor joao-hipercubo
> teemupa tjaalton
> Launchpad-Bug-Reporter: henczati (henczati)
> Launchpad-Bug-Modifier: tvap (teemupa)
> Launchpad-Message-Rationale: Assignee
> Launchpad-Message-For: albertomilone
>

--
Alberto Milone

Eric (ericsantosbr2) wrote :

Even tho I've installed the driver proposed, my apt still looks for version 340.106 of the driver:

dpkg: erro ao processar o arquivo /var/cache/apt/archives/libgles1_1.0.0-2ubuntu2.2_amd64.deb (--unpack):
 a tentar sobre-escrever '/usr/lib/x86_64-linux-gnu/libGLESv1_CM.so.1', que também está no pacote nvidia-340 340.106-0ubuntu3

How can I remove it to be able to update my system?

Alket Rexhepi (alketii) wrote :

@Eric

Run:
sudo dpkg --configure -a
sudo apt-get dist-upgrade -f

Alket Rexhepi (alketii) wrote :

P.S.

Also:
sudo apt-get --fix-broken install

jfs (jfs+lp) wrote :

Enabling bionic-proposed and trying to install nvidia-340 does not fix the bug for me. The installation fails:

$ sudo apt-get install nvidia-340/bionic-proposed ~ 100 ↵

Reading package lists... Done
Building dependency tree
Reading state information... Done
Selected version '340.107-0ubuntu0.18.04.1' (Ubuntu:18.04/bionic-proposed [amd64]) for 'nvidia-340'
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 libglvnd-dev : Depends: libglvnd0 (= 1.0.0-2ubuntu2.1) but 1.0.0-2ubuntu2.2 is to be installed
                Depends: libglvnd-core-dev (= 1.0.0-2ubuntu2.1) but 1.0.0-2ubuntu2.2 is to be installed
                Depends: libegl1 (= 1.0.0-2ubuntu2.1) but 1.0.0-2ubuntu2.2 is to be installed
                Depends: libgles2 (= 1.0.0-2ubuntu2.1) but 1.0.0-2ubuntu2.2 is to be installed
                Depends: libgl1 (= 1.0.0-2ubuntu2.1) but 1.0.0-2ubuntu2.2 is to be installed
                Depends: libglx0 (= 1.0.0-2ubuntu2.1) but 1.0.0-2ubuntu2.2 is to be installed
                Depends: libopengl0 (= 1.0.0-2ubuntu2.1) but 1.0.0-2ubuntu2.2 is to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

The --fix-broken command also fails:

sudo apt --fix-broken install ~ 100 ↵
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following additional packages will be installed:
  libgles1 libglvnd-dev
The following NEW packages will be installed:
  libgles1
The following packages will be upgraded:
  libglvnd-dev
1 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/14.6 kB of archives.
After this operation, 66.6 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Reading changelogs... Done
(Reading database ... 415186 files and directories currently installed.)
Preparing to unpack .../libgles1_1.0.0-2ubuntu2.2_amd64.deb ...
Unpacking libgles1:amd64 (1.0.0-2ubuntu2.2) ...
dpkg: error processing archive /var/cache/apt/archives/libgles1_1.0.0-2ubuntu2.2_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/x86_64-linux-gnu/libGLESv1_CM.so.1', which is also in package nvidia-340 340.106-0ubuntu3
Preparing to unpack .../libglvnd-dev_1.0.0-2ubuntu2.2_amd64.deb ...
Unpacking libglvnd-dev:amd64 (1.0.0-2ubuntu2.2) over (1.0.0-2ubuntu2.1) ...
dpkg: error processing archive /var/cache/apt/archives/libglvnd-dev_1.0.0-2ubuntu2.2_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/x86_64-linux-gnu/libGLESv1_CM.so', which is also in package nvidia-340 340.106-0ubuntu3
Errors were encountered while processing:
 /var/cache/apt/archives/libgles1_1.0.0-2ubuntu2.2_amd64.deb
 /var/cache/apt/archives/libglvnd-dev_1.0.0-2ubuntu2.2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

tags: added: verification-failed-bionic

I downloaded the nvidia-340 driver from the link provided, installed the driver, fixed the broken packages and after that everything worked fine.

Download full text (3.6 KiB)

I've enabled -proposed as suggested above to get 340.107 instead, put running dpkg --fix-broken install still results in the following output:

Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  gir1.2-osmgpsmap-1.0 libosmgpsmap-1.0-1 python3-dateutil
  python3-requests-oauthlib
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  libgles1 libglvnd-dev
The following NEW packages will be installed:
  libgles1
The following packages will be upgraded:
  libglvnd-dev
1 upgraded, 1 newly installed, 0 to remove and 157 not upgraded.
Need to get 0 B/14.6 kB of archives.
After this operation, 66.6 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
(Reading database ... 687305 files and directories currently installed.)
Preparing to unpack .../libgles1_1.0.0-2ubuntu2.2_amd64.deb ...
Unpacking libgles1:amd64 (1.0.0-2ubuntu2.2) ...
dpkg: error processing archive /var/cache/apt/archives/libgles1_1.0.0-2ubuntu2.2_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/x86_64-linux-gnu/libGLESv1_CM.so.1', which is also in package nvidia-340 340.106-0ubuntu3
Preparing to unpack .../libglvnd-dev_1.0.0-2ubuntu2.2_amd64.deb ...
Unpacking libglvnd-dev:amd64 (1.0.0-2ubuntu2.2) over (1.0.0-2ubuntu2.1) ...
dpkg: error processing archive /var/cache/apt/archives/libglvnd-dev_1.0.0-2ubuntu2.2_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/x86_64-linux-gnu/libGLESv1_CM.so', which is also in package nvidia-340 340.106-0ubuntu3
Errors were encountered while processing:
 /var/cache/apt/archives/libgles1_1.0.0-2ubuntu2.2_amd64.deb
 /var/cache/apt/archives/libglvnd-dev_1.0.0-2ubuntu2.2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
nightstallion@Mimir:~/Downloads$ sudo apt --fix-broken install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  gir1.2-osmgpsmap-1.0 libosmgpsmap-1.0-1 python3-dateutil
  python3-requests-oauthlib
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  libgles1 libglvnd-dev
The following NEW packages will be installed:
  libgles1
The following packages will be upgraded:
  libglvnd-dev
1 upgraded, 1 newly installed, 0 to remove and 157 not upgraded.
Need to get 0 B/14.6 kB of archives.
After this operation, 66.6 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
(Reading database ... 687305 files and directories currently installed.)
Preparing to unpack .../libgles1_1.0.0-2ubuntu2.2_amd64.deb ...
Unpacking libgles1:amd64 (1.0.0-2ubuntu2.2) ...
dpkg: error processing archive /var/cache/apt/archives/libgles1_1.0.0-2ubuntu2.2_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/x86_64-linux-gnu/libGLESv1_CM.so.1', which is also in package nvidia-340 340.106-0ubuntu3
Preparing to unpack .../libglvnd-dev_1.0.0-2ubuntu2.2_amd64.deb ...
Unpacking libglvnd-dev:amd64 (1.0.0-2ubuntu2.2) ove...

Read more...

Also, sudo dpkg --configure -a (which was suggested above) yields the following:

Processing triggers for libc-bin (2.27-3ubuntu1) ...
/sbin/ldconfig.real: Warning: ignoring configuration file that cannot be opened: /etc/ld.so.conf.d/nvidia_settings.conf: No such file or directory

Help?

Okay, manually installing version the .deb of 340.107 did seem to work, but

/sbin/ldconfig.real: Warning: ignoring configuration file that cannot be opened: /etc/ld.so.conf.d/nvidia_settings.conf: No such file or directory

remained as an error even afterwards. Should I be worried about that?

jfs (jfs+lp) wrote :

Installing using `sudo apt-get install nvidia-340/bionic-proposed` + `apt --fix-broken install` fails (as shown above in my comment).

Downloading the nvidia-340_340.107-0ubuntu0.18.04.1_amd64.deb file (after enabling bionic-proposed https://wiki.ubuntu.com/Testing/EnableProposed ):

  $ apt download nvidia-340/bionic-proposed

and installing it using:

  $ sudo dpkg -i nvidia-340_340.107-0ubuntu0.18.04.1_amd64.deb

succeeds.

To fix the previous failed installation, I've run:

  $ sudo apt-get install -f

apt seems to be working now.

tags: removed: verification-failed-bionic
Kern Sibbald (kern) wrote :

Could you give me a simple command with complete syntax to download the new nvidia-340 driver for 18.04?

I tried the following:

apt download nvidia-340/bionic-proposed
E: Release 'bionic-proposed' for 'nvidia-340' was not found

Kern Sibbald (kern) wrote :

Never mind my previous question #22. I just had to enable the use of bionic-proposal, then the procedures worked. However, they generated a number of worrisome error messages. In any case, I am now able to use apt on my system again. :-)

Magnus (ale-carrazzoni) wrote :

I did what jfs did and it fixed everything :)

Wolf Geldmacher (wolf-womaro) wrote :

Fixed it for me.

BSA (b-s-a) wrote :

2 errors (warnings) while install:

dpkg: error: version '-' has bad syntax: revision number is empty
dpkg: error: version '-' has bad syntax: revision number is empty

Bao Nguyen (baona119) wrote :

It fixed the problem for me.

Boris Malkov (hikari968) wrote :

Proposed package 340.107-0ubuntu0.18.04.1 from #7 fixed the problem for me after manual download and install with dpkg.

This also fixed it for me.

Andres Muniz (andresmp) wrote :

Tried #21 might have taken a wrong turn but it did not work for me. CLI history.

bata pete (betelanus) wrote :

Worked for me thanx :D

Jay Foster (jayf0ster) wrote :

I cannot get my apt system to work again. I tried adding the bionic-proposed repository as indicated in the link (above), but when I try the 'sudo apt --fix-broken install', it still wants to install the broken libgles1 and libglvnd-dev packages, which fail (as before).

Please, could someone provide step by step command line instructions on how to get a working apt system again.

GU (guido-ueffing) wrote :

comment #21 worked for me.
https://bugs.launchpad.net/ubuntu/+source/libglvnd/+bug/1791542/comments/21

----------------------------------

had to add this line to `/etc/apt/sources.list`:

~~~
deb http://archive.ubuntu.com/ubuntu/ bionic-proposed restricted main multiverse universe
~~~

then

~~~bash
# apt update; cd /tmp/; apt download nvidia-340/bionic-proposed; dpkg -i nvidia-340_340.107-0ubuntu0.18.04.1_amd64.deb; apt-get install -f;
~~~

Jay Foster (jayf0ster) wrote :

Thanks, GU. Your instructions worked. I did not the following dpkg errors when installing the nvidia driver:

Unpacking nvidia-340 (340.107-0ubuntu0.18.04.1) over (340.106-0ubuntu3) ...
Setting up nvidia-340 (340.107-0ubuntu0.18.04.1) ...
dpkg: error: version '-' has bad syntax: revision number is empty
dpkg: error: version '-' has bad syntax: revision number is empty
update-initramfs: deferring update (trigger activated)
INFO:Enable nvidia-340

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-graphics-drivers-340 - 340.107-0ubuntu0.18.04.1

---------------
nvidia-graphics-drivers-340 (340.107-0ubuntu0.18.04.1) bionic; urgency=medium

  * New upstream release:
    - Added support for X.Org xserver ABI 24 (xorg-server 1.20).
    - Improved nvidia-bug-report.sh to check for kern.log which is
      the default kernel log-file location for many Debian-based
      Linux distributions.
    - Fixed a bug which could cause X servers that export a Video
      Driver ABI earlier than 0.8 to crash when running X11
      applications which call XRenderAddTraps().
  * debian/substvars:
    - Add support for ABI 24.
  * debian/templates/nvidia-graphics-drivers.postrm.in,
    debian/templates/nvidia-graphics-drivers.preinst.in,
    debian/templates/nvidia-graphics-drivers.prerm.in:
    - Use diversions for "libGLESv1_CM.so" "libGLESv1_CM.so.1" (LP: #1791542).
  * debian/rules,
    debian/templates/nvidia-graphics-drivers.dirs.in,
    debian/templates/nvidia-graphics-drivers.postinst.in:
    - Install the modprobe file in /lib, and remove the blacklist
      file manually (LP: #1761593).

 -- Alberto Milone <email address hidden> Tue, 11 Sep 2018 15:04:03 +0200

Changed in nvidia-graphics-drivers-340 (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for nvidia-graphics-drivers-340 has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Timo Aaltonen (tjaalton) on 2018-11-06
Changed in libglvnd (Ubuntu Bionic):
status: Confirmed → Invalid
Changed in libglvnd (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.