gksu crashed with SIGSEGV in fputs()

Bug #898874 reported by Addamaccada on 2011-12-02
356
This bug affects 66 people
Affects Status Importance Assigned to Milestone
libgksu (Ubuntu)
High
Martin Pitt
Precise
High
Martin Pitt

Bug Description

It seems every run of gksu is now crashing. Just "gksu true" reproduces this.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: gksu 2.0.2-6ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-2.6-generic 3.2.0-rc3
Uname: Linux 3.2.0-2-generic i686
NonfreeKernelModules: nvidia
ApportVersion: 1.90-0ubuntu1
Architecture: i386
Date: Fri Dec 2 00:39:32 2011
ExecutablePath: /usr/bin/gksu
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110705.1)
ProcCmdline: /usr/bin/gksu --message <span\ weight="bold"\ size="larger">Please\ enter\ your\ password\ to\ access\ problem\ reports\ of\ system\ programs</span> /usr/share/apport/apport-gtk
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x356321: mov (%eax),%ecx
 PC (0x00356321) ok
 source "(%eax)" (0x00000000) not located in a known VMA region (needed readable region)!
 destination "%ecx" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: gksu
StacktraceTop:
 ?? () from /lib/i386-linux-gnu/libc.so.6
 fputs () from /lib/i386-linux-gnu/libc.so.6
 gksu_sudo_fuller () from /usr/lib/libgksu2.so.0
 gksu_run_fuller () from /usr/lib/libgksu2.so.0
 ?? ()
Title: gksu crashed with SIGSEGV in fputs()
UpgradeStatus: Upgraded to precise on 2011-12-02 (0 days ago)
UserGroups: adm admin cdrom debian-tor dialout lpadmin mythtv plugdev sambashare

Addamaccada (adematthews) wrote :

StacktraceTop:
 __strlen_ia32 () at ../sysdeps/i386/i686/multiarch/../../i586/strlen.S:99
 __GI__IO_fputs (str=0x0, fp=0x458460) at iofputs.c:37
 gksu_sudo_fuller (context=0x9a7a668, ask_pass=0x2d5fe0 <su_ask_password>, ask_pass_data=0x0, pass_not_needed=0x2d46e0 <no_pass>, pass_not_needed_data=0x0, exit_status=0xbf99451f "", error=0xbf994510) at /usr/include/i386-linux-gnu/bits/stdio2.h:98
 gksu_run_fuller (context=0x9a7a668, ask_pass=0, ask_pass_data=0x0, pass_not_needed=0, pass_not_needed_data=0x0, exit_status=0xbf99451f "", error=0xbf994510) at libgksu.c:3254
 main (argc=4, argv=0xbf9945d4) at gksu.c:757

Changed in gksu (Ubuntu):
importance: Undecided → Medium
summary: - gksu crashed with SIGSEGV in fputs()
+ gksu crashed with SIGSEGV in __strlen_ia32()
tags: removed: need-i386-retrace

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gksu (Ubuntu):
status: New → Confirmed
Martin Pitt (pitti) on 2011-12-02
visibility: private → public
Martin Pitt (pitti) on 2011-12-06
Changed in gksu (Ubuntu):
status: Confirmed → Triaged
milestone: none → precise-alpha-2
importance: Medium → High
Martin Pitt (pitti) on 2011-12-06
Changed in gksu (Ubuntu Precise):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
description: updated
summary: - gksu crashed with SIGSEGV in __strlen_ia32()
+ gksu crashed with SIGSEGV in fputs()
Martin Pitt (pitti) on 2011-12-07
Changed in gksu (Ubuntu Precise):
status: Triaged → In Progress
assignee: Canonical Desktop Team (canonical-desktop-team) → Martin Pitt (pitti)
Martin Pitt (pitti) on 2011-12-07
affects: gksu (Ubuntu Precise) → libgksu (Ubuntu Precise)
Changed in libgksu (Ubuntu Precise):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libgksu - 2.0.13~pre1-5ubuntu2

---------------
libgksu (2.0.13~pre1-5ubuntu2) precise; urgency=low

  * 02_format-security.patch: The previous fix exposed a logic flaw which
    caused a NULL pointer crash if calling sudo was successful. Fix this.
    (LP: #898874)
 -- Martin Pitt <email address hidden> Wed, 07 Dec 2011 11:04:25 +0100

Changed in libgksu (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers