no second attempt and no feedback when wrong password entered

Bug #298217 reported by Ryan Thompson on 2008-11-14
478
This bug affects 86 people
Affects Status Importance Assigned to Milestone
libgksu (Debian)
Fix Released
Unknown
libgksu (Ubuntu)
Medium
Unassigned
Declined for Karmic by Clint Byrum
Lucid
Undecided
Unassigned
Natty
Undecided
Unassigned

Bug Description

IMPACT: Users that mistype their password in gksu do not get any feedback, the application is never started.

FIX: The parsing in libgksu has been changed to only ignore a line with a single newline and will respect non empty lines as valid answer.

REPRODUCE: Start a new terminal, run 'gksu ls /' and mistype the user password.

DISCUSSION: Regression potential is low, as the patch still discards lines with merely a newline.

ORIGINAL DESCRIPTION:
When starting, for example, Synaptic Package Manager, the password dialog that is presented only allows one attempt. If the wrong password is entered, the dialog simply disappears, and nothing else happens. This is confusing, and also annoying, since I then have to go through the menus again to selecte Synaptic a second time.

Related branches

Arnaud Soyez (weboide) wrote :

I do not have this behaviour with Intrepid 8.10 and gksudo 2.0.0-5ubuntu3.

When i hit a wrong password, it asks me again saying I entered a wrong password and that I should try again.

Sebastien Bacher (seb128) wrote :

thank you for your bug report, what ubuntu version do you use?

Changed in gksu (Ubuntu):
importance: Undecided → Low
Ryan Thompson (rct86) wrote :

Ubuntu Jaunty including updates & proposed.

$ apt-cache policy gksu
gksu:
  Installed: 2.0.2-1ubuntu2
  Candidate: 2.0.2-1ubuntu2
  Version table:
 *** 2.0.2-1ubuntu2 0
        500 http://ubuntu.media.mit.edu jaunty/main Packages
        100 /var/lib/dpkg/status

If you have any other console commands to show relevant versions, I can put those in too.

I should also clarify a few things. First, Synaptic was just an example. This happens any time the gksu prompt appears. Second, I have thinkfinger integration enabled (via /usr/lib/pam-thinkfinger/pam-thinkfinger-enable), and gksu also gives up after a single finger swipe.

Dmitry Tantsur (divius) wrote :

Still valid for Lucid: 2.0.2-2ubuntu1

I'm also having this problem

xpd259@Mars:~/Workspaces/hb-trunk$ apt-cache policy gksu
gksu:
  Installed: 2.0.2-2ubuntu2
  Candidate: 2.0.2-2ubuntu2
  Version table:
 *** 2.0.2-2ubuntu2 0
        500 http://gb.archive.ubuntu.com/ubuntu/ lucid/main Packages
        100 /var/lib/dpkg/status

I feel the bug in Lucid is a regression. I do not have this problem in an up-to-date Ubuntu 9.10. If I type in an incorrect password, a new screen comes up stating that I've entered an incorrect password and prompting me to try again. In Lucid, I don't get the second prompt.

David Clayton (dcstar) wrote :

I can confirm that my 9.04 system works correctly with an "Incorrect password... try again" message, but in 10.04 there is no opportunity to re-enter the password and gain su access once you enter an incorrect password.

Nobuto Murata (nobuto) on 2010-03-30
tags: added: regression-potential
Nobuto Murata (nobuto) on 2010-03-30
summary: - Password dialog gives up with no indication after one failed attempt
+ no second attempt and no feedback when wrong password entered
tekstr1der (tekstr1der) on 2010-03-31
Changed in gksu (Ubuntu):
status: New → Confirmed
tekstr1der (tekstr1der) wrote :

This is indeed a regression from previous release functionality.

tags: added: iso-testing
mathew Howell (mhowell3002) wrote :

This is still occurring in Lucid with all updates applied. (gksu 2.0.2-2ubuntu2)

However, if 'gksu-properties' is run and Authentication mode is changed from 'su' to 'sudo' , the expected behaviour of prompting three times for a password occurs.

mathew Howell (mhowell3002) wrote :

Apologies, it should read if you swap 'sudo' to 'su'.

Michael Reinsch (mr-uue) wrote :

On the command line, you see the following when entering a wrong password:

$ gksu --description /usr/share/applications/synaptic.desktop /usr/sbin/synaptic
GNOME_SUDO_PASSSorry, try again.
sudo: 3 incorrect password attempts

This is with current 10.04 and pretty annoying.

arab80ps (arab89ps) wrote :

arab@arab-laptop:~$ gksu nautilus
GNOME_SUDO_PASSSorry, try again.
sudo: 3 incorrect password attempts

Aaron Lebahn (cplusplus328) wrote :

I still have this problem in the final release.

C de-Avillez (hggdh2) on 2010-05-06
description: updated
tekstr1der (tekstr1der) wrote :

As this bug is a regression, is it possible there could still be a fix submitted as a SRU?

This is not a bug in gksu, at least not as of Lucid. It is a bug in sudo. Downgrading sudo to the version in the Karmic-Updates repository fixes this problem. However downgrading the gksu package does not fix it, indicating the issue is with the sudo package alone.

David Clayton (dcstar) wrote :

I can confirm that downgrading as described in post #15 does fix this issue on my 64-bit 10.04 system.

Gary M (garym) on 2010-05-26
Changed in sudo (Ubuntu):
status: New → Confirmed
tags: added: regression-release
removed: regression-potential
Jonas (jonas-f-henriksen) wrote :

For long time ubuntu users, that are used to each new release bringing new bugs where things previously worked nice, this might not present a big problem. However, I think it will be very confusing to new users. Not sure whats the criteria for the importance-settings of bugs, but I think bugs like this, that will actually affect all users of the system, should have higher importance.

ArielEnter (del-valle-ariel) wrote :

I have updated and the problem still persist. Hope the Ubuntu team is working to fix it soon.

Giorgi Maghlakelidze (dracid) wrote :

I confirm this. 10.04 LTS x64 system.
Indeed, this bug should have a higher importance.

las (bandara-ls) wrote :

Present in 10.10 too

Corey B. (cbodendein) wrote :

Ubuntu 10.04 amd64, this bug is very annoying.

Jean-Peer Lorenz (peer.loz) wrote :

@Sebastien Bacher: Why is it declined for Maverick?

tekstr1der (tekstr1der) wrote :

@Sebastien: For that matter, why is this declined for Lucid? As a regression bug, the fix should surely be SRU'd into an LTS release.

Will there be no fix forthcoming?

Martin Pitt (pitti) on 2010-09-15
Changed in gksu (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
status: Confirmed → In Progress
importance: Low → Medium
Martin Pitt (pitti) on 2010-09-15
Changed in sudo (Ubuntu):
status: Confirmed → Invalid
affects: gksu (Ubuntu) → libgksu (Ubuntu)
Martin Pitt (pitti) wrote :

I think this will make a fine SRU, it's a simple patch.

Changed in libgksu (Ubuntu Lucid):
status: New → Triaged
Martin Pitt (pitti) wrote :

libgksu (2.0.10-1ubuntu2) maverick; urgency=low

  * 20_better_usleep.patch: Drop *.rej file part, which causes problems on
    clean.
  * Add 23_sudo_wrong_pwd_check.patch: Be more careful when checking the
    "wrong password" output, there might be a new prompt before. (LP: #298217)

 -- Martin Pitt <email address hidden> Thu, 16 Sep 2010 00:52:49 +0200

Changed in libgksu (Ubuntu Maverick):
status: In Progress → Fix Released
Changed in sudo (Ubuntu Lucid):
status: New → Invalid
Changed in libgksu (Ubuntu Lucid):
assignee: nobody → Martin Pitt (pitti)
Martin Pitt (pitti) wrote :

Sorry, this is the correct changelog for Maverick:

libgksu (2.0.13~pre1-1ubuntu5) maverick; urgency=low

  * Add 27_sudo_wrong_pwd_check.patch: Be more careful when checking the
    "wrong password" output, there might be a new prompt before. (LP: #298217)

 -- Martin Pitt <email address hidden> Thu, 16 Sep 2010 01:04:43 +0200

Martin Pitt (pitti) wrote :

uploaded to lucid-proposed, this now needs an ACK from another SRU team member.

Changed in libgksu (Ubuntu Lucid):
status: Triaged → Fix Committed

I compiled libgksu 2.0.13~pre1-1ubuntu5 from source on Lucid, and the problem persists.

Martin Pitt (pitti) wrote :

Twisted Lincoln,

the update hasn't been accepted yet.

Accepted libgksu into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
tekstr1der (tekstr1der) wrote :

Tested libgksu from lucid-proposed. This appears to have fixed the issue. gksu is now prompting when an incorrect password is entered.

Thank you so much Martin. I love to see regression fixes!

Martin Pitt (pitti) on 2010-09-27
tags: added: verification-done
removed: verification-needed

I just tested the libgksu package from lucid-proposed (now that it is there for real...). It fixed the issue on a fresh install of lucid, but on two of my machines with existing installs, the problem persists.

Any idea where the inconsistency could be? Both of the existing installs were upgrades from Karmic.

Martin Pitt (pitti) wrote :

twistedlincoln,

first, please check with

  dpkg -l libgksu2-0

that you really have 2.0.13~pre1-1ubuntu4.1 installed. If that's the case, please do

  gksu -d whoami

then enter a wrong password, and copy&paste the entire output of the command here.

Thanks!

Jane Atkinson (irihapeti) wrote :

@Martin:

I have the same problem as Twisted Lincoln. My installation of Lucid was a clean install.

Current version of libgksu2-0 is 2.0.13~pre1-1ubuntu4.1

Output from gksu -d whoami is:

No ask_pass set, using default!
xauth: /tmp/libgksu-raKlv9/.Xauthority
STARTUP_ID: gksu/whoami/3503-0-ja-desktop_TIME21500095
cmd[0]: /usr/bin/sudo
cmd[1]: -H
cmd[2]: -S
cmd[3]: -p
cmd[4]: GNOME_SUDO_PASS
cmd[5]: -u
cmd[6]: root
cmd[7]: --
cmd[8]: whoami
buffer: -GNOME_SUDO_PASS-
brute force GNOME_SUDO_PASS ended...
Yeah, we're in...
xauth: /tmp/libgksu-raKlv9/.Xauthority
xauth_env: /var/run/gdm/auth-for-ja-naBCR8/database
dir: /tmp/libgksu-raKlv9

Jane Atkinson (irihapeti) wrote :

Update:
gksu is behaving correctly on my EeePC, which is an Openbox system built up from a command-line install. Not sure what would be causing the difference.

Jean-Peer Lorenz (peer.loz) wrote :

Same for me: issue is fixed on Maverick though still exists on Ubuntu Lucid (several times upgraded from Hardy over Jaunty...). Attached is gksu output on Lucid.

Indeed, the correct package is installed according to "dpkg -l libgksu2-0"

The results of "gksu -d whoami" is attached.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libgksu - 2.0.13~pre1-1ubuntu4.1

---------------
libgksu (2.0.13~pre1-1ubuntu4.1) lucid-proposed; urgency=low

  * Add 27_sudo_wrong_pwd_check.patch: Be more careful when checking the
    "wrong password" output, there might be a new prompt before. (LP: #298217)
 -- Martin Pitt <email address hidden> Thu, 16 Sep 2010 01:04:43 +0200

Changed in libgksu (Ubuntu Lucid):
status: Fix Committed → Fix Released

As stated by myself and Jean-Peer Lorenz, this bug is NOT fixed on Lucid systems that have been upgraded from previous versions.

What other info do you need from us to help fix this?

much0 (much0) on 2010-10-07
Changed in libgksu (Ubuntu Lucid):
status: Fix Released → Opinion
status: Opinion → Fix Released

I believe I have found the solution to users that have upgraded from previous versions to Lucid:

arab80ps reported above that typing "gksu natuilus" and entering the wrong password returned the following for him:

GNOME_SUDO_PASSSorry, try again.
sudo: 3 incorrect password attempts

For me, it returns:

GNOME_SUDO_PASSGNOME_SUDO_PASSSorry, try again.
sudo: 3 incorrect password attempts

Thus changing line 14 of the "27_sudo_wrong_pwd_check.patch" that was recently added to libgksu from:

+ if (g_str_has_prefix (buffer, "Sorry, try again.") || g_str_has_prefix (buffer, "GNOME_SUDO_PASSSorry, try again."))

to

+ if (g_str_has_prefix (buffer, "Sorry, try again.") || g_str_has_prefix (buffer, "GNOME_SUDO_PASSGNOME_SUDO_PASSSorry, try again.") || g_str_has_prefix (buffer, "GNOME_SUDO_PASSSorry, try again."))

and recompiling and reinstalling the resulting deb fixes the issue for me. I have tested this fix on a fresh lucid install as well, and the fix works there too.

Since this issue at present is a regression for those upgrading to Lucid (and presumably Maverick as well), it is my hope that this trivial fix could be incorporated officially ASAP, provided it can be confirmed by others as fixing the problem.

Changed in libgksu (Debian):
status: Unknown → New
tekstr1der (tekstr1der) wrote :

Unfortunately, this is no longer working correctly. This is on a clean install of Lucid with

libgksu2-0:
  Installed: 2.0.13~pre1-1ubuntu4.1

:~$ gksu -d whoami
No ask_pass set, using default!
xauth: /tmp/libgksu-vatwCy/.Xauthority
STARTUP_ID: gksu/whoami/2727-0-valhalla_TIME11925681
cmd[0]: /usr/bin/sudo
cmd[1]: -H
cmd[2]: -S
cmd[3]: -p
cmd[4]: GNOME_SUDO_PASS
cmd[5]: -u
cmd[6]: root
cmd[7]: --
cmd[8]: whoami
buffer: -GNOME_SUDO_PASS-
brute force GNOME_SUDO_PASS ended...
Yeah, we're in...
sudo: 3 incorrect password attempts
 try again.
xauth: /tmp/libgksu-vatwCy/.Xauthority
xauth_env: /var/run/gdm/auth-for-marc-2BxVtr/database
dir: /tmp/libgksu-vatwCy

Any news on if anyone else has confirmed my fix in post #40?

David Clayton (dcstar) wrote :

The function works correctly on my 10.04 system (using Lucid proposed and backports repositories) with the same libgksu2-0 version as in post #41.

I get prompted 3 times with bad passwords, then get the "wrong password" message. Logging in with a good password works correctly and the sudo password is cached until either the timeout period or a "sudo -K" is done.

LAZA (laza74) wrote :

If gparted uses the same file it isn't working!

Cas (calumlind) wrote :

https://bugs.launchpad.net/ubuntu/+source/libgksu/+bug/298217/comments/40

Thanks your updated patch works for me on Maverick!

The previous update 2.0.13~pre1-1ubuntu5 did nothing to fix the issue but decided to get my hands dirty when i saw your request for testing. Found patching a deb not as difficult as I thought it might be :D

Jean-Peer Lorenz (peer.loz) wrote :

>As stated by myself and Jean-Peer Lorenz, this bug is NOT fixed on Lucid systems that have been upgraded from previous
>versions.
>
>What other info do you need from us to help fix this?

Still not fixed. Should I reopen it?

LAZA (laza74) wrote :

Yes, that would be nice!

tekstr1der (tekstr1der) wrote :

This bug continues on... now affecting natty 11.04 release as well.

tekstr1der (tekstr1der) on 2011-04-28
tags: removed: iso-testing verification-done
Corey B. (cbodendein) wrote :

I too have seen this bug resurface in Natty on 3 different machines, all fresh installs.

Gerhard Burger (burger.ga) wrote :

can confirm for up-to-date natty as well

Felix Dreissig (f30) wrote :

Confirmed for natty, see #773284 and various duplicates.

For convenience (so Launchpad makes a URL out of it), Felix is referring to "bug 773284".

tags: added: iso-testing
fgcwatt (fgcwatt) wrote :

Confirmed for up-to-date natty

mstfa cmly (mstfacmly) wrote :

Tested and confirmed for Natty as of August 2nd.

Bug 773284 has recently been marked a duplicate of this bug. Does that mean this bug should be reopened for releases where it is occurring again? (Or is bug 773284 to be considered separate from this?)

tekstr1der (tekstr1der) wrote :

Now that both bug #773284 AND bug #777136 have been marked duplicates of this old report, will someone with the launchpad credentials to alter the status please update the status of libgksu (Ubuntu) to "New" or "Confirmed", or "Triaged"??

Duplicate Bug #773284 was triaged by Robert Roth (evfool) on 06-01-2011 with medium importance.

This issue has been confirmed as a bug repeatedly for a current, up-to-date Natty 11.04

Martin Pitt (pitti) on 2011-08-09
Changed in libgksu (Ubuntu Natty):
status: New → Confirmed
Changed in libgksu (Ubuntu):
status: Fix Released → Confirmed
assignee: Martin Pitt (pitti) → nobody
Changed in sudo (Ubuntu Natty):
status: New → Confirmed
Timmmm (tdhutt) wrote :

Wow, I can't believe this obvious (and surely easy to fix!) bug is still not fixed! After having skimmed the libgksu code though, I'm not surprised -- it does call-outs to the shell all over the place. Obviously a very bad idea:

  tmp = g_strdup_printf ("%s list %s | "
                         "head -1 | awk '{ print $3 }'",
                         xauth_bin,
                         display);
  if ((xauth_output = popen (tmp, "r")) == NULL)

--------

      cmd[i] = g_strdup ("/bin/su"); i++;
      if (context->login_shell)
        {
          cmd[i] = g_strdup ("-"); i++;
        }
      cmd[i] = g_strdup (context->user); i++;
      if (context->keep_env)
        {
          cmd[i] = g_strdup ("-p"); i++;
        }
      cmd[i] = g_strdup ("-c"); i++;

      /* needs to get X authorization prior to running the program */
      cmd[i] = g_strdup_printf ("%s \"%s\"", auxcommand,
                                context->command); i++;

      cmd[i] = NULL;

      /* executes the command */
      if (execv (cmd[0], cmd) == -1)
        {
          fprintf (stderr,
                   "Unable to run /bin/su: %s",
                   strerror(errno));
        }

-----------

Such a terrible practice. When is someone going to write "exec() considered harmful"?

Torsten Spindler (tspindler) wrote :

A suggested patch for solving the missing prompts when mistyping the password. libgksu ignored unconditionally the first line, assuming it just contains a newline. The patch checks if this assumption is true and ignores only lines containing solely a newline.

A PPA with a package containing the patch is being created at ppa:tspindler/libgksu-298217

description: updated
fgcwatt (fgcwatt) wrote :

Patch worked on fully updated natty. I've been waiting since Karmic for this.... Mucho Kudos to Torsten for fixing an ancient and very visible bug.

Martin Pitt (pitti) on 2011-09-15
Changed in sudo (Ubuntu Natty):
status: Confirmed → Invalid
Changed in libgksu (Ubuntu Lucid):
status: Fix Released → In Progress
Changed in libgksu (Ubuntu Maverick):
status: Fix Released → In Progress
status: In Progress → Triaged
Martin Pitt (pitti) on 2011-09-15
Changed in libgksu (Ubuntu):
status: Confirmed → Fix Committed
Changed in libgksu (Ubuntu Lucid):
status: In Progress → Fix Committed
assignee: Martin Pitt (pitti) → nobody
Changed in libgksu (Ubuntu Maverick):
assignee: Martin Pitt (pitti) → nobody
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libgksu - 2.0.13~pre1-4ubuntu2

---------------
libgksu (2.0.13~pre1-4ubuntu2) oneiric; urgency=low

  * debian/patches/32_checknewline.patch:
    - Check if buffer is really a single newline before
      discarding it. (LP: #298217)
 -- Torsten Spindler (Canonical) <email address hidden> Tue, 13 Sep 2011 11:09:10 +0200

Changed in libgksu (Ubuntu):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Thanks Torsten! I sponsored all your debdiffs, with a few minor tweaks (bug reference, distro target, version number).

Changed in libgksu (Ubuntu Maverick):
status: Triaged → Fix Committed
Changed in libgksu (Ubuntu Natty):
status: Confirmed → Fix Committed
tekstr1der (tekstr1der) wrote :

Looks like this patch is superseded by a security update and needs to be re-submitted.

Meanwhile, I've installed a clean copy of Debian stable 6.0.2 and see that this bug does not exist in libgksu2-0 (2.0.13~pre1-3). I can't find any reference in the changelog as to what was fixed upstream or if the bug ever existed there.

I guess I am confused by the need for an Ubuntu patch when there is a working, stable Debian package?

Clint Byrum (clint-fewbar) wrote :

Hello Ryan, or anyone else affected,

Accepted libgksu into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Clint Byrum (clint-fewbar) wrote :

Hello Ryan, or anyone else affected,

Accepted libgksu into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Clint Byrum (clint-fewbar) wrote :

Hello Ryan, or anyone else affected,

Accepted libgksu into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tekstr1der (tekstr1der) wrote :

I can confirm this patch fixes the problem on Natty 11.04. Also, it fails correctly after 3 incorrect password entry attempts.
I've attached output from:

gksu -d whoami

tags: added: verification-done-natty
Jane Atkinson (irihapeti) wrote :

I can confirm that the patch works for Lucid. Three attempts with incorrect password results in

"Failed to run ____ as user root.
Wrong password"

Nobuto Murata (nobuto) wrote :

Indeed libgksu/natty-proposed accepts password 3 times, from this aspect -proposed package works fine.
But gksu outputs "3 incorrect password attempts" per 1 attempt. Although it seems not to have actual harm, this behaviour is strange.

==========
$ gksu 'echo 1'
GNOME_SUDO_PASS #### <- beginning of first attempt
Sorry, try again.
GNOME_SUDO_PASS
Sorry, try again.
sudo: 3 incorrect password attempts
GNOME_SUDO_PASS #### <- beginning of second attempt
Sorry, try again.
GNOME_SUDO_PASS
Sorry, try again.
sudo: 3 incorrect password attempts
GNOME_SUDO_PASS #### <- beginning of third attempt
Sorry, try again.
GNOME_SUDO_PASS
Sorry, try again.
sudo: 3 incorrect password attempts
==========

Martin Pitt (pitti) on 2011-09-21
tags: added: verification-done verification-done-lucid
Peter Matulis (petermatulis) wrote :

Are we going to correct the issue in comment #73?

If it is decided that the issue in comment #73 is not going to be fixed here, then perhaps a separate bug for it should be filed.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libgksu - 2.0.13~pre1-1ubuntu4.2

---------------
libgksu (2.0.13~pre1-1ubuntu4.2) lucid-proposed; urgency=low

  * debian/patches/29_check-newline.patch:
    - check if an empty line is really received before
      ignoring it (LP: #298217)
 -- Torsten Spindler (Canonical) <email address hidden> Wed, 14 Sep 2011 11:46:48 +0200

Changed in libgksu (Ubuntu Lucid):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libgksu - 2.0.13~pre1-3ubuntu3.1

---------------
libgksu (2.0.13~pre1-3ubuntu3.1) natty-proposed; urgency=low

  * debian/patches/29_check_newline.patch:
    - Check if buffer is really a single newline before
      discarding it. (LP: #298217)
 -- Torsten Spindler (Canonical) <email address hidden> Tue, 13 Sep 2011 10:55:28 +0200

Changed in libgksu (Ubuntu Natty):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Resetting verification tags as maverick still needs testing.

tags: removed: verification-done

Hi Martin, why this bug is still open?

Adolfo Jayme (fitojb) on 2013-05-17
no longer affects: libgksu (Ubuntu Maverick)
no longer affects: sudo (Ubuntu)
no longer affects: sudo (Ubuntu Lucid)
no longer affects: sudo (Ubuntu Maverick)
no longer affects: sudo (Ubuntu Natty)
tags: removed: verification-needed
Changed in libgksu (Debian):
status: New → Fix Released
To post a comment you must log in.