libgit2-dev depends on libcurl4-openssl-dev, not libcurl4-dev (Xenial, 16.04)

Bug #1546931 reported by Lukáš Karas on 2016-02-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libgit2 (Ubuntu)
Undecided
Unassigned

Bug Description

Hi, libgit2-dev has libcurl4-openssl-dev as dependency. It is possible change this dependency to libcurl4-dev? Or setup this dependecy to libcurl4-openssl-dev or libcurl4-gnutls-dev ?

I need another "dev" package: libgcal-dev. It depends on libcurl4-gnutls-dev and it is in conflict with libcurl4-openssl-dev.

So I can't have both - libgcal-dev and libgit2-dev. If this change is possible, libgcal-dev should be updated too.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libgit2 (Ubuntu):
status: New → Confirmed
Match (xhosa) wrote :

Looks like this is no longer a dependency in 16.04 at least:
>$ dpkg -s libgit2-dev
Package: libgit2-dev
...
Depends: libgit2-24 (= 0.24.1-2), libz-dev, libcurl4-gnutls-dev, libssh2-1-dev, libhttp-parser-dev

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers