libgearman-client-async-perl: FTBFS: tests failed

Bug #1244750 reported by Andreas Moog on 2013-10-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libgearman-client-async-perl (Debian)
Fix Released
Unknown
libgearman-client-async-perl (Ubuntu)
High
Unassigned

Bug Description

Imported from Debian bug http://bugs.debian.org/571358:

Source: libgearman-client-async-perl
Version: 0.94-3
Severity: serious
User: <email address hidden>
Usertags: qa-ftbfs-2010-02-24 qa-ftbfs
Justification: FTBFS on amd64

Hi,

During a rebuild of all packages in sid, your package failed to build on
amd64.

Relevant part:
> make[1]: Entering directory `/build/user-libgearman-client-async-perl_0.94-3-amd64-P7TTeU/libgearman-client-async-perl-0.94'
> PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
> Error/timeout talking to gearman parent process: [write_presleep_error] at /usr/share/perl5/Gearman/Worker.pm line 237.
> t/allinone.t ...... ok
> t/async.t ......... ok
> t/err1.t .......... ok
> t/err2.t .......... ok
> t/err3.t .......... ok
> t/err4.t .......... ok
> t/err5.t .......... ok
> t/err6.t .......... ok
> t/err7.t .......... ok
> Can't call method "watch_read" on an undefined value at t/err8.t line 57.
> # Looks like your test exited with 255 before it could output anything.
> t/err8.t ..........
> Dubious, test returned 255 (wstat 65280, 0xff00)
> Failed 3/3 subtests
> t/tests-needed.t .. ok
> Failed 1/12 test programs. 0/32 subtests failed.
> t/uniq.t .......... ok
>
> Test Summary Report
> -------------------
> t/err8.t (Wstat: 65280 Tests: 0 Failed: 0)
> Non-zero exit status: 255
> Parse errors: Bad plan. You planned 3 tests but ran 0.
> Files=12, Tests=32, 25 wallclock secs ( 0.04 usr 0.01 sys + 0.80 cusr 0.17 csys = 1.02 CPU)
> Result: FAIL
> make[1]: *** [test_dynamic] Error 255

The full build log is available from:
   http://people.debian.org/~lucas/logs/2010-02-24/libgearman-client-async-perl_0.94-3_lsid64.buildlog

A list of current common problems and possible solutions is available at
http://wiki.debian.org/qa.debian.org/FTBFS . You're welcome to contribute!

About the archive rebuild: The rebuild was done on about 50 AMD64 nodes
of the Grid'5000 platform, using a clean chroot. Internet was not
accessible from the build systems.

--
| Lucas Nussbaum
| <email address hidden> http://www.lucas-nussbaum.net/ |
| jabber: <email address hidden> GPG: 1024D/023B3F4F |

Andreas Moog (ampelbein) on 2013-10-25
Changed in libgearman-client-async-perl (Ubuntu):
importance: Undecided → High
tags: added: ftbfs saucy trusty
Changed in libgearman-client-async-perl (Debian):
importance: Undecided → Unknown
status: New → Confirmed
Ross Gammon (rosco2) wrote :

This is confirmed in Debian, ans has been forwarded upstream from there.

Changed in libgearman-client-async-perl (Ubuntu):
status: New → Confirmed
Changed in libgearman-client-async-perl (Debian):
status: Confirmed → Fix Released
Andreas Moog (ampelbein) wrote :

This is fixed in the current Ubuntu development release.

Changed in libgearman-client-async-perl (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.