Unable to perform search error when syncing Evolution with Google Contacts

Bug #1375782 reported by Ruben Iskandaryan on 2014-09-30
44
This bug affects 7 people
Affects Status Importance Assigned to Milestone
evolution (Arch Linux)
New
Undecided
Unassigned
libgdata (Ubuntu)
Undecided
Iain Lane
Utopic
Undecided
Iain Lane

Bug Description

[ Description ]

Google changed their expected date format to fix a bug which libgdata was working around. We don't need the workaround any more.

[ Fix ]

This is fixed in 0.16.1. I think we should take this update, as it includes other bugfixes too. I think it falls under the GNOME MRE. If not, we can cherry-pick this one fix.

This is in vivid already.

[ QA ]

If you get the below error, check that upgrading to the new libgdata fixes it for you.

[ Original Report ]

Hello,

When trying to synchronise Google Contacts with Evolution, I am getting the error message:

The backend for this address book was unable to parse this query. GDBus.Error:org.gtk.GDBus.UnmappedGError.Quark._e_2dclient_2derror_2dquark.Code16: Invalid request URI or header, or unsupported nonstandard parameter: <?xml version="1.0" encoding="UTF-8"?>
<errors xmlns="http://schemas.google.com/g/2005">
 <error>
  <domain>GData</domain>
  <code>invalid</code>
  <internalReason>Bad updated-min timestamp format: 2014-09-30T12:48:18.000001 00:00</internalReason>
 </error>
</errors>

My system is Ubunru 14.10, Evolution 3.12.6.

Before updating to Ubuntu 14.10 (in 14.04) it worked without an error.

Ruben

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in evolution (Ubuntu):
status: New → Confirmed

Same problem here!

Nico (nicom66) wrote :

I have the same problem too.

molecule-eye (niburu1) wrote :

I have this problem. I'm now running version 3.12.7 and Gnome 3.14 using the Gnome Staging PPA (I'm on Ubuntu Gnome 14.10).

John Walker (jandswalker) wrote :

Same problem here.

Iain Lane (laney) wrote :

I think this is the same as https://bugzilla.gnome.org/show_bug.cgi?id=732809, and will look at fixing it tomorrow.

affects: evolution (Ubuntu) → libgdata (Ubuntu)
Changed in libgdata (Ubuntu):
assignee: nobody → Iain Lane (laney)
status: Confirmed → In Progress
Iain Lane (laney) wrote :
description: updated
Changed in libgdata (Ubuntu Utopic):
status: New → In Progress
Changed in libgdata (Ubuntu):
status: In Progress → Fix Released
Changed in libgdata (Ubuntu Utopic):
assignee: nobody → Iain Lane (laney)
Iain Lane (laney) wrote :

I uploaded 0.16.1 of libgdata to utopic-proposed. After it gets reviewed and accepted (you'll see a message here), please see if it fixes this bug.

Hello Ruben, or anyone else affected,

Accepted libgdata into utopic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/libgdata/0.16.1-1~ubuntu14.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in libgdata (Ubuntu Utopic):
status: In Progress → Fix Committed
tags: added: verification-needed
Sebastien Bacher (seb128) wrote :

could somebody verify that the text is working?

I downloaded 0.16.1-1~ubuntu14.10.1, installed it. And now synchronization between Evolution and Gmail address books works fine.

Comment #9: I upgraded to version 0.16.1-1~ubuntu14.10.1 from utopic-proposed; the error does not occur with it.

Timo Aaltonen (tjaalton) on 2015-01-28
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libgdata - 0.16.1-1~ubuntu14.10.1

---------------
libgdata (0.16.1-1~ubuntu14.10.1) utopic; urgency=medium

  * SRU new upstream bugfix release to Utopic
    + Fixes date parsing which was breaking contact sync (LP: #1375782)

libgdata (0.16.1-1) unstable; urgency=medium

  * New upstream release 0.16.1
    + Add a --disable-tests configure option to build without uhttpmock
    + Remove downstream fix for ISO 8601 dates which was breaking Contacts
    + Various fixes for the Google Tasks service
 -- Iain Lane <email address hidden> Tue, 25 Nov 2014 10:30:31 +0000

Changed in libgdata (Ubuntu Utopic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for libgdata has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Robert McKee (bertmanphx) wrote :

This bug appears in Ubuntu Gnome 17.04 (beta), noted by the text that is raised in Evolution above the address books.

The backend for this address book was unable to parse this query. Invalid request URI or header, or unsupported nonstandard parameter: <?xml version="1.0" encoding="UTF-8"?>
<errors xmlns="http://schemas.google.com/g/2005">
 <error>
  <domain>GData</domain>
  <code>invalid</code>
  <internalReason>Bad updated-min timestamp format: 2017-04-08T16:43:09.000001 00:00</internalReason>
 </error>
</errors>

Matthew Gregg (mcg) wrote :

Can confirm this issue on 17.04.

Taewoon Kim (tae898) wrote :

same here on ubuntu gnome 17.04

Error is also present on vanilla ubuntu 17.04

Petr Kubánek (petr-kubanek) wrote :

Fixed by rm ~/.cache/evolution/addressbook/*/cache.xml, which probably had wrong timestamp recorded. You can replace * with directory where your address book cache is actually stored.

Petr Kubánek (petr-kubanek) wrote :

So that only fix it that the adressbook synchronizes for the first time (with all entries uploaded), but next synchronization fails with the same error. Seems to be related to:

https://bugzilla.gnome.org/show_bug.cgi?id=780067

so libgdata22 0.17.8 should fix this (I have 0.17.7 on my 17.04).

Petr Kubánek (petr-kubanek) wrote :

New bug on 0.17.7: #1706580

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.