SRU: ignore libgda5 test results during the build

Bug #1815139 reported by Matthias Klose on 2019-02-07
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libgda5 (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned

Bug Description

SRU: ignore libgda5 test results during the build. This is just a backport from a work around in cosmic and disco, letting the package build in bionic.

regression potential: not more than in cosmic and disco, and cosmic already released with this change.

acceptance criteria: the package succeeds to build

Łukasz Zemczak (sil2100) wrote :

Accepting this as the package is in universe and, as noted by the uploader, the same change is already present in future series.

Changed in libgda5 (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic

Hello Matthias, or anyone else affected,

Accepted libgda5 into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/libgda5/5.2.4-9ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in libgda5 (Ubuntu):
status: New → Fix Released
Matthias Klose (doko) wrote :

the package built with the existing compiler in -proposed, and with the planned update in
the PPA
https://launchpad.net/~ubuntu-toolchain-r/+archive/ubuntu/ppa/+packages

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libgda5 - 5.2.4-9ubuntu0.1

---------------
libgda5 (5.2.4-9ubuntu0.1) bionic-proposed; urgency=medium

  * SRU: LP: #1815139. Backport packaging fix from 5.2.4-10.

  [ Jeremy Bicha ]
  * Ignore build test failures since the tests don't pass reliably
    and no one is volunteering to fix them

 -- Matthias Klose <email address hidden> Thu, 07 Feb 2019 21:13:47 +0100

Changed in libgda5 (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for libgda5 has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers