Please update the package libgda4 to 4.0.2

Bug #398229 reported by Bhavani Shankar on 2009-07-11
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libgda4 (Ubuntu)
Wishlist
Unassigned

Bug Description

New upstream version includes

Released 4.0.2

2009-04-18 Vivien Malerba <email address hidden>

 * providers/postgres/gda-postgres-provider.c: display a warning when
 the PostgreSQL provider does not identify any data type

2009-04-17 Vivien Malerba <email address hidden>

 * providers/postgres/gda-postgres-provider.c: fix for bug #578748
 * libgda/sqlite/gda-sqlite.h:
 * libgda/sqlite/gda-sqlite-meta.c:
 * libgda/sqlite/gda-sqlite-provider.c: make the SQLite provider
 compile with a system installed SQLite
 * configure.in: a system installed SQLite is now only searched for if the
 --enable-system-sqlite option is passed, and the presence of the sqlite3CreateFunc
 symbol is not anymore required. The only drawback of using a system installed
 SQLite is that meta data regarding functions will not be available
 * libgda/handlers/gda-handler-time.c: fix mem leak

2009-04-07 Vivien Malerba <email address hidden>

 * configure.in:
   - set version to 4.0.2
   - detect uint8_t presence
 * libgda/gda-meta-store.c:
   - correction in gda_meta_store_schema_get_structure()
   - correction in the "cnc" property
 * tools/web-server.c: don't check for uint8_t
 * doc/C: doc. updates

Released 4.0.1

2009-03-27 Vivien Malerba <email address hidden>

 * libgda/libgda.symbols: removed the gda_transaction_status_dump
 symbol
 * libgda/sqlite/Makefile.am: another correction

2009-03-27 Vivien Malerba <email address hidden>

 * libgda/sqlite/Makefile.am: build xml_embedded.h before it is needed, and
 don't distribute it as part of the sources

2009-03-25 Vivien Malerba <email address hidden>

 * configure.in: set version to 4.0.1
 * libgda/gda-config.c:
   - added _gda_config_sqlite_provider,
     a pointer to the SQLite GdaServerProvider, always available, even
     if the SQLite provider is not installed
   - correctly behave if no provider is found at all
 * libgda/gda-connection.c:
 * libgda/gda-connection-sqlite.h: added a private method to open a
 connection to an SQLite file directly, even if the SQLite provider is not
 installed: _gda_open_internal_sqlite_connection()
 * libgda/gda-meta-store.c: if the SQLite provider is not installed, then use
 _gda_open_internal_sqlite_connection()
 * libgda/gda-server-operation-private.h:
 * libgda/gda-server-operation.c: added a private
 _gda_server_operation_new_from_string() function
 * libgda/sqlite/Makefile.am
 * libgda/sqlite/gen_emb_string.c: tool which generates source code to embedd all
 the .xml files found in providers/sqlite.
 * libgda/sqlite/gda-sqlite-provider.c: if a .xml file normally installed along
 with the SQLite provider is not found, then use the embedded version, using
 the file generated by the new gen_emb_string tool (which means losing any
 translation but we don't care as it is for internal purposes only).
 * libgda/sqlite/gda-sqlite-provider.c:
 * providers/mysql/gda-mysql-provider.c:
 * providers/postgres/gda-postgres-provider.c:
 * providers/skel-implementation/capi/gda-capi-provider.c: minor corrections in
 warnings
 * tools/gda-sql.c: better handle when the meta store object can be created

Related branches

Bhavani Shankar (bhavi) wrote :
Bhavani Shankar (bhavi) wrote :
Bhavani Shankar (bhavi) wrote :
Bhavani Shankar (bhavi) wrote :
Changed in libgda4 (Ubuntu):
status: New → Confirmed
Nick Ellery (nick.ellery) wrote :

Your change "Bump standards-version to 3.8.2 with changes to homepage field" doesn't appear to exist in the debdiff or diff.gz. Can you please update this appropriately?

Changed in libgda4 (Ubuntu):
importance: Undecided → Wishlist
Bhavani Shankar (bhavi) wrote :

hello nick

on it now.....

Bhavani Shankar (bhavi) wrote :

Reverting the change because i think i found a nagging bug

Bhavani Shankar (bhavi) wrote :
Bhavani Shankar (bhavi) wrote :

please see bug #403870

Artur Rona (ari-tczew) on 2009-07-27
tags: added: upgrade
Sebastien Bacher (seb128) wrote :

thank you for your work there

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libgda4 - 4.0.2-0ubuntu1

---------------
libgda4 (4.0.2-0ubuntu1) karmic; urgency=low

  * New Upstream release LP: #398229

 -- Bhavani Shankar <email address hidden> Fri, 24 Jul 2009 10:16:37 +0530

Changed in libgda4 (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers