Comment 5 for bug 751142

Deepak C Shetty (dpkshetty) wrote :

Hi,
  I am still seeing this problem. I have ubuntu 11.04 desktop ... and i faced the same issue...
I tried using apt-get to get latest libgcrypt ( thinking the above fix is not there), but apt-get says i have latest libgcrypt installed.

Pls see the problem below.
I tried to manually change the libdir to /usr/lib/... as a workaround mentioned above, and then tried executing right from the ./autoconfiscate.sh step ( libvirt-cim does not have ./autogen) but i still see the below issue.. appreciate a response...

dpkshetty@deepak-ThinkPad-T60p:~/work/libvirt-cim/libvirt-cim$ make
make all-recursive
make[1]: Entering directory `/home/dpkshetty/work/libvirt-cim/libvirt-cim'
Making all in libxkutil
make[2]: Entering directory `/home/dpkshetty/work/libvirt-cim/libvirt-cim/libxkutil'
Making all in tests
make[3]: Entering directory `/home/dpkshetty/work/libvirt-cim/libvirt-cim/libxkutil/tests'
make[3]: Nothing to be done for `all'.
make[3]: Leaving directory `/home/dpkshetty/work/libvirt-cim/libvirt-cim/libxkutil/tests'
make[3]: Entering directory `/home/dpkshetty/work/libvirt-cim/libvirt-cim/libxkutil'
  CC cs_util_instance.lo
  CC misc_util.lo
  CC device_parsing.lo
  CC xmlgen.lo
  CC infostore.lo
  CC pool_parsing.lo
  CC acl_parsing.lo
  CCLD libxkutil.la
/bin/sed: can't read /lib/i386-linux-gnu/libgcrypt.la: No such file or directory
libtool: link: `/lib/i386-linux-gnu/libgcrypt.la' is not a valid libtool archive
make[3]: *** [libxkutil.la] Error 1
make[3]: Leaving directory `/home/dpkshetty/work/libvirt-cim/libvirt-cim/libxkutil'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/dpkshetty/work/libvirt-cim/libvirt-cim/libxkutil'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/dpkshetty/work/libvirt-cim/libvirt-cim'
make: *** [all] Error 2