Please merge libgrypt11 1.4.5-2(main) from debian unstable(main)

Bug #607861 reported by Bhavani Shankar
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libgcrypt11 (Ubuntu)
Fix Released
Undecided
Unassigned

Bug Description

Binary package hint: libgcrypt11

Debian changes:

 libgcrypt11 (1.4.5-2) unstable; urgency=low

   * Fix FTBFS on mips(el). Thank you, Aurelien Jarno. Closes: #561475

 -- Andreas Metzler <email address hidden> Wed, 03 Feb 2010 19:02:07 +0100

libgcrypt11 (1.4.5-1) unstable; urgency=low

   * New upstream version.
     + Does not try to use SPARC32 assembly code on SPARC64. Closes: #560028
   * Drop patches included upstream: 21_cpuid.diff 20_padlock.diff.
   * Switch to 3.0 (quilt) format.
   * Update copyright stanza for documentation.
   * Simplify debian/rules. There should not be any reason to disable the
     pubkey test on specific archs anymore since GCRYCTL_ENABLE_QUICK_RANDOM is
     set. (#385805). Also tests/register et al. are run by upstream's check
     target, there is no need for manual invocation.

 -- Andreas Metzler <email address hidden> Sat, 12 Dec 2009 10:44:53 +0100
libgcrypt11 (1.4.4-6) unstable; urgency=low

   * Sync priorities with override file, libgcrypt11 is priority standard
     now.
   * [patches/21_cpuid.diff] Fix CPUID detection. (Thank's, Ben Hutchings.)
     Closes: #519391

Revision history for this message
Bhavani Shankar (bhavi) wrote :
Changed in libgcrypt11 (Ubuntu):
status: New → Confirmed
Revision history for this message
Benjamin Drung (bdrung) wrote :

The endif doesn't belong to the end of debian/rules. It should only cover DEB_MAKE_CHECK_TARGET:

ifeq ($(DEB_BUILD_GNU_TYPE),$(DEB_HOST_GNU_TYPE))
DEB_MAKE_CHECK_TARGET = check
endif

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libgcrypt11 - 1.4.5-2ubuntu1

---------------
libgcrypt11 (1.4.5-2ubuntu1) maverick; urgency=low

  * Merge from Debian unstable (LP: #607861). Remaining changes:
    - Add libgcrypt11-udeb for use by cryptsetup-udeb.
    - Install to /lib.
    - Disable tests when cross-building.
    - Adjust install/libgcrypt11-dev target to cope with move to /lib.

libgcrypt11 (1.4.5-2) unstable; urgency=low

  * Fix FTBFS on mips(el). Thank you, Aurelien Jarno. Closes: #561475

libgcrypt11 (1.4.5-1) unstable; urgency=low

  * New upstream version.
    + Does not try to use SPARC32 assembly code on SPARC64. Closes: #560028
  * Drop patches included upstream: 21_cpuid.diff 20_padlock.diff.
  * Switch to 3.0 (quilt) format.
  * Update copyright stanza for documentation.
  * Simplify debian/rules. There should not be any reason to disable the
    pubkey test on specific archs anymore since GCRYCTL_ENABLE_QUICK_RANDOM is
    set. (#385805). Also tests/register et al. are run by upstream's check
    target, there is no need for manual invocation.

libgcrypt11 (1.4.4-6) unstable; urgency=low

  * Sync priorities with override file, libgcrypt11 is priority standard
    now.
  * [patches/21_cpuid.diff] Fix CPUID detection. (Thank's, Ben Hutchings.)
    Closes: #519391
 -- Bhavani Shankar <email address hidden> Tue, 20 Jul 2010 20:31:59 +0530

Changed in libgcrypt11 (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers