libgcrypt11 not present in Vivid (15.04), Xenial (16.04) - Spotify, Brackets and other app issue.

Bug #1452216 reported by Nicola Corti on 2015-05-06
62
This bug affects 11 people
Affects Status Importance Assigned to Milestone
libgcrypt11 (Ubuntu)
High
Unassigned

Bug Description

The package libgcrypt11 is not present anymore in official ubuntu vivid repositories.

This cause app crash, such as spotify:
spotify: error while loading shared libraries: libgcrypt.so.11: cannot open shared object file: No such file or directory

Current workaround is to manually download the .deb package from launchpad/debian package such as https://packages.debian.org/wheezy/libgcrypt11 and manually install with dpkg.

Linux SAGITTER 3.19.0-15-generic #15-Ubuntu SMP Thu Apr 16 23:32:37 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
Distributor ID: Ubuntu
Description: Ubuntu 15.04
Release: 15.04
Codename: vivid

Seth Arnold (seth-arnold) wrote :

The libgcrypt20 package should be binary compatible with libgcrypt11; try installing that instead of the Debian package.

Thanks

Changed in libgcrypt11 (Ubuntu):
status: New → Incomplete
Nicola Corti (corti-nico) wrote :

Unfortunately it does not work. With libgcrypt20 installed instead of libgcrypt11 spotify will not load:

spotify: error while loading shared libraries: libgcrypt.so.11: cannot open shared object file: No such file or directory

Same issue is reported here:
- http://askubuntu.com/questions/613081/spotify-has-stopped-working-on-the-latest-ubuntu-today-15-04
- https://community.spotify.com/t5/Help-Desktop-Linux-Mac-and/Ubuntu-15-04-ships-with-libgcrypt20-but-spotify-app-version-is/td-p/1121359

Changed in libgcrypt11 (Ubuntu):
status: Incomplete → Confirmed
Manfred Hampl (m-hampl) wrote :

@Seth Arnold:

Several people have tried creating a link from libgcrypt11 to libgcrypt20

sudo ln -s /lib/x86_64-linux-gnu/libgcrypt.so.20.0.2 /lib/x86_64-linux-gnu/libgcrypt.so.11
respectively
sudo ln -s /lib/i386-linux-gnu/libgcrypt.so.20.0.2 /lib/i386-linux-gnu/libgcrypt.so.11

and have received errors like

spotify: /lib/x86_64-linux-gnu/libgcrypt.so.11: version `GCRYPT_1.2' not found (required by /opt/spotify/spotify-client/Data/libcef.so)

So that seems not to be sufficiently binary compatible.

Changed in libgcrypt11 (Ubuntu):
importance: Undecided → High
Norbert (nrbrtx) on 2017-07-07
summary: - libgcrypt11 not present in Vivid (15.04) - Spotify and other app issue.
+ libgcrypt11 not present in Vivid (15.04), Xenial (16.04) - Spotify,
+ Brackets and other app issue.
tags: added: xenial
Norbert (nrbrtx) wrote :

Got this issue while installing Brackets 1.10 editor from official deb (https://github.com/adobe/brackets/releases/tag/release-1.10).
sudo dpkg -i Brackets.Release.1.10.64-bit.deb
[sudo] password for norbert:
(Reading database ... 728352 files and directories currently installed.)
Preparing to unpack Brackets.Release.1.10.64-bit.deb ...
Unpacking brackets (1.10.0-17483) over (1.9.0libgcrypt11-17312+1~webupd8~0) ...
dpkg: dependency problems prevent configuration of brackets:
 brackets depends on libgcrypt11 (>= 1.4.5); however:
  Package libgcrypt11 is not installed.

dpkg: error processing package brackets (--install):
 dependency problems - leaving unconfigured
Processing triggers for menu (2.1.47ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.15-0ubuntu1) ...
Errors were encountered while processing:
 brackets

Temporary solution is to use previous version 1.9.0libgcrypt11-17312+1~webupd8~0 from PPA (ppa:webupd8team/brackets).
Or install required library from trusty (http://archive.ubuntu.com/ubuntu/pool/main/libg/libgcrypt11/libgcrypt11_1.5.3-2ubuntu4.5_amd64.deb) manually.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers