Please sync libgc (main) 1:7.1-7 from Debian unstable main

Bug #724486 reported by Alex Valavanis on 2011-02-24
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libgc (Ubuntu)
Low
Unassigned

Bug Description

New version available in Debian. The only ubuntu-specific change affects functionality in gc_locks.h that has now been removed, so I guess a sync would be appropriate.

Debian changelog head as follows:

libgc (1:7.1-7) unstable; urgency=low

   * Add ppc64 symbol file (Closes: #615469)
   * Add sh4 symbol file (Closes: #614744)
   * Add armhf symbol file
   * Add powerpcspe symbol file
   * Handle sparc64 the same as sparc
   * Clear non-arch symbol file to support building on not yet captured
     architectures
   * add -pthread to fix build with --no-add-needed
 -- Christoph Egger <email address hidden> Wed, 02 Mar 2011 13:43:18 +0100

libgc (1:7.1-6) unstable; urgency=low

  * include pkg-config file (Closes: #546833)
  * Include Hurd symbol file (Closes: #611643) thanks to Svante Signell
    for providing it
  * add hppa symbol file

 -- Christoph Egger <email address hidden> Tue, 22 Feb 2011 17:17:54 +0100

libgc (1:7.1-5) unstable; urgency=low

  * Upload to unstable

 -- Christoph Egger <email address hidden> Sat, 19 Feb 2011 12:19:56 +0100

libgc (1:7.1-4) experimental; urgency=low

  * Adopt package (Closes: #590772)
    * Adopt debian/control git headers (moved to collab-maint)
    * Convert to source format 3.0 (quilt)
  * Build against system libatomic-ops (Closes: #559345)
    * Now builds on mipsen as well (Closes: #542285)
    * Include correct arch-specific symbols file for mipsen
    * Remove atomic-ops specific symbols from symbols file
    * Drop patch for automic-ops on s390
  * Fix dependency on debhelper (needs 7.0.50 > 7)
  * Bump standards version to 3.9.1
  * Fix symbol files (Closes: #565778)

 -- Christoph Egger <email address hidden> Sat, 09 Oct 2010 16:08:53 +0200

libgc (1:7.1-3) experimental; urgency=low

  * Add symbols for armel and i386.

 -- Chris Lamb <email address hidden> Sun, 16 Aug 2009 20:28:41 +0100

libgc (1:7.1-2) experimental; urgency=low

  * Fix FTBFS on sparc by specifying correct machine-dependent code.
  * Fix FTBFS on s390 by correcting #include directory.
  * Add avr32 support. Patch by Bradley Smith <email address hidden>.
    (Closes: #528406)
  * Symbols maintenance:
    - Add Build-Depends-Package
    - Add required arch-dependent symbols for sparc, powerpc, s390 and avr32
  * Add Vcs-{Git,Browser} headers.

 -- Chris Lamb <email address hidden> Fri, 14 Aug 2009 00:15:45 +0100

libgc (1:7.1-1) experimental; urgency=low

  * New maintainer. (Closes: #541015)
  * New upstream release. (Closes: #434106, #446068)
  * Fix debian/watch file. Thanks Jonny <email address hidden> and Ruben Molina
    <email address hidden>. (Closes: #535985)
  * debian/patches/*
    - Extract changes from .diff.gz into quilt patch series
    - Update architecture patches for new upstream; partly applied upstream
  * Move to debhelper 7.
  * Add symbols file for libgc1c2.
  * debian/control:
    - Bump Standards-Version to 3.8.2.
    - Add Homepage: field.
    - Add ${misc:Depends} for all binary packages.
    - Use ${binary:Version} in libgc-dev => libgcX versioned dependency.
    - Drop duplicate "Section:" heading in libgc1c2.
    - Update long description, clarifying ambiguity caused by Debian's choice
      of configuration. (Closes: #329338)
  * Remove some cruft from debian/rules.
  * Install README.environment via dh_installdocs, not dh_install.
  * Don't install README.cords if we aren't shipping that library
    (Closes: #422440)

 -- Chris Lamb <email address hidden> Wed, 12 Aug 2009 02:16:30 +0100

Changed in libgc (Ubuntu):
importance: Undecided → Wishlist
status: New → Triaged
tags: added: packaging
description: updated
summary: - Please merge libgc (main) 1:7.1-6 from Debian unstable main
+ Please merge libgc (main) 1:7.1-7 from Debian unstable main
summary: - Please merge libgc (main) 1:7.1-7 from Debian unstable main
+ Please sync libgc (main) 1:7.1-7 from Debian unstable main
Alex Valavanis (valavanisalex) wrote :

I'm changing this to a sync request, because the only ubuntu-specific change affects functionality in gc_locks.h that has now been removed.

@Matthias - Do you have any thoughts about whether this will cause any problems?

Changed in libgc (Ubuntu):
milestone: none → oneiric-alpha-1
Alex Valavanis (valavanisalex) wrote :

Targeting this to oneiric alpha1... it would be nice to get back in sync now that the Debian package is being actively-maintained.

description: updated
Alex Valavanis (valavanisalex) wrote :

(Successful local amd64 pbuilder build)

Changed in libgc (Ubuntu):
importance: Wishlist → Low
Colin Watson (cjwatson) wrote :

Thanks for your report. Somebody seems to have done this independently:

  https://launchpad.net/ubuntu/+source/libgc/1:7.1-7

Changed in libgc (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers