version 7.1 now available, need pkgconfig file

Bug #489746 reported by linas on 2009-11-28
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libgc (Ubuntu)
Undecided
Unassigned

Bug Description

Current versions of teh BDW-GC in ubuntu are based on vresion 6.8, which is more than three years old. Note that version 7.0 came out on 02-Jul-2007 and version 7.1 on 03-May-2008

I need the pkg-config file "bdw-gc.pc" from these versions, because other systems that use ./configure (autoconf/automake) expect to find this file (in /usr/lib/pkgconfig)

Note that this bug affects all versions of ubuntu -- from at least hardy up to karmic and lucid

The boehm GC is downloadable from
http://www.hpl.hp.com/personal/Hans_Boehm/gc/gc_source/

Colin Watson (cjwatson) wrote :

This is now done in Oneiric, via Debian unstable:

libgc (1:7.1-6) unstable; urgency=low

  * include pkg-config file (Closes: #546833)
  * Include Hurd symbol file (Closes: #611643) thanks to Svante Signell
    for providing it
  * add hppa symbol file

 -- Christoph Egger <email address hidden> Tue, 22 Feb 2011 17:17:54 +0100

If you need this in older releases, it would probably be best to rebuild the package in a PPA - libgc is used by enough packages that we're unlikely to upgrade it to a new major version in stable releases.

Changed in libgc (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers