libfreenect-demos : Depends: libglut3 but it is not installable

Bug #861338 reported by Pavel Studeník on 2011-09-28
28
This bug affects 3 people
Affects Status Importance Assigned to Milestone
libfreenect (Debian)
Fix Released
Unknown
libfreenect (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Bartosz Kosiorek
Precise
Undecided
Unassigned

Bug Description

I try to install libfreenect-demos on ubuntu 11.10, but problem is that repository doesn't contain libglut3.

The following packages have unmet dependencies:
 libfreenect-demos : Depends: libglut3 but it is not installable
E: Unable to correct problems, you have held broken packages.

Thomas (thomas-toussaint) wrote :

Same problem here!

alexsleat (alexsleat) wrote :

Looks like it's because libglut3 was replaced by freeglut3.

I know it, i use this package. It's problem only dependence. I thing that it will be really good when somebody repair this package.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libfreenect (Ubuntu):
status: New → Confirmed
Ellis Rahhal (elrah) wrote :

Also having the same problem, Ubuntu 11.10

Here is a patch to fix this problem. You may also have to "sudo modprobe -r gspca_kinect" or blacklist the kernel module before the libfreenect demo software will run.

The attachment "changed dependency in control file" of this bug report has been identified as being a patch in the form of a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Changed in libfreenect (Ubuntu Precise):
status: Confirmed → Fix Released
Changed in libfreenect (Ubuntu Oneiric):
status: New → Confirmed
Marc Deslauriers (mdeslaur) wrote :

ACK on the debdiff, thanks. I've slightly adjusted the changelog.

SRU request:

Impact:
libglut3 isn't in the Oneiric archive, it was replaced with freeglut3. Bad dependencies in the libfreenect file prevent it from being installable in Oneiric.

Fix:
The package was fixed by the debdiff in comment #7 which adjusts the dependencies to freeglut3.

Regression potential:
Since the package is currently uninstallable, there's not much potential for regressing it.

Changed in libfreenect (Debian):
status: Unknown → Fix Released

Hello Pavel, or anyone else affected,

Accepted libfreenect into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in libfreenect (Ubuntu Oneiric):
status: Confirmed → Fix Committed
tags: added: verification-needed
Bartosz Kosiorek (gang65) wrote :

I successfully installed package from proposed, and it works correctly.

Verification done.

tags: added: verification-done
removed: verification-needed
Changed in libfreenect (Ubuntu Oneiric):
assignee: nobody → Bartosz Kosiorek (gang65)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libfreenect - 1:0.0.1+20101211+2-2ubuntu1

---------------
libfreenect (1:0.0.1+20101211+2-2ubuntu1) oneiric-proposed; urgency=low

  * Changed libglut3 dependency to freeglut3 (LP: #861338)
 -- Daniel Patrick Johnson <email address hidden> Tue, 17 Jan 2012 11:32:56 -0800

Changed in libfreenect (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.