Ubuntu

[08ff:1600] AES1600 fingerprint reader not recognized in Ubuntu 10.10

Reported by Fabián Rodríguez on 2010-10-08
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Unassigned
libfprint (Ubuntu)
Medium
Unassigned
Maverick
Medium
Unassigned

Bug Description

I've had this system for the past few releases.

The fingerprint reader did work in Ubuntu 10.04 LTS, which I just tested again.

sudo fprint_demo now reports "no devices found".

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: linux-image-2.6.35-22-generic 2.6.35-22.33
Regression: Yes
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic x86_64
NonfreeKernelModules: wl
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: magicfab 1826 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'NVidia'/'HDA NVidia at 0x80020000 irq 17'
   Mixer name : 'Realtek ALC861-VD'
   Components : 'HDA:10ec0862,103c30bf,00100001 HDA:10573055,103c30bf,00100700'
   Controls : 23
   Simple ctrls : 13
Date: Fri Oct 8 14:27:19 2010
EcryptfsInUse: Yes
HibernationDevice: RESUME=UUID=0f5c8361-033e-40cf-b418-d2873cc60f44
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release Candidate amd64 (20100928)
MachineType: Hewlett-Packard HP Pavilion tx1000 Notebook PC
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-22-generic root=UUID=e4334e0c-5bd9-4dbe-bfaa-04c47cc8925c ro vga=791 quiet splash
ProcEnviron:
 LANG=en_CA.utf8
 SHELL=/bin/bash
RelatedPackageVersions: linux-firmware 1.38
SourcePackage: linux
dmi.bios.date: 04/18/2008
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.20
dmi.board.name: 30BF
dmi.board.vendor: Quanta
dmi.board.version: 69.2E
dmi.chassis.type: 10
dmi.chassis.vendor: Quanta
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnHewlett-Packard:bvrF.20:bd04/18/2008:svnHewlett-Packard:pnHPPaviliontx1000NotebookPC:pvrRev1:rvnQuanta:rn30BF:rvr69.2E:cvnQuanta:ct10:cvrN/A:
dmi.product.name: HP Pavilion tx1000 Notebook PC
dmi.product.version: Rev 1
dmi.sys.vendor: Hewlett-Packard

Fabián Rodríguez (magicfab) wrote :
affects: linux (Ubuntu) → libfprint (Ubuntu)
Fabián Rodríguez (magicfab) wrote :

This bug is specifically about this device not working on a fresh install of Ubuntu 10.10. There is a separate bug about this breaking when updating from 10.04 LTS to 10.10, bug #640083.

Installing a newer version of fprint from the PPA worked for me.

Here are the steps to get the PPA version installed:

1) Add the fprint PPA to your repositories:
sudo add-apt-repository ppa:fingerprint/fprint
2) Update your repositories package list and update your packages:
sudo apt-get update && sudo apt-get upgrade -y

No need to reboot or restart any daemons.

Jonathan Davies (jpds) on 2010-10-08
Changed in libfprint (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
summary: - AES1600 fingerprint reader not recognized in Ubuntu 10.10
+ [08ff:1600] AES1600 fingerprint reader not recognized in Ubuntu 10.10
Changed in ubuntu-release-notes:
status: New → Fix Released
albireo (albireo-nizmster) wrote :

Solved when I update fprint packages from ppa:fingerprint/fprint.

The same finger print is build into Toshiba Tecra M10 and didn't work on freshly build Ubuntu 10.10.

All fixed after installing ppa:fingerprint/fprint

Bus 007 Device 002: ID 08ff:1600 AuthenTec, Inc. AES1600
Device Descriptor:
  bLength 18
  bDescriptorType 1
  bcdUSB 1.10
  bDeviceClass 255 Vendor Specific Class
  bDeviceSubClass 255 Vendor Specific Subclass
  bDeviceProtocol 255 Vendor Specific Protocol
  bMaxPacketSize0 8
  idVendor 0x08ff AuthenTec, Inc.
  idProduct 0x1600 AES1600
  bcdDevice c.10
  iManufacturer 0
  iProduct 1 Fingerprint Sensor
  iSerial 0
  bNumConfigurations 1
  Configuration Descriptor:
    bLength 9
    bDescriptorType 2
    wTotalLength 32
    bNumInterfaces 1
    bConfigurationValue 1
    iConfiguration 0
    bmAttributes 0xa0
      (Bus Powered)
      Remote Wakeup
    MaxPower 100mA
    Interface Descriptor:
      bLength 9
      bDescriptorType 4
      bInterfaceNumber 0
      bAlternateSetting 0
      bNumEndpoints 2
      bInterfaceClass 255 Vendor Specific Class
      bInterfaceSubClass 255 Vendor Specific Subclass
      bInterfaceProtocol 255 Vendor Specific Protocol
      iInterface 0
      Endpoint Descriptor:
        bLength 7
        bDescriptorType 5
        bEndpointAddress 0x81 EP 1 IN
        bmAttributes 2
          Transfer Type Bulk
          Synch Type None
          Usage Type Data
        wMaxPacketSize 0x0020 1x 32 bytes
        bInterval 0
      Endpoint Descriptor:
        bLength 7
        bDescriptorType 5
        bEndpointAddress 0x02 EP 2 OUT
        bmAttributes 2
          Transfer Type Bulk
          Synch Type None
          Usage Type Data
        wMaxPacketSize 0x0008 1x 8 bytes
        bInterval 0
Device Status: 0x0000
  (Bus Powered)

Thanks

Dariusz

Robert Ancell (robert-ancell) wrote :

Closing as 10.10 is no longer supported. Please open a new bug if this fingerprint reader does not work in a support version of Ubuntu.

Changed in libfprint (Ubuntu):
status: Confirmed → Triaged
importance: Medium → Wishlist
importance: Wishlist → Medium
status: Triaged → Won't Fix
Changed in libfprint (Ubuntu Maverick):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers