Elan Microelectronics Corp fingerprint reader not recognized

Bug #1876502 reported by Maarten Fonville on 2020-05-02
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
libfprint (Ubuntu)
Undecided
Unassigned

Bug Description

Elan fingerprint reader that is integrated in the touchpad of e.g. Asus Vivobooks is not recognized. It uses i2c instead of USB.
This bug is filed as replacement bug for https://bugs.launchpad.net/ubuntu/+source/libfprint/+bug/1641290

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: libfprint-2-2 1:1.90.1+tod1-0ubuntu4
ProcVersionSignature: Ubuntu 5.4.0-28.32-generic 5.4.30
Uname: Linux 5.4.0-28-generic x86_64
ApportVersion: 2.20.11-0ubuntu27
Architecture: amd64
CasperMD5CheckResult: skip
CurrentDesktop: ubuntu:GNOME
Date: Sat May 2 20:13:52 2020
InstallationDate: Installed on 2017-09-21 (954 days ago)
InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Alpha amd64 (20170919)
SourcePackage: libfprint
UpgradeStatus: Upgraded to focal on 2020-04-12 (20 days ago)
modified.conffile..etc.default.apport: [modified]
mtime.conffile..etc.default.apport: 2017-09-21T13:56:38.384300

Sebastien Bacher (seb128) wrote :

Thank you for your bug report. could you add your 'lsusb -v' outpu to the bug? (we should make the reporting tools do that by default...)

Changed in libfprint (Ubuntu):
status: New → Incomplete

Here you are

Trayan (trayan) wrote :
Download full text (48.7 KiB)

Issue with ASUS VivoBook n580v -lsusb -v report below

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Couldn't open device, some information will be missing
Device Descriptor:
  bLength 18
  bDescriptorType 1
  bcdUSB 3.00
  bDeviceClass 9 Hub
  bDeviceSubClass 0
  bDeviceProtocol 3
  bMaxPacketSize0 9
  idVendor 0x1d6b Linux Foundation
  idProduct 0x0003 3.0 root hub
  bcdDevice 5.04
  iManufacturer 3
  iProduct 2
  iSerial 1
  bNumConfigurations 1
  Configuration Descriptor:
    bLength 9
    bDescriptorType 2
    wTotalLength 0x001f
    bNumInterfaces 1
    bConfigurationValue 1
    iConfiguration 0
    bmAttributes 0xe0
      Self Powered
      Remote Wakeup
    MaxPower 0mA
    Interface Descriptor:
      bLength 9
      bDescriptorType 4
      bInterfaceNumber 0
      bAlternateSetting 0
      bNumEndpoints 1
      bInterfaceClass 9 Hub
      bInterfaceSubClass 0
      bInterfaceProtocol 0 Full speed (or root) hub
      iInterface 0
      Endpoint Descriptor:
        bLength 7
        bDescriptorType 5
        bEndpointAddress 0x81 EP 1 IN
        bmAttributes 3
          Transfer Type Interrupt
          Synch Type None
          Usage Type Data
        wMaxPacketSize 0x0004 1x 4 bytes
        bInterval 12
        bMaxBurst 0

Bus 001 Device 006: ID 8087:0a2b Intel Corp.
Couldn't open device, some information will be missing
Device Descriptor:
  bLength 18
  bDescriptorType 1
  bcdUSB 2.00
  bDeviceClass 224 Wireless
  bDeviceSubClass 1 Radio Frequency
  bDeviceProtocol 1 Bluetooth
  bMaxPacketSize0 64
  idVendor 0x8087 Intel Corp.
  idProduct 0x0a2b
  bcdDevice 0.10
  iManufacturer 0
  iProduct 0
  iSerial 0
  bNumConfigurations 1
  Configuration Descriptor:
    bLength 9
    bDescriptorType 2
    wTotalLength 0x00b1
    bNumInterfaces 2
    bConfigurationValue 1
    iConfiguration 0
    bmAttributes 0xe0
      Self Powered
      Remote Wakeup
    MaxPower 100mA
    Interface Descriptor:
      bLength 9
      bDescriptorType 4
      bInterfaceNumber 0
      bAlternateSetting 0
      bNumEndpoints 3
      bInterfaceClass 224 Wireless
      bInterfaceSubClass 1 Radio Frequency
      bInterfaceProtocol 1 Bluetooth
      iInterface 0
      Endpoint Descriptor:
        bLength 7
        bDescriptorType 5
        bEndpointAddress 0x81 EP 1 IN
        bmAttributes 3
          Transfer Type Interrupt
          Synch Type None
          Usage Type ...

Sebastien Bacher (seb128) wrote :

Thank, in fact you wrote that it isn't using usb so it's not listed there. It would probably be best if you could report it upstream directly on https://gitlab.freedesktop.org/libfprint/libfprint/issues/

Changed in libfprint (Ubuntu):
status: Incomplete → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libfprint (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libfprint - 1:1.90.2+tod1-0ubuntu1

---------------
libfprint (1:1.90.2+tod1-0ubuntu1) groovy; urgency=medium

  * New upstream release
    - Fixed crash in VFS0050 (LP: #1876502)
    - Enrollment fails with UPEK reader (LP: #1881380)
    - Lots of various drivers fixes
    - As per a patch for nbis required for some sensors that was accidentally
      dropped in an earlier release. Users of sensors/drivers aes1610, aes2501,
      aes2550, aes1660, aes2660, elan, upektc_img) need to re-enroll
  * d/p/git_reading_pointer.patch:
    - Dopped (applied upstream)
  * debian/control: Add missing libfprint-2-tod-dev dependencies (LP: #1884267)
  * debian/rules: Be strictier about symbol changes
  * libfprint-2-tod1.symbols: Add new TOD symbols

 -- Marco Trevisan (Treviño) <email address hidden> Fri, 19 Jun 2020 17:38:55 +0200

Changed in libfprint (Ubuntu):
status: Confirmed → Fix Released
Changed in libfprint (Ubuntu):
status: Fix Released → Fix Committed
status: Fix Committed → Confirmed

Even though this bug is marked as fixed, I don't have the impression it is fixed. These fingerprint sensors are not connected via USB but via I2C with the touchpad. I don't see any support for that in libfprint.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers