Preferred Applications incompatible with glib 2.27

Bug #683922 reported by Julien Lavergne on 2010-12-01
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
libfm (Ubuntu)
High
Unassigned

Bug Description

With glib 2.27, the preferred applications framework is broken, and need to be ported to use x-scheme-handler.
exo had the same problem (see xfce bug http://bugzilla.xfce.org/show_bug.cgi?id=6800) and fix it using those commit :
http://git.xfce.org/xfce/exo/commit/?id=ecb8a6e01204fd36319c69431c3ff9fd59f3c37c
http://git.xfce.org/xfce/exo/commit/?id=59214af3d667e6351dc2dee4fe4523aaf445679f

Related branches

Julien Lavergne (gilir) on 2010-12-01
Changed in libfm (Ubuntu):
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libfm - 0.1.15+git-3625952cea-0ubuntu1

---------------
libfm (0.1.15+git-3625952cea-0ubuntu1) natty; urgency=low

  * New upstream snapshot (2011-02-15)
   - Use x-schemas-handler (LP: #683922)
  * debian/patches/
   - 90_add_gobject_link.patch: Remove, merged upstream.
   - 02-libfm-0.1.14-API-changes.patch: Refresh.
   - 03_disable_deprecated_gio_module.patch: Refresh.
   - 04_fix_docs_linker.patch: Fix DSO linking in docs/.
  * debian/libfm0.install:
   - Remove usr/lib/libfm/gnome-terminal, dropped upstream.
   - Remove gio module, dropped upstream.
  * debian/rules:
   - Add --enable-gtk-doc to configure.
  * debian/libfm-gtk0.symbols:
   - Update with new symbols.
  * debian/apport/source_libfm.py
   - Fix location of pcmanfm config files.
 -- Julien Lavergne <email address hidden> Mon, 21 Feb 2011 21:55:43 +0100

Changed in libfm (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers