Pcmanfm crash on invalid path

Bug #1562764 reported by Marcel de Korte on 2016-03-28
62
This bug affects 7 people
Affects Status Importance Assigned to Milestone
libfm (Ubuntu)
Medium
Julien Lavergne
Xenial
Undecided
Unassigned

Bug Description

[Impact]

 * This bug makes pcmanfm crash if an invalid path is selected on the address bar.
 * The fix upstream is quite simple : removing an assert which was not necessary.

[Test Case]

 * Open pcmanfm
 * Go to the address bar and try to enter /this_is_a_test (which should not exist on your system)
 * It should crash pcmanfm without the fix. With the fix, pcmanfm should warn you about the non existence of this path (and stayed open)

[Regression Potential]

 * I can't see any. The fix removes an assert that should not be here (according to upstream), and it's the only change (1 line fix).

[Original bug report]

I do not remember anymore

ProblemType: Crash
DistroRelease: Ubuntu 16.04
Package: pcmanfm 1.2.4-1
ProcVersionSignature: Ubuntu 4.4.0-15.31-generic 4.4.6
Uname: Linux 4.4.0-15-generic i686
ApportVersion: 2.20-0ubuntu3
Architecture: i386
Config_pcmanfm_System_Lubuntu: Error: [Errno 2] Bestand of map bestaat niet: '/etc/xdg/pcmanfm/Lubuntu/lubuntu.conf'
CurrentDesktop: LXDE
Date: Mon Mar 28 11:05:59 2016
ExecutablePath: /usr/bin/pcmanfm
InstallationDate: Installed on 2016-03-27 (0 days ago)
InstallationMedia: Lubuntu 16.04 LTS "Xenial Xerus" - Beta i386 (20160326)
ProcCmdline: pcmanfm --desktop --profile lubuntu
ProcEnviron:
 LANGUAGE=nl_NL
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=nl_NL.UTF-8
 SHELL=/bin/bash
Signal: 6
SourcePackage: pcmanfm
Udisks_dump: Error: [Errno 2] Bestand of map bestaat niet: 'udisks'
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

StacktraceTop:
 g_assertion_message () from /tmp/apport_sandbox_fdOgq5/lib/i386-linux-gnu/libglib-2.0.so.0
 g_assertion_message_expr () from /tmp/apport_sandbox_fdOgq5/lib/i386-linux-gnu/libglib-2.0.so.0
 fm_dir_list_job_run () from /tmp/apport_sandbox_fdOgq5/usr/lib/i386-linux-gnu/libfm.so.4
 job_thread () from /tmp/apport_sandbox_fdOgq5/usr/lib/i386-linux-gnu/libfm.so.4
 g_thread_pool_thread_proxy () from /tmp/apport_sandbox_fdOgq5/lib/i386-linux-gnu/libglib-2.0.so.0

Changed in pcmanfm (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in pcmanfm (Ubuntu):
status: New → Confirmed
tags: added: yakkety
Julien Lavergne (gilir) on 2016-07-03
information type: Private → Public
summary: - file folder crashed
+ Pcmanfm crash on invalid path
Changed in pcmanfm (Ubuntu):
assignee: nobody → Julien Lavergne (gilir)
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in pcmanfm (Ubuntu Xenial):
status: New → Confirmed
Julien Lavergne (gilir) on 2016-07-03
Changed in libfm (Ubuntu):
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Julien Lavergne (gilir)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libfm - 1.2.4-1ubuntu2

---------------
libfm (1.2.4-1ubuntu2) yakkety; urgency=medium

  * debian/patches:
   - 90-SF-1012-Fix-crash-on-non-existent-directory-listing-: From upstream,
     fix crash on invalid path (LP: #1562764).
   - 91-SF-1010-Fix-Launch-in-Terminal-issue-when-custom-arg: From upstream,
     fix usage of additional arguments on terminal settings (LP: #1598595).

 -- Julien Lavergne <email address hidden> Sun, 03 Jul 2016 18:37:07 +0200

Changed in libfm (Ubuntu):
status: In Progress → Fix Released
Julien Lavergne (gilir) on 2016-07-04
description: updated
Julien Lavergne (gilir) on 2016-07-08
no longer affects: pcmanfm (Ubuntu)
no longer affects: pcmanfm (Ubuntu Xenial)

Hello Marcel, or anyone else affected,

Accepted libfm into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/libfm/1.2.4-1ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in libfm (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed
Simon Quigley (tsimonq2) wrote :

This patch fixes it. I installed the update from xenial-proposed and it worked fine.

tags: added: verification-done
removed: verification-needed

The verification of the Stable Release Update for libfm has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libfm - 1.2.4-1ubuntu1.1

---------------
libfm (1.2.4-1ubuntu1.1) xenial-proposed; urgency=medium

  * debian/patches:
   - 90-SF-1012-Fix-crash-on-non-existent-directory-listing-: From upstream,
     fix crash on invalid path (LP: #1562764).

 -- Julien Lavergne <email address hidden> Mon, 04 Jul 2016 22:40:24 +0200

Changed in libfm (Ubuntu Xenial):
status: Fix Committed → Fix Released
Simon Quigley (tsimonq2) wrote :

This fix will be included in the 16.04.1 milestone.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers