lxpanel crashed with SIGSEGV in expand_exec_macros()

Bug #1421508 reported by Dandromb on 2015-02-13
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
libfm (Ubuntu)
Undecided
Unassigned
lxpanel (Ubuntu)
Medium
Unassigned

Bug Description

I tried to launch Firefox, then immediately tried to launch "Photo Lens for Unity," from the Application Launch Bar (aka quick launch bar) on the panel.

I assume lxpanel doesn't like "Photo Lens for Unity" very much.

This crash happened, and I'm honestly not sure why, but I guess it's because of the Photo Lens for Unity.

System Info:

Vivid Vervet

"apt-cache policy lxpanel" gives me the following

lxpanel:
  Installed: 0.7.2-1ubuntu2
  Candidate: 0.7.2-1ubuntu2
  Version table:
 *** 0.7.2-1ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ vivid/universe i386 Packages
        100 /var/lib/dpkg/status

Expected: I'm honestly not sure what I expected to happen

What happened instead: lxpanel seemed to struggle for 15 seconds, then crashed and restarted. Changes I had made to the Application Launch Bar widget were thrown out, but I may not have saved them by the time I crashed the lxpanel.

ProblemType: Crash
DistroRelease: Ubuntu 15.04
Package: lxpanel 0.7.2-1ubuntu2
ProcVersionSignature: Ubuntu 3.18.0-13.14-generic 3.18.5
Uname: Linux 3.18.0-13-generic i686
NonfreeKernelModules: wl
ApportVersion: 2.16.1-0ubuntu2
Architecture: i386
Config_Home_Lubuntu:
 [Command]
 Logout=lxsession-default quit
CurrentDesktop: LXDE
Date: Thu Feb 12 23:19:39 2015
ExecutablePath: /usr/bin/lxpanel
InstallationDate: Installed on 2015-02-11 (1 days ago)
InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Alpha i386 (20150211)
ProcCmdline: lxpanel --profile Lubuntu
ProcEnviron:
 LANGUAGE=en_US
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0xb7667ad4: movsbl (%edi),%edx
 PC (0xb7667ad4) ok
 source "(%edi)" (0x00000000) not located in a known VMA region (needed readable region)!
 destination "%edx" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: lxpanel
StacktraceTop:
 ?? () from /usr/lib/i386-linux-gnu/libfm.so.4
 fm_app_info_launch () from /usr/lib/i386-linux-gnu/libfm.so.4
 fm_app_info_launch_uris () from /usr/lib/i386-linux-gnu/libfm.so.4
 fm_launch_desktop_entry () from /usr/lib/i386-linux-gnu/libfm.so.4
 fm_launch_files () from /usr/lib/i386-linux-gnu/libfm.so.4
Title: lxpanel crashed with SIGSEGV in fm_app_info_launch()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Dandromb (dandromb) wrote :

StacktraceTop:
 expand_exec_macros (launching=<optimized out>, gfiles=<optimized out>, kf=<optimized out>, full_desktop_path=<optimized out>, app=<optimized out>) at base/fm-app-info.c:92
 do_launch (appinfo=0xb7d56300, full_desktop_path=0xb7a8a848 "", kf=0xb7c23e00, inp=0xbfccef24, ctx=0xb7ce6d50, err=0xbfccefa8) at base/fm-app-info.c:246
 fm_app_info_launch (appinfo=0xbfccefa8, files=0x0, launch_context=0xb7ce6d50, error=0xbfccefa8) at base/fm-app-info.c:362
 fm_app_info_launch_uris (appinfo=0xb7d85628, uris=<optimized out>, launch_context=0xb7ce6d50, error=0xbfccefa8) at base/fm-app-info.c:443
 fm_launch_desktop_entry (ctx=0xb7ce6d50, file_or_id=0xb7d49f78 "/usr/share/applications/unity-lens-photos.desktop", uris=0x0, launcher=0xbfccf0f4, user_data=0xbfccf0e8) at base/fm-file-launcher.c:82

Changed in lxpanel (Ubuntu):
importance: Undecided → Medium
summary: - lxpanel crashed with SIGSEGV in fm_app_info_launch()
+ lxpanel crashed with SIGSEGV in expand_exec_macros()
tags: removed: need-i386-retrace
Dandromb (dandromb) on 2015-02-13
information type: Private → Public
LStranger (andrej-rep) wrote :

In fact, it is not a bug in lxpanel, but rather two other bugs:
1) the file /usr/share/applications/unity-lens-photos.desktop (from package unity-lens-photos) is invalid as it does not contain mandatory Exec line;
2) the libfm (from package libfm4) does not check for missing Exec key and therefore crashes.
The upstream of libfm is notified about the crash, see https://sourceforge.net/p/pcmanfm/bugs/953/ bugreport.

Guasong (musclorr) wrote :

I believe this is still occuring in Lubuntu 16.04. I got a segmentation fault in expand_exec_macros while creating a shortcut using lxshortcut. See attached stacktrace

LiveMediaBuild: Lubuntu 16.04 LTS "Xenial Xerus" - Alpha amd64 (20160102)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lxpanel (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers