Install Lubuntu 19.04 desktop icon fails to execute installer in Live ISO

Bug #1813687 reported by Dan Simmons on 2019-01-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libfm-qt (Ubuntu)
High
Dan Simmons

Bug Description

STEPS TO REPRODUCE
1. Double click Install Lubuntu 19.04 icon

EXPECTED RESULTS
Lubuntu Installer is executed.

ACTUAL RESULTS
Execute file dialog appears. "This file 'Install Lubuntu 19.04' seems to be a desktop entry. What do you want to do with it?" The options are "Open" "Execute" and "Cancel"

ProblemType: Bug
DistroRelease: Ubuntu 19.04
Package: pcmanfm-qt 0.14.0-0ubuntu2
ProcVersionSignature: Ubuntu 4.18.0-11.12-generic 4.18.12
Uname: Linux 4.18.0-11-generic x86_64
ApportVersion: 2.20.10-0ubuntu19
Architecture: amd64
CasperVersion: 1.401
CurrentDesktop: LXQt
Date: Tue Jan 29 01:02:37 2019
ExecutablePath: /usr/bin/pcmanfm-qt
LiveMediaBuild: Lubuntu 19.04 "Disco Dingo" - Alpha amd64 (20190128.1)
ProcEnviron:
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=C.UTF-8
 SHELL=/bin/bash
 TERM=qterminal
SourcePackage: pcmanfm-qt
UpgradeStatus: No upgrade log present (probably fresh install)

Dan Simmons (kc2bez) wrote :
Walter Lapchynski (wxl) wrote :

So we had a cherry picked patch that added support for trusted executables based on the gio "metadata::trust" setting:
https://phab.lubuntu.me/rLIBFMQTPACKAGINGc1952b6ddafe9bec2c8b65b31dc052ad9c11c718

However, because the Ubuntu world uses "metadata::trusted:"
https://git.launchpad.net/ubuntu/+source/casper/tree/scripts/casper-bottom/25adduser#n87
and because upstream was unwilling to change it from trust to trusted:
https://github.com/lxqt/libfm-qt/pull/242#issuecomment-430142138
we patched it ourselves:
https://phab.lubuntu.me/rLIBFMQTPACKAGING9abec1c8dddc2cdb5f362a7ecb9ce9bf1cd00831

Unfortunately, we didn't make a new patch, but edited that one:
https://phab.lubuntu.me/rLIBFMQTPACKAGING9abec1c8dddc2cdb5f362a7ecb9ce9bf1cd00831
so when we uploaded 0.14.0, we dropped all the patches and didn't think to keep this:
https://phab.lubuntu.me/rLIBFMQTPACKAGING88d19f7ee1325b28fa94f9507dffe0298ed35f35

So we simply need to restore it and we're set.

To see it in action, do `gio set ~/Desktop/lubuntu-calamares.desktop metadata::trust true`, log out and back in again and you'll notice immediately that the little "!" badge is missing on the left hand side of the icon and that double clicking on it just works.

affects: pcmanfm-qt (Ubuntu) → libfm-qt (Ubuntu)
Changed in libfm-qt (Ubuntu):
status: New → Triaged
importance: Undecided → High
Walter Lapchynski (wxl) wrote :

Oh and BTW this will require a no-change recompile of pcmanfm-qt. We should make notes about all of this in the commit message and the patch itself so we don't forget it again.

Walter Lapchynski (wxl) wrote :

If you want to watch the progress of the fix: https://phab.lubuntu.me/T180

Changed in libfm-qt (Ubuntu):
status: Triaged → Fix Committed
assignee: nobody → Dan Simmons (kc2bez)
Walter Lapchynski (wxl) wrote :

Fix is out in:

libfm-qt (0.14.0-0ubuntu3) disco; urgency=medium

  * Fix metadata for trusting executables.
    - Use Ubuntu standard for trusting executables.

 -- Dan Simmons <email address hidden> Tue, 29 Jan 2019 20:32:19 -0500

Changed in libfm-qt (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers