Missing/broken version info

Bug #1797008 reported by Attila Kovacs
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libfits-java (Debian)
New
Unknown
libfits-java (Ubuntu)
Undecided
Unassigned

Bug Description

The 'fits.jar' archive that is built for Debian (ver. 1.15.2-1) from source has a problem locating the version information resource in the JAR, crashing on Fits.version() calls with an unexpected NullPointerException, and likely breaking any code that tries to call Fits.version().

It looks like the JAR archive build for Debian has the resource:

  /META-INF/maven/gov.nasa.gsfc.heasarc/nom-tam-fits/pom.properties

missing from the JAR archive.

As such it can break any dependent code that uses the Fits.version() call, and which otherwise works as expected with the stock (not Debian-built) 'fits.jar'.

Further info:

> lsb_release -rd:

Description: Ubuntu 18.04.1 LTS
Release: 18.04

> libfits-java version: 1.15.2-1

> Expected behavior:

Fits.version() java calls return the libfits-java underlying library version String (e.g. "1.15.2"), just like the stock JAR library that is provided by nom.tam.fits.

> Actual behavior:

Fits.version() calls result in an unexpected NullPointerException. This is both an unwelcome divergence of behavior the Debian-built JAR from the official 'binary' release, and will break code that tries to use Fits.version() calls.

Attila Kovacs (attipaci)
description: updated
Attila Kovacs (attipaci)
description: updated
tags: added: bioinic cosmic
tags: added: bionic
removed: bioinic
Changed in libfits-java (Debian):
status: Unknown → New
tags: added: focal groovy
removed: cosmic
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.