[MIR] libffado

Bug #416778 reported by Scott Lavender on 2009-08-21
44
This bug affects 7 people
Affects Status Importance Assigned to Milestone
libffado (Ubuntu)
Undecided
Unassigned

Bug Description

libffado is needed in the main repositories to fix several bugs

https://wiki.ubuntu.com/MainInclusionReport/libffado

description: updated
Loïc Minier (lool) wrote :

I probably missed that but was there some public discussion about adding jack support in main?

I understand some flavours of Ubuntu might benefit from it, but I would like to avoid pulling jack related stuff in the seeds already using pulseaudio (Ubuntu Netbook Remix, Ubuntu desktop, Ubuntu Studio...). First because this eats space on the CD and second because our audio stack is already quite fragile and at a sore point so I'd rather avoid making it more complex than it already is.

If you'd have some pointers on public discussions on this topic, or if you could start such a discussion, it would help documenting the consensus around addition of jack deps to various packages. Thanks!

Changed in libffado (Ubuntu):
status: New → Incomplete
Eric Hedekar (stochastic) wrote :

I've begun to revive the discussion on Jack entering main.

Here are links to the threads:
ubuntu-devel https://lists.ubuntu.com/archives/ubuntu-devel/2009-August/028784.html
ubuntu-devel-discuss https://lists.ubuntu.com/archives/ubuntu-devel-discuss/2009-August/009237.html
ubuntu-studio-devel https://lists.ubuntu.com/archives/ubuntu-studio-devel/2009-August/001873.html

Already a number of people have replied with favorable opinions on the matter. Please add your opinion to any of these threads.

Martin Pitt (pitti) on 2009-08-26
summary: - main inclusion request for libffado
+ [MIR] libffado
Eric Hedekar (stochastic) wrote :

It has been ten days now since the discussions were started and the only voices that spoke have been 100% in favor of the inclusion of Jack in Main. Switching this bug to Confirmed.

Changed in libffado (Ubuntu):
status: Incomplete → Confirmed
Loïc Minier (lool) wrote :

Hmpf the .diff.gz transports a new upstream version; I understand we inherit the tarball + diff from Debian but would it be possible to fix this mixup in Debian? i.e. have a .tar.gz which really contains the target upstream files rather than updating them in the .diff. Thanks!

Matthias Klumpp (ximion) wrote :

Hello!
Is there anything I can do to help fixing this bug? Maybe I could modify the package so it does not have this issue... (but I think you did it already)
To fix this in Debian, we may need to contact Adrian Knoth (maintainer of that package) and submit a patch for this. Is there planned in this direction?

Michael Terry (mterry) wrote :
Matthias Klumpp (ximion) wrote :

The problem is fixed in the Debian GIT repositories. A new package will be uploaded soon.
What else has to be done to get this in main?

Martin Pitt (pitti) wrote :

> What else has to be done to get this in main?

Something actually needs to pull it into main, via depending on it or seeding it.

If ~ubuntustudio-dev takes care about this package, it's approved. (Probably too late for karmic, but for lucid)

Matthias Klumpp (ximion) wrote :

JackAudio depends on libffado, so applications can now be linked against libjack? (Jack will be in main also if libffado is in main)

Matthias Klumpp [2009-10-13 21:33 -0000]:
> JackAudio depends on libffado, so applications can now be linked against
> libjack? (Jack will be in main also if libffado is in main)

jack also depends on freebob, which also needs an MIR (or get dropped
as a dependency -- I thought ffado was the successor to freebob?).

jack itself needs a MIR as well, and a review that it does not contain
this nasty suid root helper any more (we had to disable that in the
past when it was in main).

Just to let you know, I've uploaded libfaado 2.0.0 to Debian/sid (many thanks to Adrian Knot who prepared the update), hope it helps.

I would be really pleased to see Jack in Ubuntu's main. If there's anything else that we can do on the Debian-side to help, just let me know.

Martin Pitt (pitti) wrote :

I synced libffado, we have no remaining changes (lpia is no more). Will review the package tomorrow again, but by itself it's probably okay. (And thanks for taking good care of it on the Debian side!)

What's left is the issues in comment 8, comment 10, and someone in Ubuntu to take ownership of Jack integration.

Changed in libffado (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
Martin Pitt (pitti) wrote :

Packaging, bugs, etc. look good, approved.

Changed in libffado (Ubuntu):
assignee: Martin Pitt (pitti) → nobody
status: Confirmed → Fix Committed
Steve Kowalik (stevenk) wrote :

Promoted to main.

Changed in libffado (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.