libertine crashed with SIGSEGV in strlen()

Bug #1620016 reported by krishnan sampath on 2016-09-04
32
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Libertine
Status tracked in Devel
Devel
High
Larry Price
Trunk
High
Larry Price
libertine (Ubuntu)
High
Larry Price

Bug Description

Using ubuntu-desktop-session package, tied to use libertine container on both unity 7 and 8. The libertine app does not open. On unity 7, i get the usual application crash message from whoopsie

ProblemType: Crash
DistroRelease: Ubuntu 16.10
Package: libertine 1.3.1+16.10.20160812.3-0ubuntu1
ProcVersionSignature: Ubuntu 4.4.0-9136.55-generic 4.4.16
Uname: Linux 4.4.0-9136-generic x86_64
ApportVersion: 2.20.3-0ubuntu7
Architecture: amd64
CurrentDesktop: Unity
Date: Sun Sep 4 13:10:15 2016
ExecutablePath: /usr/bin/libertine
InstallationDate: Installed on 2016-08-19 (15 days ago)
InstallationMedia: Ubuntu 16.10 "Yakkety Yak" - Alpha amd64 (20160811)
ProcCmdline: libertine
ProcEnviron:
 PATH=(custom, user)
 SHELL=/bin/bash
 LANG=en_IN
 LANGUAGE=en_IN:en
 XDG_RUNTIME_DIR=<set>
SegvAnalysis:
 Segfault happened at: 0x7febb5e4af06 <strlen+38>: movdqu (%rax),%xmm4
 PC (0x7febb5e4af06) ok
 source "(%rax)" (0x00000021) not located in a known VMA region (needed readable region)!
 destination "%xmm4" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: libertine
StacktraceTop:
 strlen () at ../sysdeps/x86_64/strlen.S:106
 QCoreApplication::arguments() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
 ?? () from /usr/lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
 ?? () from /usr/lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
 _SmcProcessMessage () from /usr/lib/x86_64-linux-gnu/libSM.so.6
Title: libertine crashed with SIGSEGV in strlen()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Related branches

krishnan sampath (tskrishnan) wrote :

StacktraceTop:
 strlen () at ../sysdeps/x86_64/strlen.S:106
 QCoreApplication::arguments() () from /tmp/apport_sandbox__Gb8Zo/usr/lib/x86_64-linux-gnu/libQt5Core.so.5
 sm_performSaveYourself(QXcbSessionManager*) () from /tmp/apport_sandbox__Gb8Zo/usr/lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
 sm_saveYourselfCallback(_SmcConn*, void*, int, int, int, int) () from /tmp/apport_sandbox__Gb8Zo/usr/lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
 _SmcProcessMessage (iceConn=0x56254ceee420, clientData=0x56254ceeede0, opcode=<optimized out>, length=<optimized out>, swap=0, replyWait=<optimized out>, replyReadyRet=0x7fff06000308) at ../../src/sm_process.c:241

Changed in libertine (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libertine (Ubuntu):
status: New → Confirmed
information type: Private → Public
ventrical (dale-f-beaudoin) wrote :

On first run you can load xapps in unity8 but then, after log-off or restart and it will crash in unity7 when you try to restart it.

Larry Price (larryprice) wrote :

It looks like you were using version 1.3.1 of libertine when this crash occurred. The latest version of libertine on yakkety is 1.4.1. Can you upgrade libertine and verify whether the crash still occurs?

Larry Price (larryprice) wrote :

OK I just updated and can confirm this is also happening with 1.4.1. libertine works fine when run from the terminal, but not when selected from the Dash on unity 7.

Larry Price (larryprice) wrote :

If I copy/paste the libertine binary after building locally, the app runs fine from the Dash. But if I install the deb built locally, the app fails to start. I'm guessing this has something to do with the way we are trying to find the QML in the main loop.

Changed in libertine:
status: New → In Progress
importance: Undecided → High
assignee: nobody → Larry Price (larryprice)

Fix committed into lp:libertine at revision 308, scheduled for release in libertine, milestone Unknown

Changed in libertine:
status: In Progress → Fix Committed
Changed in libertine (Ubuntu):
status: Confirmed → In Progress
importance: Medium → High
assignee: nobody → Larry Price (larryprice)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libertine - 1.4.2+16.10.20161003-0ubuntu1

---------------
libertine (1.4.2+16.10.20161003-0ubuntu1) yakkety; urgency=medium

  [ Chris Townsend ]
  * Add a new update_apt_cache method and call that when needed, especially
    when installing new packages. (LP: #1625627)
  * Install matchbox-window-manager instead of the matchbox metapackage in
    a container. (LP: #1628563)

  [ Larry Price ]
  * Remove bad status update preventing archive removal from container.
  * Make debconf interactions work correctly from GUI. (LP: #1627757)
  * Fix crash on start in Unity 7 when launching from the dash.
    (LP: #1620016)

 -- Christopher Townsend <email address hidden> Mon, 03 Oct 2016 19:50:24 +0000

Changed in libertine (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers