UTF8 support not enabled in libedit?

Bug #1276836 reported by linas on 2014-02-05
This bug report is a duplicate of:  Bug #816758: libedit lacks utf-8 support. Edit Remove
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
libedit (Ubuntu)
Undecided
Unassigned

Bug Description

Kudos for supporting the latest version of libedit in the new releases ... but ... one of the great benefits of the latest version is that it supports unicode -- UTF8 strings. From what I can tell, the current ubuntu builds do not enable this. So, for example:

https://launchpadlibrarian.net/154417352/buildlog_ubuntu-trusty-amd64.libedit_3.1-20130712-2_UPLOADING.txt.gz

reports:

checking if you want wide-character code... no

To get UTF8 support one normally needs to ./configure --enable-widec which then defines WIDECHAR in config.h which causes symbols like history_w history_wend history_winit and el_wget el_wgetc el_wgets to appear in the library.

It would be great if you did this: I'm exhausted in explaining to my users where they can get libedit and how to build it from source :-(

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libedit - 3.1-20140213-1

---------------
libedit (3.1-20140213-1) unstable; urgency=medium

  * Upload to unstable

 -- Sylvestre Ledru <email address hidden> Wed, 12 Mar 2014 15:19:30 +0100

Changed in libedit (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.