libdvdread: Can't seek to block XXXXX

Bug #983535 reported by David Seppi on 2012-04-16
64
This bug affects 15 people
Affects Status Importance Assigned to Milestone
libdvdread (Ubuntu)
Undecided
Unassigned

Bug Description

Same problemlem as described here:
https://bugs.launchpad.net/bugs/446664

I'm opening a new bug, because the referred bug expired and it seems to affect Ubuntu 11.10, too.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: libdvdread4 4.1.3-10ubuntu4.1
ProcVersionSignature: Ubuntu 3.0.0-19.32-generic 3.0.27
Uname: Linux 3.0.0-19-generic i686
NonfreeKernelModules: nvidia
ApportVersion: 1.23-0ubuntu4
Architecture: i386
Date: Tue Apr 17 01:01:33 2012
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
ProcEnviron:
 LANGUAGE=de_AT:de
 PATH=(custom, user)
 LANG=de_AT.UTF-8
 SHELL=/bin/bash
SourcePackage: libdvdread
UpgradeStatus: Upgraded to oneiric on 2011-10-15 (184 days ago)

Related branches

David Seppi (dseppi) wrote :
David Seppi (dseppi) wrote :

vlc just stops some movies a couple of minutes before they end with
libdvdread: Can't seek to block XXXXXXX
written to stderr.

David Seppi (dseppi) wrote :

I think I've found the source of the bug:
When I open my DVD device direclty over the eject button, the old DVD is still mounted, even if I insert a new DVD.
Nautilus still shows the title of the old DVD in the directory tree.
I assume that the OS still works with the size of the old DVD and can't seek the new DVD to blocks that would be out of range at the old DVD.

Ejecting the DVD via nautilus solves the problem.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libdvdread (Ubuntu):
status: New → Confirmed
Torsten Bronger (bronger) wrote :

I confirm for Ubuntu 12.10 both this bug and the workaround mentioned in comment #3.

Stefan Löffler (st.loeffler) wrote :

Same here on 13.04 (amd64)

Eric Goulet (eric-m-goulet) wrote :

I confirm for Ubuntu 13.10 (amd64) both this bug and the workaround mentioned in comment #3.

quequotion (quequotion) wrote :

One more thing that was broken after upgrading to Saucy.

Singpolyma (singpolyma) wrote :

I can confirm this on LUbuntu 13.10 (i386)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libdvdread - 5.0.0-1ubuntu1

---------------
libdvdread (5.0.0-1ubuntu1) utopic; urgency=medium

  * Merge from Debian unstable. Remaining changes:
    - Re-add missing install-css.sh.
    - debian/control: add Suggests for install-css.sh on debhelper,
      fakeroot, and build-essential.
    - debian/rules: install install-css.sh, leave perms executable.

libdvdread (5.0.0-1) unstable; urgency=medium

  [ Matteo F. Vescovi ]
  * New upstream release
    - debian/patches: patchset re-worked against v4.9.9
  * Imported Upstream version 4.9.9
  * debian/patches: patchset re-worked against v4.9.9

  [ Benjamin Drung ]
  * dvdread-config is gone now.
  * Drop dvdread-config_manpage.patch.
  * DEVELOPMENT-POLICY.txt is gone.
  * debian/rules: Update list of unused files.
  * Add missing pkg-config dependency.

  [ Reinhard Tartler ]
  * Imported Upstream version 5.0.0
    - Fixes libdvdread runs out of memory (LP: #377414)
    - Fixes: libdvdread4 unable to read Wall.e encrypted DVDs (LP: #590983)
    - Fixes: libdvdread: Can't seek to block (LP: #983535, #446664, #1066317)
    - Fixes: Zero check failed in ifo_read.c:904 for pgc->subp_control[i]
             = 0x00000001 (LP: #1179913, Closes: #504256)
  * Refresh patches, drop merged patches
 -- Benjamin Drung <email address hidden> Sun, 17 Aug 2014 23:03:17 +0200

Changed in libdvdread (Ubuntu):
status: Confirmed → Fix Released
astro (bernard-godard) wrote :

This bug was reported in 2012, but the fix is only in Utopic and later...
14.04 LTS still has package libdvdread4 in version 4.2.1-2ubuntu1.
Version 5.0.0-1ubuntu1 in Utopic should be backported to LTS.

See also http://www.jbkempf.com/blog/post/2014/dvdread-dvdnav-and-dvdcss

astro (bernard-godard) wrote :

In the meantime, backports seem available in this PPA:
https://launchpad.net/~n-muench/+archive/ubuntu/vlc2

Tuomo Sipola (tuomosipola) wrote :

Still affects me.

Ubuntu 14.10 utopic
nautilus 1:3.10.1-0ubuntu15
libdvdread 5.0.0-1ubuntu1

This is really confusing for a user! I thought that there was a physical problem with the disc. Thanks to David Seppi for explaining a workaround in the meanwhile.

Tuomo Sipola (tuomosipola) wrote :

Still affects me. I think it was fixed for Wily but now that I upgraded to Xenial 16.04, this bug is back.

faissaloo (faissaloo) wrote :

Still affects me on 18.04

frankster (wtfrank) wrote :

I've experienced this error with a couple of DVDs on 18.04.1

if I do "vobcopy -m" on some DVDs this error appears.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers