libdvdread runs out of memory following libdvdread: CHECK_VALUE failed in ifo_read.c:1913 on certain DVDs - Copy protection on The Dark Knight and other recent DVDs

Bug #377414 reported by Neil Jeffery on 2009-05-16
214
This bug affects 42 people
Affects Status Importance Assigned to Milestone
libdvdread (Debian)
New
Undecided
Unassigned
libdvdread (Ubuntu)
High
Unassigned

Bug Description

I get the following error using lsdvd with a copy of "The Dark Knight"

*** libdvdread: CHECK_VALUE failed in ifo_read.c:1913 ***
*** for pgci_ut->nr_of_lus < 100 **

(after a fairly long pause, this message repeats)

Once the command is typed the computer becomes very slow to respond, including jerky mouse movements. I couldn't play the disk in Totem which is what lead me to run the command manually from the terminal.

I have not had problems with any other dvds, just this one. I managed to watch the disc successfully on my Xbox360 so I know it is working

Possibly affected DVDs:
  * The Dark Knight
  * Up
  * Toy Story 1

Extra info:

$ lsb_release -rd
Description: Ubuntu 9.04
Release: 9.04

$ apt-cache policy libdvdread4
libdvdread4:
  Installed: 4.1.3-4ubuntu2
  Candidate: 4.1.3-4ubuntu2
  Version table:
 *** 4.1.3-4ubuntu2 0
        500 http://gb.archive.ubuntu.com jaunty/universe Packages
        100 /var/lib/dpkg/status

Related branches

Neil Jeffery (neilneil2000) wrote :

Could this be some new encryption technique? I only ask because Windows doesn't seem to like it either.

If I run DVD Decrypter it throws the following error:

ParseVTSM Runtime Exception!

File: VTS_06_0.IFO

And I can't play it in Windows Media player on two Windows Vista Machines

Tom Asbury (tasbury) wrote :

I have very similar behavior on the 9.10 and 9.04 machines around my house. I load Ponyo (Miyazaki's latest, just out on DVD), run

# lsdvd /dev/sr0

and get the following output:
====================

libdvdread: Using libdvdcss version 1.2.10 for DVD access

*** libdvdread: CHECK_VALUE failed in ifo_read.c:1202 ***
*** for vts_ptt_srpt->title[i].ptt[j].pgn != 0 ***

*** libdvdread: CHECK_VALUE failed in ifo_read.c:1913 ***
*** for pgci_ut->nr_of_lus < 100 ***

At which point, AFAICT, libdvdread runs until it has eaten all of ram and swap, then crashes. vlc will play the dvd without problems, so it's most probably not an issue with the disk.

Also, the bonus disk, and dvd's I've converted in the past, still work fiine with lsdvd.

Josh Simmons (simmons-44) wrote :

I seem to be able to play the dvd (Dark Knight also), but attempting to backup with thoggen or any other dvd accessing application gives me this error so maybe Totem has worked around / fixed it inadvertently or otherwise.

apt-cache policy libdvdread4
libdvdread4:
  Installed: 4.1.3-5ubuntu2
  Candidate: 4.1.3-5ubuntu2
  Version table:
 *** 4.1.3-5ubuntu2 0
        500 http://au.archive.ubuntu.com karmic/universe Packages
        100 /var/lib/dpkg/status

apt-cache policy totem
totem:
  Installed: 2.28.2-0ubuntu3
  Candidate: 2.28.2-0ubuntu3
  Version table:
 *** 2.28.2-0ubuntu3 0
        500 http://au.archive.ubuntu.com karmic-updates/main Packages
        100 /var/lib/dpkg/status
     2.28.1-0ubuntu4 0
        500 http://au.archive.ubuntu.com karmic/main Packages

apt-cache policy thoggen
thoggen:
  Installed: 0.7.1-1ubuntu1
  Candidate: 0.7.1-1ubuntu1
  Version table:
 *** 0.7.1-1ubuntu1 0
        500 http://au.archive.ubuntu.com karmic/universe Packages
        100 /var/lib/dpkg/status

Bryce Harrington (bryce) on 2010-05-20
Changed in libdvdread (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
summary: - libdvdread libdvdread: CHECK_VALUE failed in ifo_read.c:1913
+ libdvdread libdvdread: CHECK_VALUE failed in ifo_read.c:1913 on "The
+ Dark Knight"

I'm guessing that on "The Dark Knight" is so that it can be tested. It also fails on "Criminal Minds Season 4" (UK region) as well. Happy to test any updated software.

Changed in libdvdread (Debian):
status: Unknown → Incomplete

There is some evidence that this problem might be specific to fact that DVDs in question are DVD-9 (larger capacity) than
most DVDs (which are DVD-5).

Similar stuff is happening to people with Avatar DVD (which I think is also DVD-9).

David:

More evidence you are right: the Ponyo dvd has ~8gb on it, which would
seem to indicate (I don't actually know any other way) that it is a DVD-9.

On 7/13/2010 7:13 AM, David Cook wrote:
>
> There is some evidence that this problem might be specific to fact that DVDs in question are DVD-9 (larger capacity) than
> most DVDs (which are DVD-5).
>
> Similar stuff is happening to people with Avatar DVD (which I think is
> also DVD-9).
>

David:

More evidence you are right: the Ponyo dvd has ~8gb on it, which would seem to indicate (I don't actually know any other way) that it is a DVD-9.

Conor McMonagle (omgconor) wrote :

DVD: Ultramarathon Man: 50 Marathons, 50 States, 50 Days.

Won't play in Totem,

When running:
HandBrakeCLI -i /dev/dvd --main-feature -o Ultra.Marathon.Man -Z Normal -a 0

Lots of :

*** libdvdread: CHECK_VALUE failed in ifo_read.c:1981 ***
*** for (pgci_ut->lu[i].exists & 0x07) == 0 ***

Followed by:

*** Zero check failed in ifo_read.c:1794
    for pgcit->zero_1 = 0x5bb7

*** libdvdread: CHECK_VALUE failed in ifo_read.c:1798 ***
*** for pgcit->nr_of_pgci_srp < 10000 ***

*** Zero check failed in ifo_read.c:1794
    for pgcit->zero_1 = 0x5bb7

*** libdvdread: CHECK_VALUE failed in ifo_read.c:1798 ***
*** for pgcit->nr_of_pgci_srp < 10000 ***

*** Zero check failed in ifo_read.c:1794
    for pgcit->zero_1 = 0x5bb7

*** libdvdread: CHECK_VALUE failed in ifo_read.c:1798 ***
*** for pgcit->nr_of_pgci_srp < 10000 ***

Segmentation fault

Possibly relevant info:

$ dvd+rw-mediainfo /dev/dvd
INQUIRY: [ATAPI ][iHAS220 6 ][8L02]
GET [CURRENT] CONFIGURATION:
 Mounted Media: 10h, DVD-ROM
 Speed Descriptor#0: 08/332999 R@0.7x1385=944KB/s W@0.7x1385=944KB/s
READ DVD STRUCTURE[#0h]:
 Media Book Type: 00h, DVD-ROM book [revision 0]
 Legacy lead-out at: 1933184*2KB=3959160832
DVD-ROM media detected, exiting…

$ df
Filesystem 1K-blocks Used Available Use% Mounted on
…..
…..
/dev/sr0 7732188 7732188 0 100% /media/cdrom0

$ lsb_release -rd
Description: Ubuntu 10.04.1 LTS
Release: 10.04

$ apt-cache policy libdvdread4
libdvdread4:
  Installed: 4.1.3-8ubuntu1
  Candidate: 4.1.3-8ubuntu1
  Version table:
 *** 4.1.3-8ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ lucid/universe Packages
        100 /var/lib/dpkg/status

Joe User (axyz-yahoo) wrote :

This also effects reading of "Up" DVD on kubuntu 10.10, amd64:

>lsdvd /dev/sr1
libdvdread: Using libdvdcss version 1.2.10 for DVD access

*** libdvdread: CHECK_VALUE failed in /build/buildd/libdvdread-4.1.3/src/ifo_read.c:1202 ***
*** for vts_ptt_srpt->title[i].ptt[j].pgn != 0 ***

*** libdvdread: CHECK_VALUE failed in /build/buildd/libdvdread-4.1.3/src/ifo_read.c:1914 ***
*** for pgci_ut->nr_of_lus < 100 ***

jim brown (jimandsalbrown) wrote :

Hi also had similar problems playing the camp rock 2 dvd for my daughter.

jim@brownie-safe-config:~$ lsb_release -rd
Description: Ubuntu 10.10
Release: 10.10

jim@brownie-safe-config:~$ apt-cache policy libdvdread4
libdvdread4:
  Installed: 4.1.3-10ubuntu2
  Candidate: 4.1.3-10ubuntu2
  Version table:
 *** 4.1.3-10ubuntu2 0
        500 http://ftp.ticklers.org/archive.ubuntu.org/ubuntu/ maverick/universe i386 Packages
        100 /var/lib/dpkg/status

Totem (mplayer backend) playback is jerky,
Note: Xine plays the DVD perfectly

If I issue the following command as above I get CHECK_VALUE errors
jim@brownie-safe-config:~$ lsdvd
libdvdread: Using libdvdcss version 1.2.10 for DVD access

*** libdvdread: CHECK_VALUE failed in /build/buildd/libdvdread-4.1.3/src/ifo_read.c:1202 ***
*** for vts_ptt_srpt->title[i].ptt[j].pgn != 0 ***

*** libdvdread: CHECK_VALUE failed in /build/buildd/libdvdread-4.1.3/src/ifo_read.c:1914 ***
*** for pgci_ut->nr_of_lus < 100 ***

Other information captured above

jim@brownie-safe-config:~$ dvd+rw-mediainfo /dev/dvd
INQUIRY: [MATSHITA][DVD-RAM UJ-845S ][D201]
GET [CURRENT] CONFIGURATION:
 Mounted Media: 10h, DVD-ROM
 Current Write Speed: 8.0x1385=11080KB/s
 Write Speed #0: 8.0x1385=11080KB/s
 Write Speed #1: 4.0x1385=5540KB/s
 Write Speed #2: 2.0x1385=2770KB/s
 Write Speed #3: 1.0x1385=1385KB/s
 Speed Descriptor#0: 00/2464153 R@8.0x1385=11080KB/s W@8.0x1385=11080KB/s
 Speed Descriptor#1: 00/2464153 R@4.0x1385=5540KB/s W@4.0x1385=5540KB/s
 Speed Descriptor#2: 00/2464153 R@2.0x1385=2770KB/s W@2.0x1385=2770KB/s
 Speed Descriptor#3: 00/2464153 R@1.0x1385=1385KB/s W@1.0x1385=1385KB/s
READ DVD STRUCTURE[#0h]:
 Media Book Type: 00h, DVD-ROM book [revision 0]
 Legacy lead-out at: 0*2KB=0
DVD-ROM media detected, exiting...
jim@brownie-safe-config:~$ df
Filesystem 1K-blocks Used Available Use% Mounted on
/dev/sr0 5861324 5861324 0 100% /media/C2R-0E-UW1.1_DES

Yuval Hager (yhager) wrote :

Some for "My Neighbour Totoro" (another Miyazaki...)

Andy Barclay (abb-acm) wrote :

Same error with My Neighbor Totoro
Ubuntu 10.04.2 LTS
libdvdread4:
  Installed: 4.1.3-8ubuntu1
/dev/sr0 6374546 6374546 0 100% /media/cdrom0

I just experienced this problem with the MIcMacs DVD on a 10.04 system, but had no such problem with another DVD-9, so it must be something more specific than that.

According to Jim Brown's comment, the problem still exists in 10.10.

summary: - libdvdread libdvdread: CHECK_VALUE failed in ifo_read.c:1913 on "The
- Dark Knight"
+ libdvdread runs out of memory following libdvdread: CHECK_VALUE failed
+ in ifo_read.c:1913 on certain DVDs
Changed in libdvdread (Ubuntu):
status: Confirmed → Triaged
Øyvind Repvik (repvik) wrote :

I can confirm it also fails on "A Single Man" on Ubuntu 10.10.

Mark Fraser (launchpad-mfraz) wrote :

Not sure if this is related, but I'm trying to rip the audio from a DVD created on a DVD recorder. I keep getting lines:

libdvdread: CHECK_VALUE failed in /build/buildd/libdvdread-4.1.3/src/nav_read.c:263
for dsi->dsi_gi.zero1 == 0

Bryce Harrington (bryce) on 2011-10-15
summary: libdvdread runs out of memory following libdvdread: CHECK_VALUE failed
- in ifo_read.c:1913 on certain DVDs
+ in ifo_read.c:1913 on certain DVDs - Copy protection on The Dark Knight
+ and other recent DVDs
Bryce Harrington (bryce) on 2011-10-15
Changed in libdvdread (Ubuntu):
importance: Medium → High
Changed in libdvdread (Debian):
status: Incomplete → Fix Released
rogerdpack (rogerdpack) wrote :

Anybody know what caused the resolution here?

Bryce Harrington (bryce) wrote :

rogerdpack, probably fixed in Ubuntu by 101-fix-msb-unicode.patch. Can you confirm it is working properly now?

Changed in libdvdread (Ubuntu):
status: Triaged → Incomplete
Russell Smith (mr-russ) wrote :

This issue still exists in Ubuntu 11.04.

$ aptitude show libdvdread4
Package: libdvdread4
State: installed
Automatically installed: yes
Version: 4.1.3-10ubuntu3

Example;
$ lsdvd Videos/toy_story.iso
libdvdread: Using libdvdcss version 1.2.10 for DVD access

*** libdvdread: CHECK_VALUE failed in /build/buildd/libdvdread-4.1.3/src/ifo_read.c:1202 ***
*** for vts_ptt_srpt->title[i].ptt[j].pgn != 0 ***

*** libdvdread: CHECK_VALUE failed in /build/buildd/libdvdread-4.1.3/src/ifo_read.c:1914 ***
*** for pgci_ut->nr_of_lus < 100 ***

Killed

(It bloats to fill over 2G of RAM, then OOM killer kills it)

Changed in libdvdread (Ubuntu):
status: Incomplete → Confirmed
Bryce Harrington (bryce) wrote :

Russell,

Patch 101-fix-msb-unicode.patch is fixed on 11.04 in natty-updates. Please enable the natty-updates PPA and update to 4.1.3-10ubuntu3.1 and verify whether or not that fixes the bug in your case.

libdvdread (4.1.3-10ubuntu3.1) natty-proposed; urgency=low

  * debian/patches/101-fix-msb-unicode.patch: Fixes unicode issue encountered
    when playing DVDs with newer protection. (LP: #852345)

 -- Robert BARABAS <dc@0xdc.org> Sun, 18 Sep 2011 13:56:04 -0400

Changed in libdvdread (Ubuntu):
status: Confirmed → Incomplete

@mr-russ: I saw your question in IRC. You do not have the latest version according to aptitude. If you already have the natty-updates repo enabled, you may need to refresh the sources with:
apt-get (or aptitude) update

If you still don't get the 4.1.3-10ubuntu3.1 version, install it manually from: 4.1.3-10ubuntu3.1

Russell Smith (mr-russ) wrote :

I have finally managed to upgrade to the version specified and the problem still exists.

$ aptitude show libdvdread4
Package: libdvdread4
State: installed
Automatically installed: yes
Version: 4.1.3-10ubuntu3.1

output from lsdvd is unchanged;

$ lsdvd ~mr-russ/Videos/toy_story.iso
libdvdread: Using libdvdcss version 1.2.10 for DVD access

*** libdvdread: CHECK_VALUE failed in /build/buildd/libdvdread-4.1.3/src/ifo_read.c:1202 ***
*** for vts_ptt_srpt->title[i].ptt[j].pgn != 0 ***

*** libdvdread: CHECK_VALUE failed in /build/buildd/libdvdread-4.1.3/src/ifo_read.c:1914 ***
*** for pgci_ut->nr_of_lus < 100 ***

Killed

Changed in libdvdread (Ubuntu):
status: Incomplete → Confirmed
Chris Tubutis (ctubutis) wrote :

I can echo Russell's experience, it still exists for me, too.

10.04

libdvdread 4.1.3-10

Oddly enough, also with Toy Story (from Blockbuster) ;)

Download full text (5.5 KiB)

I'm unable to play "Transformers 3 - Dark of the Moon" with what looks like a similar failure, whilst Movie Player is able to play the disk (Totem 3.0.1 with 0.10.35 gstreamer on ubuntu). Version info for vlc and libdvdnav and log below.

cefn@cefn-dell-oneiric:~$ vlc --version
VLC media player 2.0.0 Twoflower (revision 2.0.0-0-g421a4fc)
VLC version 2.0.0 Twoflower (2.0.0-0-g421a4fc)
Compiled by buildd on nannyberry.ppa (Mar 3 2012 01:06:44)
Compiler: gcc version 4.6.1 (Ubuntu/Linaro 4.6.1-9ubuntu3)
This program comes with NO WARRANTY, to the extent permitted by law.
You may redistribute it under the terms of the GNU General Public Licence;
see the file named COPYING for details.
Written by the VideoLAN team; see the AUTHORS file.

Here's a console log from the GUI when I try to open the DVD direct (similar experience with an iso image). I upgraded to a newer VLC version using ppa:bdrung/backports. That gives me libdvdnav 4.2.0-1~oneiric1~ppa1 which I've combined with vlc 2.0.0-6~ppa1 . Trying to play the video gives the log below with the last lines, (or very similar lines) seeming to run forever and ever.

cefn@cefn-dell-oneiric:~$ vlc 2>&1 | head -n 100
[0x9450920] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
libdvdnav: Using dvdnav version 4.2.0
libdvdread: Using libdvdcss version 1.2.11 for DVD access
libdvdnav: DVD Title: TRANSFORMERS_3
libdvdnav: DVD Serial Number: 3F298BD7
libdvdnav: DVD Title (Alternative): TRANSFORMERS_3
libdvdnav: Unable to find map file '/home/cefn/.dvdnav/TRANSFORMERS_3.map'
libdvdnav: DVD disk reports itself with Region mask 0x00ed0000. Regions: 2 5

libdvdread: Attempting to retrieve all CSS keys
libdvdread: This can take a _long_ time, please be patient

libdvdread: Get key for /VIDEO_TS/VIDEO_TS.VOB at 0x0000020b
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_01_1.VOB at 0x000006f4
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_02_1.VOB at 0x00000712
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_03_1.VOB at 0x00000761
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_04_1.VOB at 0x0000077f
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_05_0.VOB at 0x00000ac8
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_05_1.VOB at 0x000067bf
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_06_0.VOB at 0x00000ac8
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_06_1.VOB at 0x000067bf
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_07_0.VOB at 0x00000ac8
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_07_1.VOB at 0x000067bf
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_08_0.VOB at 0x00000ac8
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_08_1.VOB at 0x000067bf
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_09_0.VOB at 0x00000ac8
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_09_1.VOB at 0x000067bf
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_10_0.VOB at 0x00000ac8
libdvdread: Elapsed time 0
libdvdread: Get key for...

Read more...

Tim Hockin (thockin-hockin) wrote :

Seems to be the same problem on "The Black Cauldron", just purchased.

Running MakeMKV shows LOTS of warnings about the DVD contents.

Tim Hockin (thockin-hockin) wrote :

Sorry, I should have said - this is on Lucid x64

Bryce Harrington (bryce) wrote :

I managed to get ahold of Toy Story 1 (and 2) and am reproducing the bug in Precise.

*** libdvdread: CHECK_VALUE failed in /build/buildd/libdvdread-4.2.0/src/ifo_read.c:1257 ***
*** for vts_ptt_srpt->title[i].ptt[j].pgn != 0 ***

*** libdvdread: CHECK_VALUE failed in /build/buildd/libdvdread-4.2.0/src/ifo_read.c:1986 ***
*** for pgci_ut->nr_of_lus < 100 ***

libdvdread: Can't allocate memory for file read!
No VTS_TMAPT available - skipping.

Those errors appear to be repeating a couple times a minute or so. The DVDs play fine in a regular DVD player. dd_rescue didn't work on it (nor dd).

  for(i = 0; i < vts_ptt_srpt->nr_of_srpts; i++) {
    CHECK_VALUE(vts_ptt_srpt->title[i].nr_of_ptts < 1000); /* ?? */
    for(j = 0; j < vts_ptt_srpt->title[i].nr_of_ptts; j++) {
      CHECK_VALUE(vts_ptt_srpt->title[i].ptt[j].pgcn != 0 );
      CHECK_VALUE(vts_ptt_srpt->title[i].ptt[j].pgcn < 1000); /* ?? */
      CHECK_VALUE(vts_ptt_srpt->title[i].ptt[j].pgn != 0); /* <--- line 1257 */
      CHECK_VALUE(vts_ptt_srpt->title[i].ptt[j].pgn < 100); /* ?? */
    }
  }
...
  CHECK_ZERO(pgci_ut->zero_1);
  CHECK_VALUE(pgci_ut->nr_of_lus != 0);
  CHECK_VALUE(pgci_ut->nr_of_lus < 100); /* ?? 3-4 ? */ /* <-- line 1986 */
  CHECK_VALUE((uint32_t)pgci_ut->nr_of_lus * PGCI_LU_SIZE < pgci_ut->last_byte);

Let's focus this bug report only on DVDs which hit the pgci_ut->nr_of_lus assertions. Other error messages like the ones in comments #8 and #15 may be unrelated bugs that deserve to be investigated separately.

Bryce Harrington (bryce) wrote :

I've listed the movies where there is log evidence given that it's the same problem.

Please don't comment that it affects such and such a movie without posting the log output with the error messages. These failures can all look the same, but unless it's exactly the same assertion being hit, it's not likely to be the same bug.

Bryce Harrington (bryce) wrote :

The debian bug report was closed as fixed for The Dark Knight and Wall-E. I tested Wall-E and verified that the out-of-memory condition was solved, but it still did not produce a usable backup, so presumably there are still issues needing figured out.

Bryce Harrington (bryce) on 2012-05-14
Changed in libdvdread (Debian):
importance: Unknown → Undecided
status: Fix Released → New
Bryce Harrington (bryce) on 2012-05-14
Changed in libdvdread (Ubuntu):
status: Confirmed → Triaged
Bryce Harrington (bryce) wrote :

There are references to several of these movies in this thread: http://forum.doom9.org/archive/index.php/t-157734.html

It mentions that these movies use the multi-angling feature to substitute translated text into frames of the movies and that screws things up. However, it says ddrescue should work in this case, but in testing both gddrescue and ddrescue I found neither produced usable images.

Here's the output of lsdvd for Toy Story 1 and Dumbo:

hubert@ubuntu:~$ lsdvd /dev/dvd1
libdvdread: Using libdvdcss version 1.2.12 for DVD access

*** libdvdread: CHECK_VALUE failed in /build/buildd/libdvdread-4.2.0/src/ifo_read.c:1257 ***
*** for vts_ptt_srpt->title[i].ptt[j].pgn != 0 ***

*** libdvdread: CHECK_VALUE failed in /build/buildd/libdvdread-4.2.0/src/ifo_read.c:1986 ***
*** for pgci_ut->nr_of_lus < 100 ***

I'm using precise...

Bryce Harrington (bryce) wrote :

I haven't tested this patch but it sounds like it should fix the issue. It adds reference counting to avoid getting stuck re-reading repeated language unit tables and pgc's.

The patch specifically mentions it fixes "Up" and "Dark Knight" but may well improve reading of other similar dvds.

This is a pretty invasive patch so before can be considered for SRU, we will need ample testing to verify it a) fixes a variety of different dvd's, and b) causes no regressions for unaffected dvd's.

Please test this patch and provide feedback here.

tags: added: patch
Bryce Harrington (bryce) wrote :

Here's a PPA with builds of libdvdread with this patch: https://launchpad.net/~bryce/+archive/lp377414

Bryce Harrington (bryce) wrote :

I tested the patch (and another upstream patch to remove an extraneous free) using my son's Toy Story DVD. It does prevent the out-of-memory condition, but (at least for Toy Story) it achieves this simply by failing early.

I suppose failing early is preferable to gobbling all memory and disk space, but it still isn't providing a usable copy, so I couldn't call this a fix. Maybe it works better on some of the other mentioned DVDs, but I don't have access to them at the moment so can't confirm.

I've updated the above ppa to current SVN tip for libdvdread (+ debian patches) if others wish to test other problematic DVDs with it.

Bryce Harrington (bryce) wrote :

FTR, the lsdvd output is:

$ lsdvd /dev/sr0

*** libdvdread: CHECK_VALUE failed in ifo_read.c:1246 ***
*** for vts_ptt_srpt->title[i].ptt[j].pgn != 0 ***

*** libdvdread: CHECK_VALUE failed in ifo_read.c:1246 ***
*** for vts_ptt_srpt->title[i].ptt[j].pgn != 0 ***

libdvdread: Invalid IFO for title 2 (VTS_02_0.BU).
Can't open ifo 2!

Bryce Harrington (bryce) on 2013-05-02
description: updated

Thanks Bryce, I tried the patch with The FIghter (Mark Wahlberg, Christian Bale), which was a DVD which had the problem before, on Xubuntu 12.04.2. I ran vlc in terminal and received a constant loop of messages, which I had to quit with ctrl-c twice (although this version of libdvdread didn't swallow up all available memory):

*** libdvdread: CHECK_VALUE failed in ifo_read.c:1226 ***
*** for data[i] + sizeof(ptt_info_t) <= vts_ptt_srpt->last_byte + 1 ***

I'll test any other DVDs as I come across them.

After having the same problems with The Fighter and Capote, some experimentation with vlc actually got them working fine. It might work for some of the other problem dvds, so it's worth trying at least.

(Replace /dev/sr0 with your own dvd drive in the command below: vlc's dvdsimple option disables dvd menus, and I start the film at a specific chapter and title (just 40 seconds in for Capote, and at the start for The Fighter (for some reason #69:1 works).

(The aspect ratio will be wrong for some reason, so just adjust it in the options; stating it on the cmd-line didn't seem to work)

For Capote:

vlc dvdsimple://dev/sr0#1:1 :disc-caching=300 :start-time=40.000

For The Fighter:

vlc dvdsimple://dev/sr0#69:1 :disc-caching=300

Rumpeltux (rumpeltux) wrote :

Any progress on this? I ran into the same error with a DVD from 2011. I tried the suggested patch, but only get the same error Bryce already pasted.

    …
    Can't open ifo 2!

Rumpeltux (rumpeltux) wrote :

So turns out the check is probably too strict. Removing it works fine at least for the DVDs I had the issue with. Here’s a patch.

Tuomo Sipola (tuomosipola) wrote :

Any chances of having that as a PPA?

Martin Thoma (themoosemind) wrote :

For "Iron Man 3":

#####################################################

$ lsdvd /dev/sr0
libdvdread: Using libdvdcss version 1.2.12 for DVD access

*** libdvdread: CHECK_VALUE failed in ifo_read.c:1781 ***
*** for info_length % sizeof(uint32_t) == 0 ***

*** libdvdread: CHECK_VALUE failed in ifo_read.c:1678 ***
*** for c_adt->cell_adr_table[i].start_sector < c_adt->cell_adr_table[i].last_sector ***

[many more]

Disc Title: IRON_MAN_3_D1
Title: 01, Length: 00:00:00.010 Chapters: 01, Cells: 01, Audio streams: 00, Subpictures: 00

Title: 02, Length: 02:05:25.020 Chapters: 17, Cells: 18, Audio streams: 04, Subpictures: 04

[many more]

Longest track: 62
###########################################################
$ apt-cache policy libdvdread4
libdvdread4:
  Installed: 4.2.0+20120521-2ubuntu1
  Candidate: 4.2.0+20120521-2ubuntu1
  Version table:
 *** 4.2.0+20120521-2ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ quantal/universe i386 Packages
        100 /var/lib/dpkg/status
###########################################################

Work-around:

vlc dvdsimple://dv/sr0#1:1 :disc-caching=300 :start-time=1.000

Martin Thoma (themoosemind) wrote :

$ lsb_release -rd
Description: Linux Mint 14 Nadia
Release: 14
###########################################
$ dvd+rw-mediainfo /dev/dvd
INQUIRY: [MATSHITA][DVD-RAM UJ8B0AW ][1.00]
GET [CURRENT] CONFIGURATION:
 Mounted Media: 10h, DVD-ROM
 Current Write Speed: 8.0x1385=11080KB/s
 Write Speed #0: 8.0x1385=11080KB/s
 Write Speed #1: 8.0x1385=11080KB/s
 Write Speed #2: 6.0x1385=8310KB/s
 Write Speed #3: 4.0x1385=5540KB/s
 Write Speed #4: 2.0x1385=2770KB/s
 Write Speed #5: 1.0x1385=1385KB/s
 Speed Descriptor#0: 00/4006607 R@3101059.2x1385=4294967040KB/s W@8.0x1385=11080KB/s
 Speed Descriptor#1: 00/4006607 R@3101059.2x1385=4294967040KB/s W@8.0x1385=11080KB/s
 Speed Descriptor#2: 00/4006607 R@3101059.2x1385=4294967040KB/s W@6.0x1385=8310KB/s
 Speed Descriptor#3: 00/4006607 R@3101059.2x1385=4294967040KB/s W@4.0x1385=5540KB/s
 Speed Descriptor#4: 00/4006607 R@3101059.2x1385=4294967040KB/s W@2.0x1385=2770KB/s
 Speed Descriptor#5: 00/4006607 R@3101059.2x1385=4294967040KB/s W@1.0x1385=1385KB/s
READ DVD STRUCTURE[#0h]:
 Media Book Type: 00h, DVD-ROM book [revision 0]
 Legacy lead-out at: 2037152*2KB=4172087296
DVD-ROM media detected, exiting...
###########################################
$ df
Filesystem 1K-blocks Used Available Use% Mounted on
[...]
/dev/sr0 8012538 8012538 0 100% /media/moose/IRON_MAN_3_D1

When using the work-around with "vlc dvdsimple", vlc jumps back a few minutes quite often.

Martin Thoma (themoosemind) wrote :

It works with banshee :-)

Massimo Viaro (max-232) wrote :

while VLC is having trouble, Xine is working for me.

Rafael Levi (rlevi66) wrote :
Download full text (9.3 KiB)

I'm having the bug still with ubuntu 13.10.
Here is the output of lsdvd:
libdvdread: Using libdvdcss version 1.2.13 for DVD access

*** libdvdread: CHECK_VALUE failed in ifo_read.c:914 ***
*** for pgc->cell_playback_offset != 0 ***

Disc Title: PAIN_AND_GAIN
Title: 01, Length: 00:00:00.076 Chapters: 01, Cells: 01, Audio streams: 00, Subpictures: 00

Title: 02, Length: 00:00:01.276 Chapters: 01, Cells: 02, Audio streams: 00, Subpictures: 01

Title: 03, Length: 02:09:28.243 Chapters: 23, Cells: 48, Audio streams: 04, Subpictures: 06

Title: 04, Length: 02:09:28.243 Chapters: 23, Cells: 48, Audio streams: 04, Subpictures: 06

Title: 05, Length: 02:09:28.243 Chapters: 23, Cells: 48, Audio streams: 04, Subpictures: 06

Title: 06, Length: 02:09:28.243 Chapters: 23, Cells: 48, Audio streams: 04, Subpictures: 06

Title: 07, Length: 02:09:28.243 Chapters: 23, Cells: 48, Audio streams: 04, Subpictures: 06

Title: 08, Length: 02:09:28.243 Chapters: 23, Cells: 48, Audio streams: 04, Subpictures: 06

Title: 09, Length: 02:10:01.086 Chapters: 23, Cells: 48, Audio streams: 04, Subpictures: 06

Title: 10, Length: 02:10:18.186 Chapters: 23, Cells: 48, Audio streams: 04, Subpictures: 06

Title: 11, Length: 02:13:50.086 Chapters: 23, Cells: 48, Audio streams: 04, Subpictures: 06

Title: 12, Length: 02:09:02.053 Chapters: 23, Cells: 48, Audio streams: 04, Subpictures: 06

Title: 13, Length: 02:11:26.143 Chapters: 23, Cells: 48, Audio streams: 04, Subpictures: 06

Title: 14, Length: 02:09:47.266 Chapters: 23, Cells: 48, Audio streams: 04, Subpictures: 06

Title: 15, Length: 02:13:49.166 Chapters: 23, Cells: 48, Audio streams: 04, Subpictures: 06

Title: 16, Length: 02:10:20.033 Chapters: 23, Cells: 48, Audio streams: 04, Subpictures: 06

Title: 17, Length: 02:11:59.110 Chapters: 23, Cells: 48, Audio streams: 04, Subpictures: 06

Title: 18, Length: 02:05:03.210 Chapters: 23, Cells: 48, Audio streams: 04, Subpictures: 06

Title: 19, Length: 02:06:53.233 Chapters: 23, Cells: 48, Audio streams: 04, Subpictures: 06

Title: 20, Length: 02:10:13.186 Chapters: 23, Cells: 48, Audio streams: 04, Subpictures: 06

Title: 21, Length: 02:09:28.243 Chapters: 23, Cells: 48, Audio streams: 04, Subpictures: 06

Title: 22, Length: 02:09:28.243 Chapters: 23, Cells: 48, Audio streams: 04, Subpictures: 06

Title: 23, Length: 02:09:28.243 Chapters: 23, Cells: 48, Audio streams: 04, Subpictures: 06

Title: 24, Length: 02:09:28.243 Chapters: 23, Cells: 48, Audio streams: 04, Subpictures: 06

Title: 25, Length: 02:09:28.243 Chapters: 23, Cells: 48, Audio streams: 04, Subpictures: 06

Title: 26, Length: 02:09:28.243 Chapters: 23, Cells: 48, Audio streams: 04, Subpictures: 06

Title: 27, Length: 02:09:28.243 Chapters: 23, Cells: 48, Audio streams: 04, Subpictures: 06

Title: 28, Length: 02:12:05.100 Chapters: 23, Cells: 48, Audio streams: 04, Subpictures: 06

Title: 29, Length: 02:09:31.233 Chapters: 23, Cells: 48, Audio streams: 04, Subpictures: 06

Title: 30, Length: 02:08:59.233 Chapters: 23, Cells: 48, Audio streams: 04, Subpictures: 06

Title: 31, Length: 02:06:35.066 Chapters: 23, Cells: 48, Audio streams: 04, Subpictures: 06

Title: 32, Length: 02:05:07.253 Chapters: 23, Cells: 48, ...

Read more...

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libdvdread - 5.0.0-1ubuntu1

---------------
libdvdread (5.0.0-1ubuntu1) utopic; urgency=medium

  * Merge from Debian unstable. Remaining changes:
    - Re-add missing install-css.sh.
    - debian/control: add Suggests for install-css.sh on debhelper,
      fakeroot, and build-essential.
    - debian/rules: install install-css.sh, leave perms executable.

libdvdread (5.0.0-1) unstable; urgency=medium

  [ Matteo F. Vescovi ]
  * New upstream release
    - debian/patches: patchset re-worked against v4.9.9
  * Imported Upstream version 4.9.9
  * debian/patches: patchset re-worked against v4.9.9

  [ Benjamin Drung ]
  * dvdread-config is gone now.
  * Drop dvdread-config_manpage.patch.
  * DEVELOPMENT-POLICY.txt is gone.
  * debian/rules: Update list of unused files.
  * Add missing pkg-config dependency.

  [ Reinhard Tartler ]
  * Imported Upstream version 5.0.0
    - Fixes libdvdread runs out of memory (LP: #377414)
    - Fixes: libdvdread4 unable to read Wall.e encrypted DVDs (LP: #590983)
    - Fixes: libdvdread: Can't seek to block (LP: #983535, #446664, #1066317)
    - Fixes: Zero check failed in ifo_read.c:904 for pgc->subp_control[i]
             = 0x00000001 (LP: #1179913, Closes: #504256)
  * Refresh patches, drop merged patches
 -- Benjamin Drung <email address hidden> Sun, 17 Aug 2014 23:03:17 +0200

Changed in libdvdread (Ubuntu):
status: Triaged → Fix Released
PJSingh5000 (pjsingh5000) wrote :

Tried libdvdread 5.0.0-1ubuntu1(x64) on Ubuntu 14.10 x64, but recieved the following error...

libdvdread: Found 21 VTS's
libdvdread: Elapsed time 3
libdvdnav: decoder.c: [WARNING, unknown bits: 1000000000080000]
libdvdnav: decoder.c: [WARNING, unknown bits: 1000000000000000]

*** libdvdread: CHECK_VALUE failed in src/ifo_read.c:914 ***
*** for pgc->cell_playback_offset != 0 ***

PJSingh5000 (pjsingh5000) wrote :

One more note, the above CHECK_VALUE failed error ocurrs for one (newer) DVD I tested, but does not ocurr for another (couple of years old) DVD. I can share information about these two DVDs if someone can suggest what info would be useful to help pinpoint the issue?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.