dvdbackup exited with "Please send bug report - no VTS_TMAPT ??"

Bug #374031 reported by Rachel Greenham on 2009-05-09
44
This bug affects 8 people
Affects Status Importance Assigned to Milestone
libdvdread (Debian)
Fix Released
Unknown
libdvdread (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: dvdbackup

After ripping most of the content of a DVD, dvdbackup exited with:

Please send bug report - no VTS_TMAPT ??

So here's the bug report. :-)

NB: libdvdcss2 is also installed and probably used in this instance.

DVD in question was Stargate Atlantis season 4 disc 1, region 2. Commandline was:

dvdbackup -i /dev/sr0 -v -M -n 'stargate-s4d1'

Version data:

rachel@mab:~$ lsb_release -rd
Description: Ubuntu 9.04
Release: 9.04
rachel@mab:~$ apt-cache policy dvdbackup
dvdbackup:
  Installed: 0.2-2build1
  Candidate: 0.2-2build1
  Version table:
 *** 0.2-2build1 0
        500 http://gb.archive.ubuntu.com jaunty/universe Packages
        100 /var/lib/dpkg/status
rachel@mab:~$ apt-cache policy libdvdcss2
libdvdcss2:
  Installed: 1.2.10-0.2medibuntu1
  Candidate: 1.2.10-0.2medibuntu1
  Version table:
 *** 1.2.10-0.2medibuntu1 0
        500 http://packages.medibuntu.org jaunty/free Packages
        100 /var/lib/dpkg/status
rachel@mab:~$

Related branches

Benjamin Drung (bdrung) wrote :

Can you post the complete output of dvdbackup? E.g. run "dvdbackup -i /dev/sr0 -v -M -n 'stargate-s4d1' > dvdbackup.log" and attach dvdbackup.log to this bug report.

Changed in dvdbackup (Ubuntu):
status: New → Incomplete

This is what I got:

piraja@crashboombang:~$ dvdbackup --mirror --output=/media/vaja/video/ -v -M > dvdbackup.log
libdvdread: Using libdvdcss version 1.2.10 for DVD access

File sizes for Title set 0 VIDEO_TS.XXX
IFO = 12288, MENU_VOB = 34816
At top of loop
After opening files
After Menu VOB check
After Menu Title VOB check

File sizes for Title set 1 i.e.VTS_01_X.XXX
IFO: 16384, MENU: 10240
VOB 1 is 452608
Bottom of loop
At top of loop
After opening files
After Menu VOB check
After Menu Title VOB check

File sizes for Title set 2 i.e.VTS_02_X.XXX
IFO: 55296, MENU: 60469248
VOB 1 is 1073684480
VOB 2 is 1073543168
VOB 3 is 1073340416
VOB 4 is 1073397760
VOB 5 is 458338304
Bottom of loop

libdvdread: Attempting to retrieve all CSS keys
libdvdread: This can take a _long_ time, please be patient

libdvdread: Get key for /VIDEO_TS/VIDEO_TS.VOB at 0x00000123
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_01_0.VOB at 0x00000152
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_01_1.VOB at 0x00000157
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_02_0.VOB at 0x00000257
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_02_1.VOB at 0x000075ad
libdvdread: Elapsed time 0
libdvdread: Found 2 VTS's
libdvdread: Elapsed time 0
Please send bug report - no VTS_TMAPT ??
Please send bug report - no VTS_TMAPT ??
piraja@crashboombang:~$

The above is copied from the terminal – for some reason, the file dvdbackup.log was created but contained nothing. PFA a screenshot of the VIDEO_TS contents.

Download full text (3.6 KiB)

I've had a repeat occurrence; this time on Karmic, and with the Region 2 DVD of Star Wars II.

as the previous poster says, it looks like dvdbackup doesn't send anything to stdout; presumably all the output we get is to stderr, which, as before, isn't very informative, only giving us the "Please send bug report - no VTS_TMAPT ??" message before quitting.

Time has passed:

rachel@mab:~$ lsb_release -rd
Description: Ubuntu karmic (development branch)
Release: 9.10
rachel@mab:~$ apt-cache policy dvdbackup
dvdbackup:
  Installed: 0.4.1-1
  Candidate: 0.4.1-1
  Version table:
 *** 0.4.1-1 0
        500 http://gb.archive.ubuntu.com karmic/universe Packages
        100 /var/lib/dpkg/status

stdout output is empty.

Console output (presumably stderr), in its entirety:

rachel@mab:~$ dvdbackup -M -o . -i /dev/sr0 -v -n 'Star Wars 2' > dvdbackup.log
libdvdread: Using libdvdcss version 1.2.10 for DVD access

File sizes for Title set 0 VIDEO_TS.XXX
IFO = 22528, MENU_VOB = 694272
At top of loop
After opening files
After Menu VOB check
After Menu Title VOB check

File sizes for Title set 1 i.e. VTS_01_X.XXX
IFO: 131072, MENU: 582295552
VOB 1 is 1073709056
VOB 2 is 1073709056
VOB 3 is 1073709056
VOB 4 is 1073709056
VOB 5 is 1073709056
VOB 6 is 643905536
Bottom of loop
At top of loop
After opening files
After Menu VOB check
After Menu Title VOB check

File sizes for Title set 2 i.e. VTS_02_X.XXX
IFO: 18432, MENU: 917504
VOB 1 is 33290240
Bottom of loop
At top of loop
After opening files
After Menu VOB check
After Menu Title VOB check

File sizes for Title set 3 i.e. VTS_03_X.XXX
IFO: 18432, MENU: 233472
VOB 1 is 25176064
Bottom of loop
At top of loop
After opening files
After Menu VOB check
After Menu Title VOB check

File sizes for Title set 4 i.e. VTS_04_X.XXX
IFO: 18432, MENU: 827392
VOB 1 is 96466944
Bottom of loop
At top of loop
After opening files
After Menu VOB check
After Menu Title VOB check

File sizes for Title set 5 i.e. VTS_05_X.XXX
IFO: 18432, MENU: 827392
VOB 1 is 2564096
Bottom of loop
At top of loop
After opening files
After Menu VOB check
After Menu Title VOB check

File sizes for Title set 6 i.e. VTS_06_X.XXX
IFO: 16384, MENU: 827392
VOB 1 is 27650048
Bottom of loop

libdvdread: Attempting to retrieve all CSS keys
libdvdread: This can take a _long_ time, please be patient

libdvdread: Get key for /VIDEO_TS/VIDEO_TS.VOB at 0x00025830
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_01_0.VOB at 0x000259ce
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_01_1.VOB at 0x0006b072
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_02_0.VOB at 0x00337c92
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_02_1.VOB at 0x00337e52
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_03_0.VOB at 0x0033bde3
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_03_1.VOB at 0x0033be55
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_04_0.VOB at 0x0033ee6c
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_04_1.VOB at 0x0033f000
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_05_0.VOB at 0x0034a811
libdvdread: Ela...

Read more...

Another data point fwiw - Fairmount, on Mac OS X, which does the same job but uses VLC for its backend (it basically presents the decrypted disc as a mounted volume) - rips the same DVD with no problems.

Benjamin Drung (bdrung) on 2009-09-25
Changed in dvdbackup (Ubuntu):
status: Incomplete → Confirmed
importance: Undecided → Medium
hyperqbe (hyperqbe) wrote :

The message is actually being printed by libdvdread, and there is a debian bug (316926) for this as well:
   http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=316926

VPablo (villumar) wrote :

I think this bug is related to this other:
https://bugs.launchpad.net/ubuntu/+source/gstreamer0.10/+bug/466389

And is a bug from libdvdread, not dvdbackup nor ogmrip (for me).

B rian Styles (brian-cdmnet) wrote :

I'd query comment #6 - for me, the proposed fix for the linked bug 466389 has not resolved the problem which occurs on some DVDs but not others, on a machine with karmic-proposed and one without.

Bryce Harrington (bryce) on 2010-04-03
affects: dvdbackup (Ubuntu) → libdvdread (Ubuntu)
Changed in libdvdread (Debian):
status: Unknown → Confirmed
George Politis (gpolitis) wrote :

I don't think this problem is related with bug 466389, like commen #6 suggests. Bug 466389 is supposed to be fixed with libdvdnav-4.1.3-3ubuntu1, but I have libdvdnav-4.1.3-3ubuntu1 and I just got the error message.

Bryce Harrington (bryce) on 2010-11-05
summary: - dvdbackup exited with "Please send bug report"...
+ dvdbackup exited with "Please send bug report - no VTS_TMAPT ??"
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libdvdread - 4.1.3-10ubuntu3

---------------
libdvdread (4.1.3-10ubuntu3) natty; urgency=low

  * debian/patches/100-quell-vts-tmapt-warning.patch: Stifle the "Please
    send bug report - no VTS_TMAPT ??" message. Upstream indicates it's
    merely a warning and not an indication of a bug that needs reported.
    (LP: #374031)
 -- Bryce Harrington <email address hidden> Thu, 04 Nov 2010 23:03:29 -0700

Changed in libdvdread (Ubuntu):
status: Confirmed → Fix Released
Changed in libdvdread (Debian):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.