Can't allocate memory while viewing DVD

Bug #367450 reported by ketchers on 2009-04-26
4
Affects Status Importance Assigned to Milestone
libdvdnav
Invalid
Undecided
Unassigned
libdvdread (Ubuntu)
Undecided
Unassigned

Bug Description

Trying to open a DVD with totem/vlc/mplayer/ etc all end with something like

libdvdnav: ifoRead_TITLE_VOBU_ADMAP vtsi failed
libdvdread: Can't allocate memory for file read!
libdvdnav: ifoRead_VOBU_ADMAP vtsi failed

I have ubuntu-restricted installed, ran the script libdvdread4/install-css, etc. I had this working in 8.10 - this is a 9.04 issue.

ProblemType: Bug
Architecture: i386
Dependencies:
 libgcc1 1:4.3.3-5ubuntu4
 gcc-4.3-base 4.3.3-5ubuntu4
 findutils 4.4.0-2ubuntu4
 libc6 2.9-4ubuntu6
DistroRelease: Ubuntu 9.04
Package: libdvdread4 4.1.3-4ubuntu2
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/zsh
SourcePackage: libdvdread
Uname: Linux 2.6.28-11-generic i686

Raf Geens (rafgeens) wrote :

I ran into the same issue, getting the "ifoRead_TITLE_VOBU_ADMAP vtsi failed" message with I think vlc, and an assert failing in libdvdnav with totem. The Planet Earth DVD I was trying to play was region 2+4. It played correctly on my Windows install that had an older version of vlc. I tested several other DVD's in Ubuntu with vlc, and they all worked correctly. They were regions 0, 1 or 2. Next I tried the Planet Earth DVD again, and it magically worked. After rebooting it still worked.

Raf Geens (rafgeens) wrote :

I had the same issue with the same DVD on a clean Ubuntu 9.10 install.

Steps to reproduce:
1. Insert the Planet Earth DVD
2. Open the dvd with the default Movie Player in the popup
3. Play the dvd
4. Crash

See the attached libdvdnav_error_totem_bbcdvd for the output when running totem in a terminal, as well as libdvdnav_error_vlc_bbcdvd for vlc.

Since I remembered from the previous time that I got it to work after playing several other DVD's, I tried playing a Battlestar Galactica DVD that had the same 2+4 region. That one played correctly (see the attached libdvdnav_success_totem_bsg). When I tried the Planet Earth DVD again, it played correctly as well (libdvdnav_success_totem_bbcdvd).

Raf Geens (rafgeens) wrote :
Raf Geens (rafgeens) wrote :
Raf Geens (rafgeens) wrote :
Anibal Avelar (aavelar) wrote :

It's true. I had the same error with a new DVD, I tried many things to play it, but nothing worked, I always got the same error:
"libdvdnav: ifoRead_VOBU_ADMAP vtsi failed"

but I tried the Raf's tip: I played an old DVD, it works fine from the begin. After I tried again (without reboot) with the new DVD (where I had the error), the DVD works fine now!!!!

Very strange behavior. But works.

Regards.

Bryce Harrington (bryce) wrote :

This bug sounds like it may be an upstream issue, rather than a problem specific to Ubuntu, so this bug report should probably be filed upstream.

First though, can this issue be reproduced on Maverick?

Changed in libdvdread (Ubuntu):
status: New → Incomplete
Bryce Harrington (bryce) wrote :

[Closing as expired due to no response in a year]

Changed in libdvdread (Ubuntu):
status: Incomplete → Invalid
Changed in libdvdnav:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers