Ubuntu

replace medibuntu with videolan archive for install-css

Reported by Jonathan Riddell on 2013-09-11
88
This bug affects 16 people
Affects Status Importance Assigned to Milestone
libdvdread (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned
Quantal
Undecided
Unassigned
Raring
Undecided
Unassigned
Saucy
Undecided
Unassigned

Bug Description

The Medibuntu archive is shut down. The videolan developers have put up a new archive for libdvdcss. The install-css.sh script should be updated to use this new archive.

Jonathan Riddell (jr) wrote :

TEST CASE
Run /usr/share/doc/libdvdread4/install-css.sh from the new package
Ensure libdvdcss is installed from videolan correct and you can plan DVD videos

Changed in libdvdread (Ubuntu Saucy):
status: New → Fix Released
Jonathan Riddell (jr) wrote :

Uploading an SRU to desktop supported releases

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libdvdread (Ubuntu Precise):
status: New → Confirmed
Changed in libdvdread (Ubuntu Quantal):
status: New → Confirmed
Changed in libdvdread (Ubuntu Raring):
status: New → Confirmed

Hello Jonathan, or anyone else affected,

Accepted libdvdread into raring-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/libdvdread/4.2.0+20121016-1ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in libdvdread (Ubuntu Raring):
status: Confirmed → Fix Committed
tags: added: verification-needed
Changed in libdvdread (Ubuntu Quantal):
status: Confirmed → Fix Committed
Brian Murray (brian-murray) wrote :

Hello Jonathan, or anyone else affected,

Accepted libdvdread into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/libdvdread/4.2.0+20120521-2ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Brian Murray (brian-murray) wrote :

Hello Jonathan, or anyone else affected,

Accepted libdvdread into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/libdvdread/4.2.0-1ubuntu4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in libdvdread (Ubuntu Precise):
status: Confirmed → Fix Committed
Simon Déziel (sdeziel) on 2013-09-24
tags: added: verification-done-precise
tags: added: verification-done-raring
Mateo Salta (mateo-salta) wrote :

It worked on 12.04, can we get the this going. Since now - Medibuntu IS shutdown, and the current script breaks.

description: updated
description: updated
Doug McMahon (mc3man) wrote :

now that the medibuntu server has closed would be nice to push updates to all current Ubuntu releases
verified on 12.04, 12.10, 13.04

tags: added: verification-done
removed: verification-needed
tags: added: verification-done-quantal
Mateo Salta (mateo-salta) wrote :

Looks like we have several people that tested for 12.04 - Currently people are asking "Ask Ubuntu" about why the old one broke - since in the meantime the wiki instructions have not changed (won't need to change after this update) http://askubuntu.com/questions/356046/i-cant-install-libdvdcss-script-not-finding-medibuntu-how-to-get-dvd-playbac , would be nice to have a "update and try again answer"

Scott Kitterman (kitterman) wrote :

OK. I can release the update for 12.04. Given the situation, I'll make an exception to the no updates on weekends and do it later today.

If someone can test 12.10 and/or 13.04 in the meantime, I'll release those too.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libdvdread - 4.2.0-1ubuntu4

---------------
libdvdread (4.2.0-1ubuntu4) precise-proposed; urgency=low

  * Replace medibuntu with VideoLan in install-css.sh LP: #1223928
 -- Jonathan Riddell <email address hidden> Wed, 11 Sep 2013 16:23:44 +0100

Changed in libdvdread (Ubuntu Precise):
status: Fix Committed → Fix Released
Mateo Salta (mateo-salta) wrote :

Ok, Tested again on diffrent computer running Kubuntu 12.04 using libdvdread4_4.2.0-1ubuntu4_i386 , which pulls from stable libdvdcss2_1.2.13-0_i386.deb using the script. Once installed playback works as expected in dragon and vlc player.

12.10 and 13.04 (32bit virtual machine tests) both play dvd as expected in default "Movie Player" "Videos" respectivly, performance lacking due to using virturalization only.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libdvdread - 4.2.0+20121016-1ubuntu1.1

---------------
libdvdread (4.2.0+20121016-1ubuntu1.1) raring; urgency=low

  * Replace medibuntu with VideoLan in install-css.sh LP: #1223928
 -- Jonathan Riddell <email address hidden> Wed, 11 Sep 2013 16:31:06 +0100

Changed in libdvdread (Ubuntu Raring):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libdvdread - 4.2.0+20120521-2ubuntu1.1

---------------
libdvdread (4.2.0+20120521-2ubuntu1.1) quantal-proposed; urgency=low

  * Replace medibuntu with VideoLan in install-css.sh LP: #1223928
 -- Jonathan Riddell <email address hidden> Wed, 11 Sep 2013 16:29:12 +0100

Changed in libdvdread (Ubuntu Quantal):
status: Fix Committed → Fix Released
Scott Kitterman (kitterman) wrote :

Thanks. Released for all supported releases now.

Mateo Salta (mateo-salta) wrote :

Sent an update on versions to the wiki, and comments to update, for users on AU. Thank you all for awesome work.

Changed in libdvdread (Ubuntu Raring):
assignee: nobody → Karlheinz Dorner (khdorner)
assignee: Karlheinz Dorner (khdorner) → nobody
Julian Alarcon (alarconj) wrote :

One question, they already have saucy and other ubuntu releases (http://download.videolan.org/pub/debian/), why the file install-css.sh is using Debian Stable?

sitert=http://download.videolan.org/
site=${sitert}pub/debian/stable/

(The files seems equals, but maybe in a futere some of them can differ to other)

Joel Ramirez (seaguru77) wrote :

N: Ignoring file 'medibuntu.lis' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers