Zero check failed in ifo_read.c:904 for pgc->subp_control[i] = 0x00000001

Bug #1179913 reported by Jani Uusitalo on 2013-05-14
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
libdvdread (Ubuntu)
Undecided
Unassigned

Bug Description

When reading 'The Snowman' DVD from 2004, I get this output:

jani@saegusa:DVD$ dvdbackup -i /dev/sr0 -M
libdvdread: Using libdvdcss version 1.2.12 for DVD access

libdvdread: Attempting to retrieve all CSS keys
libdvdread: This can take a _long_ time, please be patient

libdvdread: Get key for /VIDEO_TS/VIDEO_TS.VOB at 0x0000015a
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_01_0.VOB at 0x000001c1
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_01_1.VOB at 0x00023749
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_02_0.VOB at 0x000241f0
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_02_1.VOB at 0x0002423d
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_03_0.VOB at 0x00024f03
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_03_1.VOB at 0x00024f50
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_04_0.VOB at 0x00025d8f
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_04_1.VOB at 0x00025ddc
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_05_0.VOB at 0x000e2c65
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_05_1.VOB at 0x000e2cb2
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_06_0.VOB at 0x000eb4df
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_06_1.VOB at 0x000eb52c
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_07_0.VOB at 0x000f7617
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_07_1.VOB at 0x000f7664
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_08_0.VOB at 0x00128eb1
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_08_1.VOB at 0x00128efe
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_09_0.VOB at 0x001da296
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_09_1.VOB at 0x001da2e3
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_10_0.VOB at 0x001e3856
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_10_1.VOB at 0x001e38a3
libdvdread: Elapsed time 0
libdvdread: Found 10 VTS's
libdvdread: Elapsed time 0
*** Zero check failed in /build/buildd/libdvdread-4.2.0/src/ifo_read.c:904
    for pgc->subp_control[i] = 0x00000001
*** Zero check failed in /build/buildd/libdvdread-4.2.0/src/ifo_read.c:904
    for pgc->subp_control[i] = 0x00000001
*** Zero check failed in /build/buildd/libdvdread-4.2.0/src/ifo_read.c:904
    for pgc->subp_control[i] = 0x00000001

This doesn't prevent dvdbackup from finishing up, and the resulting copy looks to be fine (on cursory inspection). While dvdbackup is running, the issue also doesn't cause an OOM as in Bug #377414. Still, I tested libdvdread4_4.2.0+20130428-0ubuntu0~bryce~precise1_amd64.deb from Bryce Harrington's PPA [1], but it just slightly changed the "Zero check failed" output:

*** Zero check failed in ifo_read.c:904
    for pgc->subp_control[i] = 0x00000001
*** Zero check failed in ifo_read.c:904
    for pgc->subp_control[i] = 0x00000001
*** Zero check failed in ifo_read.c:904
    for pgc->subp_control[i] = 0x00000001

This DVD is the only one I've come across manifesting this, and I've backed up some 40 DVDs so far on this same setup.

*[1] https://launchpad.net/~bryce/+archive/lp377414/+build/4542681

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: libdvdread4 4.2.0-1ubuntu3
ProcVersionSignature: Ubuntu 3.5.0-29.49~precise1-generic 3.5.7.11
Uname: Linux 3.5.0-29-generic x86_64
ApportVersion: 2.0.1-0ubuntu17.2
Architecture: amd64
CheckboxSubmission: 09ae689090491ca53449589269e4bfd8
CheckboxSystem: edda5d4f616ca792bf437989cb597002
Date: Tue May 14 14:49:44 2013
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
MarkForUpload: True
SourcePackage: libdvdread
UpgradeStatus: Upgraded to precise on 2011-11-21 (540 days ago)

Related branches

Jani Uusitalo (uusijani) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libdvdread (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libdvdread - 5.0.0-1ubuntu1

---------------
libdvdread (5.0.0-1ubuntu1) utopic; urgency=medium

  * Merge from Debian unstable. Remaining changes:
    - Re-add missing install-css.sh.
    - debian/control: add Suggests for install-css.sh on debhelper,
      fakeroot, and build-essential.
    - debian/rules: install install-css.sh, leave perms executable.

libdvdread (5.0.0-1) unstable; urgency=medium

  [ Matteo F. Vescovi ]
  * New upstream release
    - debian/patches: patchset re-worked against v4.9.9
  * Imported Upstream version 4.9.9
  * debian/patches: patchset re-worked against v4.9.9

  [ Benjamin Drung ]
  * dvdread-config is gone now.
  * Drop dvdread-config_manpage.patch.
  * DEVELOPMENT-POLICY.txt is gone.
  * debian/rules: Update list of unused files.
  * Add missing pkg-config dependency.

  [ Reinhard Tartler ]
  * Imported Upstream version 5.0.0
    - Fixes libdvdread runs out of memory (LP: #377414)
    - Fixes: libdvdread4 unable to read Wall.e encrypted DVDs (LP: #590983)
    - Fixes: libdvdread: Can't seek to block (LP: #983535, #446664, #1066317)
    - Fixes: Zero check failed in ifo_read.c:904 for pgc->subp_control[i]
             = 0x00000001 (LP: #1179913, Closes: #504256)
  * Refresh patches, drop merged patches
 -- Benjamin Drung <email address hidden> Sun, 17 Aug 2014 23:03:17 +0200

Changed in libdvdread (Ubuntu):
status: Confirmed → Fix Released
Jani Uusitalo (uusijani) wrote :

Sorry, but 5.0.0-1ubuntu1 didn't fix this. In Utopic, with the same 'The Snowman' DVD as before, I still get:

*** Zero check failed in src/ifo_read.c:903
    for pgc->subp_control[i] = 0x00000001
*** Zero check failed in src/ifo_read.c:903
    for pgc->subp_control[i] = 0x00000001
*** Zero check failed in src/ifo_read.c:903
    for pgc->subp_control[i] = 0x00000001

jani@ubudev:~/lumiukko$ apt-cache policy libdvdread4
libdvdread4:
  Installed: 5.0.0-1ubuntu1
  Candidate: 5.0.0-1ubuntu1
  Version table:
 *** 5.0.0-1ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ utopic/universe amd64 Packages
        100 /var/lib/dpkg/status

Changed in libdvdread (Ubuntu):
status: Fix Released → Confirmed
JB VideoLAN (jb-videolan) wrote :

Sure, but it's just a warning, it should not break anything, nor stop anything from happening

Jani Uusitalo (uusijani) wrote :

I acknowledge that (and as I said, it hasn't really caused any issues with the backups), I was just responding to this being "fixed" (above). If it's not really an issue in the code, maybe we should close this as invalid? (Although I could argue that the message makes it seem as if there is a problem with the code when in fact there isn't, so the bug could be "this warning is slightly misleading". But that's up for interpretation.)

Changed in libdvdread (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers