Ubuntu

vlc assert failure: vlc: /build/buildd/libdvdnav-4.1.3/src/vm/vm.c:1074: play_Cell: Assertion `0' failed.

Reported by Dogge on 2009-10-16
78
This bug affects 13 people
Affects Status Importance Assigned to Milestone
libdvdnav (Ubuntu)
High
Unassigned
vlc (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: vlc

I tried to view a dvd backed up as an iso-file.

ProblemType: Crash
Architecture: i386
AssertionMessage: vlc: /build/buildd/libdvdnav-4.1.3/src/vm/vm.c:1074: play_Cell: Assertion `0' failed.
Date: Fri Oct 16 18:21:52 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/vlc
NonfreeKernelModules: nvidia
Package: vlc-nox 1.0.2-1ubuntu1
ProcCmdline: vlc file:///home/username/Videos/SNATCH.iso
ProcEnviron:
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.47-generic
Signal: 6
SourcePackage: vlc
StacktraceTop:
 __kernel_vsyscall ()
 raise () from /lib/tls/i686/cmov/libc.so.6
 abort () from /lib/tls/i686/cmov/libc.so.6
 __assert_fail () from /lib/tls/i686/cmov/libc.so.6
 ?? () from /usr/lib/libdvdnav.so.4
Title: vlc assert failure: vlc: /build/buildd/libdvdnav-4.1.3/src/vm/vm.c:1074: play_Cell: Assertion `0' failed.
Uname: Linux 2.6.31-14-generic i686
UserGroups: adm admin cdrom dialout lpadmin netdev plugdev sambashare
XsessionErrors: (polkit-gnome-authentication-agent-1:1980): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

Dogge (martin-dosch) wrote :

StacktraceTop:__kernel_vsyscall ()
*__GI_raise (sig=6)
*__GI_abort () at abort.c:92
*__GI___assert_fail (assertion=0xe57a03 "0",
play_Cell (vm=0x9808f38)

Changed in vlc (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
visibility: private → public
Changed in vlc (Ubuntu):
status: New → Invalid
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libdvdnav (Ubuntu):
status: New → Confirmed
parq (pablo-romeroquinteros) wrote :

I'm trying to play a DVD created with DVD95, and get this error.

I've tried:

$ apport-collect 453267

...but it says libdvdnav isn't installed. Then verified in synaptic and it's installed. Reinstalled libdvdnav and it's the same.

Rémi Denis-Courmont (rdenis) wrote :

I don't think apport-collect would bring much more at this point.

What's needed is someone to pass the problem upstream and get it fixed for real. I don't know if upstream is still active though.

Bryce Harrington (bryce) wrote :

There is only one assert(0) in playCell, so this is probably the code getting hit:

  if(!set_PGN(vm)) {
    /* Should not happen */
    assert(0);
    return play_PGC_post(vm);
  }

Changed in libdvdnav (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
Guy K. Kloss (guy.kloss) wrote :

Just stumbled upon the same issue in raring as well.

JB VideoLAN (jb-videolan) wrote :

Confirmed upstream

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers