scripting bug: unknown option or argument >/usr/src/libdvd-pkg/libdvdcss2_1.3.99-1~local_amd64.build

Bug #1589151 reported by Peter Cordes
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
libdvd-pkg (Debian)
New
Unknown
libdvd-pkg (Ubuntu)
Undecided
Unassigned

Bug Description

When installing 1.3.99-1-1 on Ubuntu 15.10 (AMD64), I get the following error while the package configures itself:

```
libdvd-pkg: Checking orig.tar integrity...
/usr/src/libdvd-pkg/libdvdcss_1.3.99.orig.tar.bz2: OK
libdvd-pkg: Unpacking and configuring...
libdvd-pkg: Building the package... (it may take a while)
libdvd-pkg: Build log will be saved to /usr/src/libdvd-pkg/libdvdcss2_1.3.99-1~local_amd64.build
Current: = cap_chown,cap_dac_override,cap_dac_read_search,cap_fowner,cap_fsetid,cap_kill,cap_setgid,cap_setuid,cap_setpcap,cap_linux_immutable,cap_net_bind_service,cap_net_broadcast,cap_net_admin,cap_net_raw,cap_ipc_lock,cap_ipc_owner,cap_sys_module,cap_sys_rawio,cap_sys_chroot,cap_sys_ptrace,cap_sys_pacct,cap_sys_admin,cap_sys_boot,cap_sys_nice,cap_sys_resource,cap_sys_time,cap_sys_tty_config,cap_mknod,cap_lease,cap_audit_write,cap_audit_control,cap_setfcap,cap_mac_override,cap_mac_admin,cap_syslog,cap_wake_alarm,cap_block_suspend,37+ep
Bounding set =cap_chown,cap_dac_override,cap_fowner,cap_wake_alarm,cap_block_suspend,37
Securebits: 024/0x14/5'b10100
 secure-noroot: no (unlocked)
 secure-no-suid-fixup: yes (unlocked)
 secure-keep-caps: yes (unlocked)
uid=0(root)
gid=0(root)
groups=0(root)
dpkg-buildpackage: unknown option or argument >/usr/src/libdvd-pkg/libdvdcss2_1.3.99-1~local_amd64.build

Use --help for program usage information.
Press Return to continue.
```

I haven't investigated further, but presumably someone was expecting shell-expansion on that arg.

My /bin/sh is dash.

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: libdvd-pkg 1.3.99-1-1
ProcVersionSignature: Ubuntu 4.2.0-36.42-generic 4.2.8-ckt8
Uname: Linux 4.2.0-36-generic x86_64
ApportVersion: 2.19.1-0ubuntu5
Architecture: amd64
CurrentDesktop: KDE
Date: Sat Jun 4 17:25:03 2016
PackageArchitecture: all
SourcePackage: libdvd-pkg
UpgradeStatus: Upgraded to wily on 2015-11-12 (205 days ago)

Revision history for this message
Peter Cordes (peter-cordes) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libdvd-pkg (Ubuntu):
status: New → Confirmed
Revision history for this message
Winston Sorfleet (wls-c) wrote :

Also in 16.04.3

tags: added: xenial
removed: wily
Changed in libdvd-pkg (Debian):
status: Unknown → New
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.