Some DVDs won't be recognized

Bug #1583832 reported by Wally
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libdvd-pkg (Ubuntu)
Undecided
Unassigned

Bug Description

Hi,

I recently started experiencing problems opening *some* DVDs. Take, for instance, some of the recent DVDs that I have tried to open, such as Buffy, Angel, and Boy Meets World, and Burn Notice season sets. These are all legit, region 1 releases and in flawless condition. Importantly, 90-95% of these discs still do open and play just fine. Only some of them do not. For example, all of Boy Meets World Season 1 opened, as did discs 1 and 2 of Season 2, but Season 2 Disc 3 will not. I took it from one computer to another and had the same problem there. The type of disc, region, and whether CSS is present is static across both affected and un-affected discs. I can come up with no explanation for why most discs are loading and a select few are not.

Some additional information to hopefully help narrow down the problem and eliminate some likely causes:

- I am using Ubuntu 16.04
- I have installed the restricted formats / libdvdcss. About 90-95% of DVDs play with no trouble.
- I am using libdvdcss 1.4.0.
- I recently upgraded from Ubuntu 14.04 to 16.04.
- The exact same discs run fine using the same hardware via Ubuntu 14.04.
- I have purged and re-installed restricted formats / libdvdcss, but continue getting the same problems for the affected discs.
- This affects multiple computers (different makes and models) and DVD drives (ditto), so it's not a hardware issue.
- I have tried deleting /.dvdcss folder and rebooting, but that solves nothing.
- The volume is loading as an unknown format according to Ubuntu's "Disks" application, so it is recognizing that a disc is present (and it correctly reads the size of the data on the disc), but can't recognize the file structure.
- Programs that can load directly from a device rather than relying on Ubuntu's folders or disc mapping can read the discs just fine. VLC Media Player, for example, can play the discs if I point it to the disc device, even though the disc itself isn't being recognized by Ubuntu.
- The Boy Meets World discs in my example are not encrypted, but Bolt, for example, is encrypted and reads just fine, so it is not an encryption problem.
- Any program that relies on selecting a disc or folder rather than a device will not be able to see the disc, unfortunately. Only programs that can be directed at a device in general can get around this program.

I'm happy to provide additional information and run tests/commands as needed.

Thanks!

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: libdvd-pkg 1.4.0-1-1
ProcVersionSignature: Ubuntu 4.4.0-22.40-generic 4.4.8
Uname: Linux 4.4.0-22-generic x86_64
ApportVersion: 2.20.1-0ubuntu2
Architecture: amd64
CurrentDesktop: Unity
Date: Thu May 19 18:57:11 2016
InstallationDate: Installed on 2015-01-22 (483 days ago)
InstallationMedia: Ubuntu 14.04.1 LTS "Trusty Tahr" - Release amd64 (20140722.2)
PackageArchitecture: all
SourcePackage: libdvd-pkg
UpgradeStatus: Upgraded to xenial on 2016-04-22 (27 days ago)

Revision history for this message
Wally (ubuntuwally) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers