Update libdrumstick to 1.0

Bug #1584310 reported by Clive Johnston on 2016-05-21
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
libdrumstick (Debian)
Fix Released
Unknown
libdrumstick (Ubuntu)
Wishlist
Unassigned

Bug Description

I am trying to package KDE Applications 16.04.1 One of the applications 'Minuet` – Music Education [1] requires 'drumstick-alsa>=1.0.1' which I believe is part of the libdrumstick package.

Are there any maintainers who could update this package?

Version 1.0.2 is available here - http://drumstick.sourceforge.net/

[1] https://minuet.kde.org/
Debian PTS: https://packages.qa.debian.org/libd/libdrumstick.html

Changed in libdrumstick (Debian):
status: Unknown → New
Jeremy Bicha (jbicha) on 2016-06-05
tags: added: upgrade-software-version
Changed in libdrumstick (Debian):
status: New → Fix Committed
Changed in libdrumstick (Debian):
status: Fix Committed → Fix Released

Can this package be sync'ed with Debian please

Changed in libdrumstick (Ubuntu):
importance: Undecided → Wishlist
tags: added: yakkety
description: updated
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libdrumstick (Ubuntu):
status: New → Confirmed

@ Clive can you pls support bug #1636313 (synrequest for Zesty)

Jeremy Bicha (jbicha) wrote :

This bug was fixed in the package libdrumstick - 1.0.2-1

---------------
libdrumstick (1.0.2-1) experimental; urgency=medium

  [ Alessio Treglia ]
  * New upstream version (Closes: #824771)

  [ Ross Gammon ]
  * Add myself to uploaders
  * Update copyright years
  * Update to Qt5 dependencies from Qt4
  * Extend gcc6 patch for new upstream version
  * Patch desktop file Exec key with %f
  * Patch desktop files to provide keyword entries
  * Rename library package due to SONAME bump
  * Update lintian-override according to updated package name
  * Add bindnow hardening option

 -- Ross Gammon <email address hidden> Fri, 26 Aug 2016 22:09:28 +0200

Changed in libdrumstick (Ubuntu):
status: Confirmed → Fix Released
Jeremy Bicha (jbicha) wrote :

kmidimon fails to build with the new libdrumstick:

-- Checking for module 'drumstick-file>=0.5'
-- Found drumstick-file, version 1.0.2
-- Checking for module 'drumstick-alsa>=0.5'
--
CMake Error at /usr/share/cmake-3.6/Modules/FindPkgConfig.cmake:428 (message):
  A required package was not found

Since libdrumstick starts a library transition (libdrumstick0 > libdrumstick1), this needs to be handled before libdrumstick can move out of zesty-proposed.

Changed in libdrumstick (Ubuntu):
status: Fix Released → Fix Committed
Jeremy Bicha (jbicha) wrote :

This was "unsynced" today (deleted from zesty-proposed) because no one has volunteered a fix for kmidimon. We might just wait for Debian to do the libdrumstick transition themselves (libdrumstick 1.0 is still in Debian experimental).

Changed in libdrumstick (Ubuntu):
status: Fix Committed → Triaged
summary: - New upstream release available
+ Update libdrumstick to 1.0
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.