package libdrm2:amd64 2.4.70-1~ubuntu16.04.1 failed to install/upgrade: package is in a very bad inconsistent state; you should reinstall it before attempting configuration

Bug #1679939 reported by Abhishek Raj on 2017-04-05
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libdrm (Ubuntu)
Undecided
Unassigned

Bug Description

Facing so many problems...

ProblemType: Package
DistroRelease: Ubuntu 16.04
Package: libdrm2:amd64 2.4.70-1~ubuntu16.04.1
ProcVersionSignature: Ubuntu 4.4.0-59.80-generic 4.4.35
Uname: Linux 4.4.0-59-generic x86_64
.tmp.unity_support_test.0:

ApportVersion: 2.20.1-0ubuntu2.4
Architecture: amd64
BootLog:

CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
Date: Wed Apr 5 12:18:26 2017
Dependencies:
 gcc-6-base 6.0.1-0ubuntu1
 libc6 2.23-0ubuntu5
 libgcc1 1:6.0.1-0ubuntu1
DistUpgraded: Fresh install
DistroCodename: xenial
DistroVariant: ubuntu
DpkgHistoryLog:
 Start-Date: 2017-04-05 12:18:20
 Commandline: apt-get install -f
 Requested-By: abhishek (1000)
 Upgrade: libdrm2:i386 (2.4.67-1ubuntu0.16.04.2, 2.4.70-1~ubuntu16.04.1)
DuplicateSignature:
 package:libdrm2:amd64:2.4.70-1~ubuntu16.04.1
 Setting up libdrm2:i386 (2.4.70-1~ubuntu16.04.1) ...
 dpkg: error processing package libdrm2:amd64 (--configure):
  package is in a very bad inconsistent state; you should
ErrorMessage: package is in a very bad inconsistent state; you should reinstall it before attempting configuration
GraphicsCard:
 Advanced Micro Devices, Inc. [AMD/ATI] Sumo [Radeon HD 6480G] [1002:9648] (prog-if 00 [VGA controller])
   Subsystem: Hewlett-Packard Company Sumo [Radeon HD 6480G] [103c:3564]
InstallationDate: Installed on 2016-11-30 (125 days ago)
InstallationMedia: Ubuntu 16.04.1 LTS "Xenial Xerus" - Release amd64 (20160719)
MachineType: Hewlett-Packard HP Pavilion g4 Notebook PC
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-59-generic root=UUID=21523131-9895-4edd-88f5-3199f38e8d77 ro quiet splash
RelatedPackageVersions:
 dpkg 1.18.4ubuntu1.1
 apt 1.2.19
SourcePackage: libdrm
Title: package libdrm2:amd64 2.4.70-1~ubuntu16.04.1 failed to install/upgrade: package is in a very bad inconsistent state; you should reinstall it before attempting configuration
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 02/05/2013
dmi.bios.vendor: Insyde
dmi.bios.version: F.65
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 3564
dmi.board.vendor: Hewlett-Packard
dmi.board.version: 21.44
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnInsyde:bvrF.65:bd02/05/2013:svnHewlett-Packard:pnHPPaviliong4NotebookPC:pvr0691130000204610000610100:rvnHewlett-Packard:rn3564:rvr21.44:cvnHewlett-Packard:ct10:cvrChassisVersion:
dmi.product.name: HP Pavilion g4 Notebook PC
dmi.product.version: 0691130000204610000610100
dmi.sys.vendor: Hewlett-Packard
version.compiz: compiz 1:0.9.12.2+16.04.20160714-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.70-1~ubuntu16.04.1
version.libgl1-mesa-dri: libgl1-mesa-dri 12.0.6-0ubuntu0.16.04.1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 11.2.0-1ubuntu2.2
version.xserver-xorg-core: xserver-xorg-core 2:1.18.4-0ubuntu0.2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.1-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.7.0-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20160325-1ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.12-1build2
xserver.bootTime: Wed Apr 5 12:14:01 2017
xserver.configfile: default
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.18.4-0ubuntu0.2
xserver.video_driver: radeon

Abhishek Raj (jauhariabhi) wrote :

Thanks for taking the time to report this bug and helping to make Ubuntu better. We appreciate the difficulties you are facing, but this appears to be a "regular" (non-security) bug. I have unmarked it as a security issue since this bug does not show evidence of allowing attackers to cross privilege boundaries nor directly cause loss of data/privacy. Please feel free to report any other bugs you may find.

information type: Private Security → Public
tags: removed: need-duplicate-check
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers