Ubuntu

package libdrm2 2.4.39-0ubuntu1 failed to install/upgrade: trying to overwrite shared '/usr/share/doc/libdrm2/changelog.Debian.gz', which is different from other instances of package libdrm2:amd64

Reported by James Patrick-Evans on 2012-10-18
690
This bug affects 157 people
Affects Status Importance Assigned to Milestone
libdrm (Ubuntu)
Undecided
Unassigned

Bug Description

Summary and bug report automatically generated.

ProblemType: Package
DistroRelease: Ubuntu 12.10
Package: libdrm2 2.4.39-0ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-17.28-generic 3.5.5
Uname: Linux 3.5.0-17-generic x86_64
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 304.43 Sun Aug 19 20:14:03 PDT 2012
 GCC version: gcc version 4.7.2 (Ubuntu/Linaro 4.7.2-2ubuntu1)
.proc.driver.nvidia.warnings.fbdev:
 Your system is not currently configured to drive a VGA console
 on the primary VGA device. The NVIDIA Linux graphics driver
 requires the use of a text-mode VGA console. Use of other console
 drivers including, but not limited to, vesafb, may result in
 corruption and stability problems, and is not supported.
.tmp.unity.support.test.1:

ApportVersion: 2.6.1-0ubuntu3
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: None
Date: Thu Oct 18 15:43:52 2012
DistUpgraded: 2012-10-18 04:21:00,754 DEBUG enabling apt cron job
DistroCodename: quantal
DistroVariant: ubuntu
DkmsStatus:
 nvidia-current, 304.43, 3.2.0-32-generic, x86_64: installed
 nvidia-current, 304.43, 3.5.0-17-generic, x86_64: installed
ErrorMessage: trying to overwrite shared '/usr/share/doc/libdrm2/changelog.Debian.gz', which is different from other instances of package libdrm2:amd64
GraphicsCard:
 Subsystem: ASRock Incorporation Device [1849:0122]
 NVIDIA Corporation GF110 [GeForce GTX 580] [10de:1080] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: NVIDIA Corporation Device [10de:086a]
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
JockeyStatus:
 kmod:nvidia_experimental_304 - Experimental NVIDIA binary Xorg driver, kernel module and VDPAU library (Proprietary, Disabled, Not in use)
 kmod:nvidia_current - nvidia_current (Proprietary, Enabled, Not in use)
 kmod:nvidia_current_updates - NVIDIA binary Xorg driver, kernel module and VDPAU library (Proprietary, Disabled, Not in use)
MachineType: To Be Filled By O.E.M. To Be Filled By O.E.M.
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-17-generic root=UUID=b54a0a82-16ce-40b8-b32b-bc73f2f214a0 ro quiet splash vt.handoff=7
SourcePackage: libdrm
Title: package libdrm2 2.4.39-0ubuntu1 failed to install/upgrade: trying to overwrite shared '/usr/share/doc/libdrm2/changelog.Debian.gz', which is different from other instances of package libdrm2:amd64
UnitySupportTest: Error: command ['/usr/lib/nux/unity_support_test', '-p', '-f'] failed with exit code 1: Error: no composite extension
UpgradeStatus: Upgraded to quantal on 2012-10-18 (0 days ago)
dmi.bios.date: 06/21/2011
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: P1.50
dmi.board.name: Z68 Extreme4
dmi.board.vendor: ASRock
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrP1.50:bd06/21/2011:svnToBeFilledByO.E.M.:pnToBeFilledByO.E.M.:pvrToBeFilledByO.E.M.:rvnASRock:rnZ68Extreme4:rvr:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
dmi.product.name: To Be Filled By O.E.M.
dmi.product.version: To Be Filled By O.E.M.
dmi.sys.vendor: To Be Filled By O.E.M.
version.compiz: compiz 1:0.9.8.4-0ubuntu3
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.39-0ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.0-0ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.0-0ubuntu1
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.13.0-0ubuntu6
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.99.99~git20120913.8637f772-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.20.9-0ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.2-0ubuntu3

The following packages will be upgraded:
  libdrm2
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/26.5 kB of archives.
After this operation, 4,096 B of additional disk space will be used.
Do you want to continue [Y/n]? y
(Reading database ... 217134 files and directories currently installed.)
Preparing to replace libdrm2:amd64 2.4.39-0ubuntu1 (using .../libdrm2_2.4.39-0ubuntu1_amd64.deb) ...
Unpacking replacement libdrm2:amd64 ...
dpkg: error processing /var/cache/apt/archives/libdrm2_2.4.39-0ubuntu1_amd64.deb (--unpack):
 trying to overwrite shared '/usr/share/doc/libdrm2/changelog.Debian.gz', which is different from other instances of package libdrm2:amd64
Errors were encountered while processing:
 /var/cache/apt/archives/libdrm2_2.4.39-0ubuntu1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libdrm (Ubuntu):
status: New → Confirmed
Vitaliy Kulikov (slonua) wrote :

here is a fix:
$sudo rm /usr/share/doc/libdrm2/changelog.Debian.gz

after try again.

it's possible then you use 3rd party repos !! ;)

Vitaliy Kulikov thank you, it worked. Now to fix everything else upgrading from 12.04 to 12.10 broke >:(

cml21 (clowther) wrote :

@Vitaliy Kulikov: That worked for me too. Thx!

P Cantwall (p-cantwell) wrote :

I drilled down to the folder to check permissions. Before removing the file, I decided to check for other solutions. I found my solution matched the suggestion. This workaround fixed this update, for now.

Alex T. (raptox91) wrote :

@Vitaliy Kulikov, it worked, thanks

emptythevoid (emptythevoid) wrote :

Confirmed, worked for me as well. Appreciate it. :) Now someone just needs to patch this.

Steve S. (torvista) wrote :

Worked for me too.

Richard Hansen (a7x) wrote :

I believe bug #1068165, bug #1069774, bug #1069210, and bug #1075027 all have the same underlying cause, but I'm not marking them as duplicates of each other because (1) I'm not 100% certain, and (2) I want people to be able to find the bug reports when the automatic crash reporting prompts them to do a search (I believe marking a bug as a duplicate hides it from the search results, which would lead to more duplicates being filed).

If someone can verify that these bugs are all caused by the same underlying issue, and can confirm that marking a bug as a duplicate does not keep people from finding it via automatic crash reporting, then please pick one of the reports as the master (probably bug #1068165) and mark the others as a duplicate.

Thanks!

Sonicstone (sonicstone) wrote :

Thank you Vitaliy Kulikov. It works!

Mike Ekim (mmkms) wrote :

Several times I tried Vitaliy Kulikov's suggestion, but it did not work.

Tom DeLiso (hermestrs) wrote :

This fix worked for me. I had to repeat it for several other files that would not install as well. I think there were 6 in all, with similar names. Anyway deleting the file and then rerunning install fixed it. No more nag to install these. Thanks

Works for me. Thanks!

Mike Ekim (mmkms) wrote :

Yep, it works if all the changelog.Debian.gz files are deleted. Thanks!

James Bridges (netranger77jb) wrote :

Looks like it might work. no system errors rebooting computer. thx Jim

Vitaliy Kulikov's solution worked for me too. Thanks.

steve77 (funmaker-11) wrote :

The fix: sudo rm /usr/share/doc/libdrm2/changelog.Debian.gz, did not work for me!

pberndt (phillip-berndt) wrote :

In the amd64 version of the package, the changelog is a plain file, while in the i386 version, it is actually a symlink to ../libdrm2/changelog.Debian.gz (which is NOT contained in the package). I presume the latter is an error.

This is why the packages won't install. Now removing the file prior to installing either package will fix the installation problem for now, but the error will likely occur again when one of the two versions is updated. Only will it not be the installation of Steam or Wine, but the system's update that fails then. Much worse IMHO..

pberndt (phillip-berndt) wrote :

(Sorry: The symlink is only there in the libdrm-* packages. In the base libdrm2 package, the two changelog files actually match.)

DP (danwerspb) wrote :

Спасибо, все работает коллега.

diego2k (diego2k) wrote :

Vitaliy Kulikov: That worked for me too. Thanks a lot!

Ivan Lackovic (lackovic10) wrote :

tnx Vitaliy Kulikov (slonua) (#4), that worked for me too!!!

To post a comment you must log in.