arm64/efi support

Bug #1435663 reported by dann frazier on 2015-03-24
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
efibootmgr (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
dann frazier
Utopic
Undecided
Unassigned
grub-installer (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
dann frazier
Utopic
Undecided
dann frazier
grub2 (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
dann frazier
Utopic
Undecided
Unassigned
grub2-signed (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Unassigned
Utopic
Undecided
Unassigned
libdebian-installer (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
dann frazier
Utopic
Undecided
dann frazier
partman-auto (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
dann frazier
Utopic
Undecided
dann frazier
partman-efi (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
dann frazier
Utopic
Undecided
dann frazier

Bug Description

[Impact]
It is currently not possible to install EFI-based arm64 systems.

[Test Case]
Install an arm64 system with d-i. On reboot you should have a new "ubuntu" entry in the EFI boot menu that starts GRUB and boots into Linux. This can be tested in QEMU if hardware is not available:
  https://wiki.ubuntu.com/ARM64/QEMU
Note that kernel support is also required, so you'll need to use an LTS Enablement kernel.

[Regression Risk]
Most of the required changes involve enabling builds/backporting code that will only run on previously-unsupported systems. The biggest risk I see is in breaking previously-supported arm64 systems - luckily there's only a few of those and we can test them.

dann frazier (dannf) on 2015-03-24
Changed in libdebian-installer (Ubuntu):
status: New → Confirmed
assignee: nobody → dann frazier (dannf)
Changed in efibootmgr (Ubuntu):
status: New → Fix Released
Changed in efibootmgr (Ubuntu Utopic):
status: New → Fix Released
Changed in efibootmgr (Ubuntu Trusty):
status: New → Triaged
dann frazier (dannf) on 2015-03-24
Changed in grub-installer (Ubuntu):
status: New → Fix Released
Changed in grub-installer (Ubuntu Trusty):
status: New → Confirmed
Changed in grub-installer (Ubuntu Utopic):
status: New → Confirmed
Changed in grub2 (Ubuntu):
status: New → Fix Released
Changed in grub2 (Ubuntu Trusty):
status: New → Confirmed
Changed in grub2 (Ubuntu Utopic):
status: New → Fix Released
Changed in libdebian-installer (Ubuntu):
status: Confirmed → Fix Released
Changed in libdebian-installer (Ubuntu Trusty):
status: New → Confirmed
Changed in libdebian-installer (Ubuntu Utopic):
status: New → Confirmed
Changed in partman-auto (Ubuntu):
status: New → Fix Released
Changed in partman-efi (Ubuntu):
status: New → Fix Released
Changed in partman-efi (Ubuntu Utopic):
status: New → Confirmed
Changed in partman-efi (Ubuntu Trusty):
status: New → Confirmed
Changed in partman-auto (Ubuntu Utopic):
status: New → Confirmed
Changed in partman-auto (Ubuntu Trusty):
status: New → Confirmed
Changed in libdebian-installer (Ubuntu):
assignee: dann frazier (dannf) → nobody
Changed in efibootmgr (Ubuntu Trusty):
assignee: nobody → dann frazier (dannf)
dann frazier (dannf) on 2015-03-24
Changed in grub-installer (Ubuntu Trusty):
assignee: nobody → dann frazier (dannf)
Changed in grub-installer (Ubuntu Utopic):
assignee: nobody → dann frazier (dannf)
Changed in grub2 (Ubuntu Trusty):
assignee: nobody → dann frazier (dannf)
Changed in libdebian-installer (Ubuntu Trusty):
assignee: nobody → dann frazier (dannf)
Changed in libdebian-installer (Ubuntu Utopic):
assignee: nobody → dann frazier (dannf)
Changed in partman-auto (Ubuntu Trusty):
assignee: nobody → dann frazier (dannf)
Changed in partman-auto (Ubuntu Utopic):
assignee: nobody → dann frazier (dannf)
Changed in partman-efi (Ubuntu Trusty):
assignee: nobody → dann frazier (dannf)
Changed in partman-efi (Ubuntu Utopic):
assignee: nobody → dann frazier (dannf)
dann frazier (dannf) on 2015-03-24
Changed in efibootmgr (Ubuntu Trusty):
status: Triaged → In Progress
dann frazier (dannf) on 2015-03-24
Changed in partman-efi (Ubuntu Trusty):
status: Confirmed → In Progress
Changed in partman-efi (Ubuntu Utopic):
status: Confirmed → In Progress
dann frazier (dannf) on 2015-03-24
Changed in partman-auto (Ubuntu Utopic):
status: Confirmed → In Progress
dann frazier (dannf) on 2015-03-24
Changed in partman-auto (Ubuntu Trusty):
status: Confirmed → In Progress
dann frazier (dannf) on 2015-03-24
Changed in libdebian-installer (Ubuntu Utopic):
status: Confirmed → In Progress
dann frazier (dannf) on 2015-03-24
Changed in libdebian-installer (Ubuntu Trusty):
status: Confirmed → In Progress
dann frazier (dannf) on 2015-03-24
Changed in grub-installer (Ubuntu Utopic):
status: Confirmed → In Progress
Changed in grub-installer (Ubuntu Trusty):
status: Confirmed → In Progress
dann frazier (dannf) wrote :

Adding a proposed backport patch for grub2. Note that this is blocked on the efibootmgr SRU, otherwise it would make grub-efi-arm64-bin uninstallable.

Changed in grub2 (Ubuntu Trusty):
status: Confirmed → Triaged
Brian Murray (brian-murray) wrote :

Which efibootmgr SRU is this blocked on?

On Thu, Mar 26, 2015 at 11:42 AM, Brian Murray <email address hidden> wrote:
> Which efibootmgr SRU is this blocked on?

0.5.4-7ubuntu1.1:
  http://launchpadlibrarian.net/201094067/efibootmgr_0.5.4-7ubuntu1_0.5.4-7ubuntu1.1.diff.gz

 -dann

Brian Murray (brian-murray) wrote :

On Thu, Mar 26, 2015 at 05:54:09PM -0000, dann frazier wrote:
> On Thu, Mar 26, 2015 at 11:42 AM, Brian Murray <email address hidden> wrote:
> > Which efibootmgr SRU is this blocked on?
>
> 0.5.4-7ubuntu1.1:
> http://launchpadlibrarian.net/201094067/efibootmgr_0.5.4-7ubuntu1_0.5.4-7ubuntu1.1.diff.gz

That's for Trusty, I don't see a corresponding upload for Utopic and the
partman-*, libdebian-installer and grub-installer uploads there.

--
Brian Murray

dann frazier (dannf) wrote :

On Thu, Mar 26, 2015 at 12:06 PM, Brian Murray <email address hidden> wrote:
> On Thu, Mar 26, 2015 at 05:54:09PM -0000, dann frazier wrote:
>> On Thu, Mar 26, 2015 at 11:42 AM, Brian Murray <email address hidden> wrote:
>> > Which efibootmgr SRU is this blocked on?
>>
>> 0.5.4-7ubuntu1.1:
>> http://launchpadlibrarian.net/201094067/efibootmgr_0.5.4-7ubuntu1_0.5.4-7ubuntu1.1.diff.gz
>
> That's for Trusty, I don't see a corresponding upload for Utopic and the
> partman-*, libdebian-installer and grub-installer uploads there.

Utopic already has the necessary changes for grub2 and efibootmgr.
I've marked those cases as "Fix Released" in this bug.
The only ordering issue here is that efibootmgr for trusty needs to go
in before the grub2 update for trusty (which hasn't been uploaded
yet).

 -dann

> --
> Brian Murray
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1435663
>
> Title:
> arm64/efi support
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/efibootmgr/+bug/1435663/+subscriptions

Hello dann, or anyone else affected,

Accepted efibootmgr into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/efibootmgr/0.5.4-7ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in efibootmgr (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Chris J Arges (arges) wrote :
Changed in grub-installer (Ubuntu Trusty):
status: In Progress → Fix Committed
Changed in grub-installer (Ubuntu Utopic):
status: In Progress → Fix Committed
Chris J Arges (arges) wrote :

Hello dann, or anyone else affected,

Accepted libdebian-installer into utopic-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/libdebian-installer/0.88ubuntu6.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in libdebian-installer (Ubuntu Utopic):
status: In Progress → Fix Committed
Changed in libdebian-installer (Ubuntu Trusty):
status: In Progress → Fix Committed
Chris J Arges (arges) wrote :

Hello dann, or anyone else affected,

Accepted libdebian-installer into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/libdebian-installer/0.88ubuntu5.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in partman-auto (Ubuntu Utopic):
status: In Progress → Fix Committed
Chris J Arges (arges) wrote :

Hello dann, or anyone else affected,

Accepted partman-auto into utopic-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/partman-auto/118ubuntu3.14.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in partman-auto (Ubuntu Trusty):
status: In Progress → Fix Committed
Chris J Arges (arges) wrote :

Hello dann, or anyone else affected,

Accepted partman-auto into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/partman-auto/118ubuntu3.14.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in partman-efi (Ubuntu Utopic):
status: In Progress → Fix Committed
Chris J Arges (arges) wrote :

Hello dann, or anyone else affected,

Accepted partman-efi into utopic-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/partman-efi/25ubuntu6.14.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in partman-efi (Ubuntu Trusty):
status: In Progress → Fix Committed
Chris J Arges (arges) wrote :

Hello dann, or anyone else affected,

Accepted partman-efi into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/partman-efi/25ubuntu6.14.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

dann frazier (dannf) on 2015-04-07
tags: added: verification-done-utopic verification-needed-trusty
removed: verification-needed
dann frazier (dannf) on 2015-04-07
Changed in grub2 (Ubuntu Trusty):
status: Triaged → In Progress
Timo Aaltonen (tjaalton) wrote :

Hello dann, or anyone else affected,

Accepted grub2 into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/grub2/2.02~beta2-9ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in grub2 (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
dann frazier (dannf) on 2015-04-19
tags: added: verification-done verification-done-trusty
removed: verification-needed-trusty
tags: removed: verification-needed
Sven Baars (sbte) wrote :

After installing this update my system won't boot any more with the message

"The system found unauthorized changes on the firmware, operating system or UEFI drivers.

Press [N] to run the next boot device, or enter directly to BIOS Setup if there are no other boot devices installed.
Go to BIOS Setup > Advanced > Boot and change the current boot drive into other secured boot devices. "

I'll try to fix this now, but this doesn't look like intended behaviour from an SRU.

Sven Baars (sbte) wrote :

Ok, so the fix to my problem was setting Windows Secure Boot -> Other OS Secure Boot in the BIOS.

However, this update will still likely break boot for everyone with an ASUS motherboard until they change this in the BIOS.

Adam Conrad (adconrad) wrote :

Your problem was simply that grub2-signed hadn't been updated to match grub2. This should be sorted before the SRU is released.

Adam Conrad (adconrad) wrote :

Hello dann, or anyone else affected,

Accepted grub2-signed into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/grub2-signed/1.34.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: removed: verification-done
tags: added: verification-needed
dann frazier (dannf) wrote :

Thanks for testing and catching this Sven! I've uploaded an updated grub2-signed, would you mind testing it?

Changed in grub2-signed (Ubuntu Trusty):
status: New → Fix Committed
Changed in grub2-signed (Ubuntu):
status: New → Fix Released
Changed in grub2-signed (Ubuntu Utopic):
status: New → Fix Released

As a part of the Stable Release Updates quality process a search for Launchpad bug reports using the version of grub2 from trusty-proposed was performed and bug 1447295 was found. Please investigate this bug report to ensure that a regression will not be created by this SRU. In the event that this is not a regression remove the "verification-failed" tag from this bug report and tag 1447295 "bot-stop-nagging". Thanks!

tags: added: verification-failed
Sven Baars (sbte) wrote :

I was waiting for an update, but didn't get one, so I manually installed grub-efi-amd64-signed 1.34.2+2.02~beta2-9ubuntu1.1, and now it works. I can not test if it also works when updating grub from 2.02~beta2-9ubuntu1 to 2.02~beta2-9ubuntu1.1 though, but I assume it does.

dann frazier (dannf) wrote :

I am changing this back to "verification-done" even though bug 1447295 has not yet been root caused. My justification is:

  1) I attempted and failed to reproduce the possible regression reported in bug 1447295.
  2) The failure mode in 1447295 looks more consistent with a bug in sed or (more likely) an intermittent hardware failure (sed crashes with an Illegal instruction)
  3) The only change made to the GRUB source is the addition of a dependency for a different architecture than the system in bug 1447295.
  4) Attempts at completing root cause analysis of bug 1447295 have been stalled for >10 days awaiting feedback from the reporter.

tags: added: verification-done
removed: verification-failed verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package partman-efi - 25ubuntu6.14.04.1

---------------
partman-efi (25ubuntu6.14.04.1) trusty-proposed; urgency=medium

  * Enable arm64 builds (LP: #1435663).
 -- dann frazier <email address hidden> Mon, 23 Mar 2015 23:11:52 -0600

Changed in partman-efi (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for partman-efi has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package partman-auto - 118ubuntu3.14.04.1

---------------
partman-auto (118ubuntu3.14.04.1) trusty-proposed; urgency=medium

  * Add arm64/efi recipe, reusing amd64/efi (LP: #1435663).
 -- dann frazier <email address hidden> Tue, 24 Mar 2015 09:49:46 -0600

Changed in partman-auto (Ubuntu Trusty):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package partman-efi - 25ubuntu6.14.10.1

---------------
partman-efi (25ubuntu6.14.10.1) utopic-proposed; urgency=medium

  * Enable arm64 builds (LP: #1435663).
 -- dann frazier <email address hidden> Mon, 23 Mar 2015 23:05:54 -0600

Changed in partman-efi (Ubuntu Utopic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package partman-auto - 118ubuntu3.14.10.1

---------------
partman-auto (118ubuntu3.14.10.1) utopic-proposed; urgency=medium

  * Add arm64/efi recipe, reusing amd64/efi (LP: #1435663).
 -- dann frazier <email address hidden> Tue, 24 Mar 2015 09:46:05 -0600

Changed in partman-auto (Ubuntu Utopic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libdebian-installer - 0.88ubuntu5.1

---------------
libdebian-installer (0.88ubuntu5.1) trusty-proposed; urgency=medium

  * arm64: Detect UEFI based systems as "efi" subarch (LP: #1435663).
 -- dann frazier <email address hidden> Tue, 24 Mar 2015 11:12:52 -0600

Changed in libdebian-installer (Ubuntu Trusty):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libdebian-installer - 0.88ubuntu6.1

---------------
libdebian-installer (0.88ubuntu6.1) utopic-proposed; urgency=medium

  * arm64: Detect UEFI based systems as "efi" subarch (LP: #1435663).
 -- dann frazier <email address hidden> Tue, 24 Mar 2015 10:58:36 -0600

Changed in libdebian-installer (Ubuntu Utopic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package grub2 - 2.02~beta2-9ubuntu1.1

---------------
grub2 (2.02~beta2-9ubuntu1.1) trusty-proposed; urgency=medium

  * Add dependency on efibootmgr to grub-efi-arm64-bin (LP: #1435663).
 -- dann frazier <email address hidden> Mon, 06 Apr 2015 22:31:19 -0600

Changed in grub2 (Ubuntu Trusty):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package grub2-signed - 1.34.2

---------------
grub2-signed (1.34.2) trusty; urgency=medium

  * Rebuild against grub-efi-amd64 2.02~beta2-9ubuntu1.1 (LP: #1435663)
 -- dann frazier <email address hidden> Mon, 20 Apr 2015 15:40:37 +0000

Changed in grub2-signed (Ubuntu Trusty):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package efibootmgr - 0.5.4-7ubuntu1.1

---------------
efibootmgr (0.5.4-7ubuntu1.1) trusty-proposed; urgency=medium

  * Add arm64 to the architecture list (LP: #1435663).
 -- dann frazier <email address hidden> Mon, 23 Mar 2015 22:53:21 -0600

Changed in efibootmgr (Ubuntu Trusty):
status: Fix Committed → Fix Released
Chris J Arges (arges) wrote :

Marking grub-installer fix-released manually for Utopic/Trusty.

Changed in grub-installer (Ubuntu Trusty):
status: Fix Committed → Fix Released
Changed in grub-installer (Ubuntu Utopic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers