libdca can't read files > 2Gb

Bug #800285 reported by Biau
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
libdca (Ubuntu)
Undecided
Unassigned

Bug Description

ubuntu 11.04
version of libdca0 : 0.0.5-3

I tried to read a dts file to ac3 with:

dcadec -o wavall file.dts | aften file.ac3

and received the following error "Value too large for defined data type - could not open file"
same error with
dcadec -o wavall file.dts > /dev/null

I've found that adding CFLAGS="-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE" solves the issue

(confirm by myself after recompiling the 0.0.5 source on my desktop with the flags)

Changed in libdca (Ubuntu):
status: New → Confirmed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libdca - 0.0.5-10

---------------
libdca (0.0.5-10) unstable; urgency=medium

  * QA upload.
  * Upload to unstable.
  * Reverted to default GCC provided by Debian.
  * debian/copyright:
      - Migrated to 1.0 format.
      - Updated all information.
  * debian/rules: added override_dh_installdocs
      to install some docs in all packages.

 -- Joao Eriberto Mota Filho <email address hidden> Sat, 14 May 2016 20:37:00 -0300

Changed in libdca (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Eriberto (eriberto) wrote :

Fixed in 0.0.5-9 (experimental) on Debian.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers