libdc-1394-22 gives "libdc1394 error: Failed to initialize libdc1394" when loaded.

Bug #462453 reported by hendeby on 2009-10-28
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
libdc1394-22 (Ubuntu)
Low
DC1394 Package Mainteners' team

Bug Description

Binary package hint: libdc1394-22

Since installing Ubuntu 9.10 the libdc1394-22 package has stopped to work. As soon as I try to load the library I get "libdc1394 error: Failed to initialize libdc1394".

Recompiling from the latest sources available on the libdc1394 homepage yields a library that doesn't have this problem.

ProblemType: Bug
Architecture: i386
Date: Wed Oct 28 01:58:58 2009
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: nvidia wl
Package: libdc1394-22 2.1.2-1
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/tcsh
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: libdc1394-22
Uname: Linux 2.6.31-14-generic i686

hendeby (hendeby) wrote :
Peter Antoniac (pan1nx) on 2009-10-28
Changed in libdc1394-22 (Ubuntu):
assignee: nobody → DC1394 Package Mainteners' team (libdc1394-dev)
status: New → Incomplete
Peter Antoniac (pan1nx) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:
1. What program did you use that caused troubles?
2. If none, what specific steps should we take to recreate this bug? Be as detailed as possible.
This will help us to find and resolve the problem.

tags: added: bitesize
tags: added: packaging
tags: added: regression-potential
Damien (takahara) wrote :

This could be a problem with the kernel modules, more specifically with the new firewire stack.

Please send us the output of

lsmod | grep 1394
lsmod | grep firewire

I believe that the latest sources have been patched regarding the new stack.

It could also be related to the access to the raw1394 device, but I don't know if the packages touch /dev/ in any way.

Peter Antoniac wrote:
> Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:
> 1. What program did you use that caused troubles?

No specific program is needed, just something that loads the lib seems
to trigger this. It can be reproduced with dc1394_reset_bus or
coriander (which afterwards segfault).

Let me know what more I can do to help track down the problem.

/Gustaf

> 2. If none, what specific steps should we take to recreate this bug? Be as detailed as possible.
> This will help us to find and resolve the problem.
>
> ** Tags added: bitesize
>
> ** Tags added: packaging
>
> ** Tags added: regression-potential
>

Peter Antoniac (pan1nx) wrote :

Thank you for helping. I am also working upstream and I will test this after the karmic release tomorrow. I let you know and I will mark it later.

Changed in libdc1394-22 (Ubuntu):
status: Incomplete → New
Viktors Petrovs (viks77) wrote :

Have similar problem on Ubuntu 9.10 with latest updates.
Found solution:

There is no file /dev/raw1394 (driver is not loaded)!

$ sudo modprobe raw1394

After this check your permissions on device /dev/raw1394
You must have rw access to this device!
For me it looks like:

$ ls -la /dev/raw1394

crw-rw---- 1 root root 171, 0 2009-10-30 11:34 /dev/raw1394

On my Ubuntu 9.04 system this looks like:

crw-rw---- 1 root disk 171, 0 2009-10-30 11:34 /dev/raw1394

hendeby (hendeby) wrote :

Viktors Petrovs wrote:
> Have similar problem on Ubuntu 9.10 with latest updates.
> Found solution:
>
> There is no file /dev/raw1394 (driver is not loaded)!
>
> $ sudo modprobe raw1394
>
> After this check your permissions on device /dev/raw1394
> You must have rw access to this device!
> For me it looks like:
>
> $ ls -la /dev/raw1394
>
> crw-rw---- 1 root root 171, 0 2009-10-30 11:34 /dev/raw1394
>
> On my Ubuntu 9.04 system this looks like:
>
> crw-rw---- 1 root disk 171, 0 2009-10-30 11:34 /dev/raw1394
>

Thank you! This solves my problem. Any idea why raw1394 isn't loaded?
 I would expect it to be by default.

/Gustaf

Viktors Petrovs (viks77) wrote :

Finally, to make changes permanent, i added raw1394 to /etc/modules file:

$ echo "raw1394" | sudo tee -a /etc/modules

and created udev rule to change group of /dev/raw1394 device:

$ echo 'KERNEL=="raw1394", GROUP="disk"' | sudo tee -a /etc/udev/rules.d/50-raw1394.rules

Peter Antoniac (pan1nx) wrote :

I will take this with debian and make sure to embed your comments. Thank you for the help.

Peter Antoniac (pan1nx) wrote :

Needs to forward to debian (not upstream)

Changed in libdc1394-22 (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
tags: added: needs-packaging
hendeby (hendeby) wrote :

Thank you very much for your kind help! It has been very much appreciated.

Regards,
Gustaf

Peter Antoniac wrote:
> I also remembered that there was a discussion on the upstream about it:
>
> http://sourceforge.net/mailarchive/message.php?msg_id=4AB735F3.20402%40enseirb.fr
>
> and here:
>
> http://sourceforge.net/mailarchive/message.php?msg_id=119178.7582.qm%40web111602.mail.gq1.yahoo.com
>
> Regards,
> Peter
>

tags: added: regression-release
removed: regression-potential
Scott Kitterman (kitterman) wrote :

This bug was fixed in the package libdc1394-22 - 2.2.0-2
Sponsored for Rohan Garg (rohangarg)

---------------
libdc1394-22 (2.2.0-2) unstable; urgency=low

  * Really move libdc1394-utils to section utils.
  * Add Multi-Arch support.
  * Don't store debug symbols of the utils.

 -- Guus Sliepen <email address hidden> Sat, 10 Mar 2012 17:06:32 +0100

libdc1394-22 (2.2.0-1) unstable; urgency=low

  * New upstream release.
    - Renames poorly named externally-visible symbol usb_init. Closes: #655332
  * Move libdc1394-utils to section utils. Closes: #663073
  * Bump Standards-Version.

 -- Guus Sliepen <email address hidden> Sat, 10 Mar 2012 16:11:05 +0100

Changed in libdc1394-22 (Ubuntu):
status: Confirmed → Fix Released

I installed the latest libdc-2.2.0 and on running :
1. Coriander, I get the message: libdc1394 error: Failed to initialize libdc1394, Segmentation fault
2. Hello World I get: libdc1394 error: Failed to initialize libdc1394

The raw1394 has read-write permissions.
The outputs of
1. lsmod | grep 1394 is
raw1394 25298 0
video1394 15684 0
ohci1394 30260 1 video1394
ieee1394 94771 3 raw1394,video1394,ohci1394

I donot get anything when I type lsmod | grep firewire

I am unable to understand what the issue is. Any help would be greatly appreciated. Thanks !

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers