gnucash menu items containing '&' display underscore

Bug #994564 reported by Colin Law on 2012-05-04
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
DBus Menu
Fix Released
Undecided
Albert Astals Cid
0.6
Fix Released
Undecided
Albert Astals Cid
12.10
Fix Released
Undecided
Albert Astals Cid
Unity
Invalid
Undecided
Unassigned
unity-2d
Undecided
Unassigned
libdbusmenu (Ubuntu)
Low
Unassigned
Precise
Low
Unassigned

Bug Description

Impact: some menus items are not correctly rendered (chars not escaped as they should)

Test Case:
- Install tomboy
- Open tomboy and create a note
- Replace the title for "a_b"
- Close the note
- Open the tomboy indicator menu to see that the entry for that note reads "ab" with an underlined b
- Open the note again
- Replace the title for "a_b & cd"
- Open the tomboy indicator menu to see that the entry for that note reads "a_b & cd"

Regression potential: some menu items could be incorrect escaped and have buggy characters

---

Menu items that contain an ampersand character display a leading underscore, for example Actions > Check & Repair displays as _Check & Repair.

I gather from the gnucash mailing list that this is not seen in the same gnucash versioin with Fedora or KDE so possibly it is a Unity issue.

Related branches

Colin Law (colin-law) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnucash (Ubuntu):
status: New → Confirmed
Tiago Neiva (tneiva) wrote :

I installed Gnome Shell and in Gnome Shell it works ok. The issue is some how related with Unity.

Tiago Neiva (tneiva) wrote :

Commpilled from source in 11.10 and it works ok.
So the issue is a combinatoin of Ubuntu 12.04, running Unity and any version of gnucash 2.4.

It looks like an issue in the new version Unity

Tiago Neiva (tneiva) wrote :

Just confirmed it is not an issue in gnucash alone.

There is a "feature"/bug on tomboy notes that allows this issue to be reproduced in Precise Pangolin 12.04:

- Open tomboy and create a note
- Replace the title for "a_b"
- Close the note
- Open the tomboy indicator menu to see that the entry for that note reads "ab" with an underlined b
- Open the note again
- Replace the title for "a_b & cd"
- Open the tomboy indicator menu to see that the entry for that note reads "a_b & cd"

There is something wrong on the interpretation of strings with "&" that "kills" the correct interpretation of underscore as a key accelerator in unity.

Tiago Neiva (tneiva) wrote :

The issue is common to more then one application and only occurs with Unity in 12.04

affects: gnucash (Ubuntu) → unity (Ubuntu)
Colin Law (colin-law) wrote :

I am seeing it on unity-2d so setting also affects -> unity-2d

Changed in unity-2d:
status: New → Confirmed
status: Confirmed → Triaged
status: Triaged → New
Changed in dbusmenu:
status: New → Confirmed
assignee: nobody → Albert Astals Cid (aacid)
Changed in unity:
status: New → Invalid
Changed in unity-2d:
status: New → Invalid
Changed in dbusmenu:
status: Confirmed → In Progress
Changed in dbusmenu:
status: In Progress → Fix Committed
affects: unity (Ubuntu) → libdbusmenu (Ubuntu)
Changed in libdbusmenu (Ubuntu):
importance: Undecided → Low
status: Confirmed → Fix Committed
Changed in libdbusmenu (Ubuntu Precise):
importance: Undecided → Low
status: New → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libdbusmenu - 0.6.2-0ubuntu1

---------------
libdbusmenu (0.6.2-0ubuntu1) quantal; urgency=low

  * New upstream release.
    * Fixed duplicated underscores in menus (LP: #979301)
    * Fix for keybindings not showing in menus bug (LP: #982656)
    * DbusmenuServer leaks private string (LP: #981766)
    * Ensure menuitems with '&' show them properly (LP: #994564)
 -- Ted Gould <email address hidden> Wed, 13 Jun 2012 14:44:52 -0500

Changed in libdbusmenu (Ubuntu):
status: Fix Committed → Fix Released
Changed in libdbusmenu (Ubuntu Precise):
status: Triaged → Fix Committed
description: updated
description: updated

Hello Colin, or anyone else affected,

Accepted libdbusmenu into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/libdbusmenu/0.6.2-0ubuntu0.1 in a few hours and then in the -proposed repository. Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case details of your testing will help us make a better decision. Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Chris Halse Rogers (raof) wrote :

The changelog doesn't mention that you've also added a whole bunch of docs to the package, but I guess that's okay.

Tiago Neiva (tneiva) wrote :

Installed proposed version, tested on both tomboy and gnucash and the bug was FIXED.

Sebastien Bacher (seb128) wrote :

@Tiago: thanks for testing!

tags: added: verification-done
removed: verification-needed

I had this same problem for LyX (e.g., Edit > Find & Replace (Quick)).

This patch fixed the problem for me. Thank you!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libdbusmenu - 0.6.2-0ubuntu0.1

---------------
libdbusmenu (0.6.2-0ubuntu0.1) precise-proposed; urgency=low

  * New upstream release.
    * Ensure menuitems with '&' show them properly (LP: #994564)
 -- Ted Gould <email address hidden> Wed, 13 Jun 2012 14:44:52 -0500

Changed in libdbusmenu (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers