Accelerators broken in Firefox menus with dbusmenu 0.5.99-0ubuntu2

Bug #982656 reported by Chris Coulson on 2012-04-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
DBus Menu
Fix Released
High
Ted Gould
libdbusmenu (Ubuntu)
High
Unassigned
Precise
High
Unassigned

Bug Description

I just noticed this evening that accelerators are missing from the History and Bookmarks menus in Firefox. After downgrading dbusmenu a few times, it seems that this worked last in 0.5.99-0ubuntu1 (and stopped working in 0.5.99-0ubuntu2).

The attached screenshot shows the issue. The "Show All History" item should have an accelerator item that says "Ctrl+Shift+H". The attached output from dbusmenu-dumper shows that Firefox is setting the correct shortcut property on this menuitem

Related branches

Chris Coulson (chrisccoulson) wrote :
Chris Coulson (chrisccoulson) wrote :
Changed in libdbusmenu (Ubuntu Precise):
importance: Undecided → Medium
Chris Coulson (chrisccoulson) wrote :

@@ -287,11 +312,15 @@
  if (labelw == NULL) {
   /* Build it */
   labelw = GTK_LABEL(gtk_accel_label_new(local_label));
- gtk_label_set_use_underline(GTK_LABEL(labelw), TRUE);
   gtk_label_set_use_markup(GTK_LABEL(labelw), TRUE);
   gtk_misc_set_alignment(GTK_MISC(labelw), 0.0, 0.5);
- gtk_accel_label_set_accel_widget(GTK_ACCEL_LABEL(labelw), GTK_WIDGET(menu_item));
- gtk_label_set_markup_with_mnemonic(labelw, local_label);
+
+ if (has_mnemonic(in_label, FALSE)) {
+ gtk_label_set_use_underline(GTK_LABEL(labelw), TRUE);
+ gtk_accel_label_set_accel_widget(GTK_ACCEL_LABEL(labelw), GTK_WIDGET(menu_item));
+ gtk_label_set_markup_with_mnemonic(labelw, local_label);
+ }
+
   gtk_widget_show(GTK_WIDGET(labelw));

   /* Check to see if it needs to be in the bin for this

Surely the call to gtk_accel_label_set_accel_widget() should be outside of this conditional?

Changed in libdbusmenu (Ubuntu Precise):
importance: Medium → High
Changed in dbusmenu:
importance: Undecided → High
Charles Kerr (charlesk) wrote :

Chris, both the display and activation of ctrl-shift-h works for me under:

  * firefox 11.0+build1-0ubuntu4
  * libdbusmenu-gtk4 0.6.1-0ubuntu2

The code block you reference in comment #3 is differs from current trunk after ted's two patches http://bazaar.launchpad.net/~dbusmenu-team/dbusmenu/trunk.0.6/revision/411 and http://bazaar.launchpad.net/~dbusmenu-team/dbusmenu/trunk.0.6/revision/413

Can you test out whether or not the bug you're seeing is reproductible for you in libdbusmenu-gtk4 0.6.1-0ubuntu2 ?

Changed in dbusmenu:
status: New → Incomplete
Changed in libdbusmenu (Ubuntu Precise):
status: New → Incomplete
Charles Kerr (charlesk) wrote :
Charles Kerr (charlesk) wrote :

Ignore comments #4 and #5, I had a different version of dbusmenu hardwired into /usr/lib over the weekend and forgot to revert to stock settings before testing this.

Changed in dbusmenu:
status: Incomplete → New
Changed in libdbusmenu (Ubuntu Precise):
status: Incomplete → New
Ted Gould (ted) on 2012-04-16
Changed in dbusmenu:
status: New → Confirmed
assignee: nobody → Ted Gould (ted)
milestone: none → 0.6.2
Changed in libdbusmenu (Ubuntu Precise):
status: New → Fix Committed
Charles Kerr (charlesk) on 2012-04-16
summary: - Accelarators broken in Firefox menus with dbusmenu 0.5.99-0ubuntu2
+ Accelerators broken in Firefox menus with dbusmenu 0.5.99-0ubuntu2
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libdbusmenu - 0.6.1-0ubuntu3

---------------
libdbusmenu (0.6.1-0ubuntu3) precise-proposed; urgency=low

  * Backport fix for keybindings not showing in menus bug (lp: #982656)
 -- Sebastien Bacher <email address hidden> Mon, 16 Apr 2012 21:28:05 +0200

Changed in libdbusmenu (Ubuntu Precise):
status: Fix Committed → Fix Released
Ted Gould (ted) on 2012-06-13
Changed in dbusmenu:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers