After libdbusmenu-gtk3-4 upgrade closing gedit shows about 800+ lines - (gedit:3155): LIBDBUSMENU-GTK-WARNING **: (/build/buildd/libdbusmenu-0.5.99/./libdbusmenu-gtk/parser.c:228):parser_data_free: runtime check failed: (i != 1)

Bug #977803 reported by Doug McMahon on 2012-04-10
48
This bug affects 10 people
Affects Status Importance Assigned to Milestone
DBus Menu
Fix Released
High
Charles Kerr
libdbusmenu (Ubuntu)
High
Ken VanDine
Precise
High
Ken VanDine

Bug Description

Don't know if it matters was just noticing it happening, normally gedit closes without 'comment'

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: gedit 3.4.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-22.35-generic-pae 3.2.14
Uname: Linux 3.2.0-22-generic-pae i686
ApportVersion: 2.0-0ubuntu4
Architecture: i386
Date: Tue Apr 10 03:19:53 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta i386 (20120407)
ProcEnviron:
 TERM=xterm
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: gedit
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Doug McMahon (mc3man) wrote :
summary: - After libdbusmenu-gtk3-4 upgradeclosing gedit shows about 800+ lines -
+ After libdbusmenu-gtk3-4 upgrade closing gedit shows about 800+ lines -
(gedit:3155): LIBDBUSMENU-GTK-WARNING **:
(/build/buildd/libdbusmenu-0.5.99/./libdbusmenu-
gtk/parser.c:228):parser_data_free: runtime check failed: (i != 1)
Sebastien Bacher (seb128) wrote :

That seems a regression from the recent changes (Ken backported those to distro):

libdbusmenu (0.5.99-0ubuntu2) precise; urgency=low

  * libdbusmenu-glib/server.c
    - Cherry picked a fix for a regression in about-to-show grouping
  * libdbusmenu-gtk/genericmenuitem.c
    - Fixed: underscore on menu items change on switching focus (LP: #903200)
  * libdbusmenu-gtk/parser.c
    - Fixed: nautilus crashed with SIGSEGV in
      dbusmenu_menuitem_property_remove() (LP: #959821)

affects: gedit (Ubuntu) → libdbusmenu (Ubuntu)
Changed in libdbusmenu (Ubuntu):
importance: Undecided → High
assignee: nobody → Ken VanDine (ken-vandine)
Changed in dbusmenu:
assignee: nobody → Charles Kerr (charlesk)
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libdbusmenu (Ubuntu):
status: New → Confirmed
Paul Ortyl (ortylp) wrote :

Same here, but with gnome-mplayer. I get a lot of these on the terminal:

(gnome-mplayer:2347): LIBDBUSMENU-GTK-WARNING **: (/build/buildd/libdbusmenu-0.5.99/./libdbusmenu-gtk/parser.c:281):parser_data_free: runtime check failed: (i != 1)
in media state change with state = 1

(gnome-mplayer:2347): LIBDBUSMENU-GTK-CRITICAL **: watch_submenu: assertion `GTK_IS_MENU_SHELL(menu)' failed

(gnome-mplayer:2347): LIBDBUSMENU-GTK-WARNING **: (/build/buildd/libdbusmenu-0.5.99/./libdbusmenu-gtk/parser.c:228):parser_data_free: runtime check failed: (i != 1)

(gnome-mplayer:2347): LIBDBUSMENU-GTK-WARNING **: (/build/buildd/libdbusmenu-0.5.99/./libdbusmenu-gtk/parser.c:273):parser_data_free: runtime check failed: (i != 1)

(gnome-mplayer:2347): LIBDBUSMENU-GTK-WARNING **: (/build/buildd/libdbusmenu-0.5.99/./libdbusmenu-gtk/parser.c:281):parser_data_free: runtime check failed: (i != 1)

(gnome-mplayer:2347): LIBDBUSMENU-GTK-WARNING **: (/build/buildd/libdbusmenu-0.5.99/./libdbusmenu-gtk/parser.c:228):parser_data_free: runtime check failed: (i != 1)

Changed in dbusmenu:
status: New → Confirmed
Mr Pablito (mrpablito645) wrote :

I got the same message with gvim:
(gvim:15882): LIBDBUSMENU-GTK-WARNING **: (/build/buildd/libdbusmenu-0.5.99/./libdbusmenu-gtk/parser.c:228):parser_data_free: runtime check failed: (i != 1)

(gvim:15882): LIBDBUSMENU-GTK-WARNING **: (/build/buildd/libdbusmenu-0.5.99/./libdbusmenu-gtk/parser.c:281):parser_data_free: runtime check failed: (i != 1)

(gvim:15882): LIBDBUSMENU-GTK-WARNING **: (/build/buildd/libdbusmenu-0.5.99/./libdbusmenu-gtk/parser.c:228):parser_data_free: runtime check failed: (i != 1)

(gvim:15882): LIBDBUSMENU-GTK-WARNING **: (/build/buildd/libdbusmenu-0.5.99/./libdbusmenu-gtk/parser.c:281):parser_data_free: runtime check failed: (i != 1)

Charles Kerr (charlesk) on 2012-04-10
Changed in dbusmenu:
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libdbusmenu - 0.5.99-0ubuntu3

---------------
libdbusmenu (0.5.99-0ubuntu3) precise; urgency=low

  * libdbusmenu-gtk/parser.c
    - switch the smoke test to a g_debug statement (LP: #977803)
 -- Ken VanDine <email address hidden> Tue, 10 Apr 2012 13:21:02 -0400

Changed in libdbusmenu (Ubuntu Precise):
status: Confirmed → Fix Released
Charles Kerr (charlesk) on 2012-04-12
Changed in dbusmenu:
status: Fix Committed → Fix Released
Charles Kerr (charlesk) on 2012-04-12
Changed in dbusmenu:
milestone: none → 0.6.0
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers