nautilus crashed with SIGSEGV in dbusmenu_menuitem_property_remove()

Bug #959821 reported by Moshe Krumbein on 2012-03-20
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
DBus Menu
Fix Released
Medium
Charles Kerr
libdbusmenu (Ubuntu)
Medium
Unassigned
nautilus (Ubuntu)
Low
Unassigned

Bug Description

did ctrl + h

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: nautilus 1:3.3.91-0ubuntu4
ProcVersionSignature: Ubuntu 3.2.0-19.30-generic 3.2.11
Uname: Linux 3.2.0-19-generic x86_64
ApportVersion: 1.94.1-0ubuntu2
Architecture: amd64
Date: Mon Mar 19 20:19:58 2012
ExecutablePath: /usr/bin/nautilus
GsettingsChanges: org.gnome.nautilus.window-state geometry '800x550+65+24'
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120304)
ProcCmdline: nautilus -n
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7ff73abed21e <dbusmenu_menuitem_property_remove+30>: cmp %rax,(%rdx)
 PC (0x7ff73abed21e) ok
 source "%rax" ok
 destination "(%rdx)" (0x700000008) not located in a known VMA region (needed writable region)!
SegvReason: writing unknown VMA
Signal: 11
SourcePackage: nautilus
StacktraceTop:
 dbusmenu_menuitem_property_remove () from /usr/lib/x86_64-linux-gnu/libdbusmenu-glib.so.4
 ?? () from /usr/lib/x86_64-linux-gnu/libdbusmenu-gtk3.so.4
 ?? () from /usr/lib/x86_64-linux-gnu/libdbusmenu-gtk3.so.4
 g_closure_invoke () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Title: nautilus crashed with SIGSEGV in dbusmenu_menuitem_property_remove()
UpgradeStatus: Upgraded to precise on 2012-03-12 (7 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Related branches

StacktraceTop:
 dbusmenu_menuitem_property_remove (mi=0x1a816a0, property=0x7ff738b6554f "icon-name") at /build/buildd/libdbusmenu-0.5.94/./libdbusmenu-glib/menuitem.c:1448
 update_icon (menuitem=0x1a816a0, pdata=<optimized out>, gmenuitem=<optimized out>, image=<optimized out>) at /build/buildd/libdbusmenu-0.5.94/./libdbusmenu-gtk/parser.c:842
 widget_notify_cb (widget=0x12262a0, pspec=<optimized out>, data=0x1a816a0) at /build/buildd/libdbusmenu-0.5.94/./libdbusmenu-gtk/parser.c:1180
 g_closure_invoke (closure=0x1d1dd80, return_value=0x0, n_param_values=2, param_values=0x1694d90, invocation_hint=<optimized out>) at /build/buildd/glib2.0-2.31.20/./gobject/gclosure.c:777
 signal_emit_unlocked_R (node=<optimized out>, detail=1550, instance=<optimized out>, emission_return=0x0, instance_and_params=0x1694d90) at /build/buildd/glib2.0-2.31.20/./gobject/gsignal.c:3547

Changed in nautilus (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
visibility: private → public
affects: nautilus (Ubuntu) → libdbusmenu (Ubuntu)
Olli Ries (ories) on 2012-03-27
Changed in dbusmenu:
importance: Undecided → High
assignee: nobody → Ted Gould (ted)
Changed in dbusmenu:
status: New → Confirmed
importance: High → Medium
Changed in libdbusmenu (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus (Ubuntu):
status: New → Confirmed
Changed in nautilus (Ubuntu):
importance: Undecided → Low
status: Confirmed → Invalid
Charles Kerr (charlesk) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:

* Is this reproducible?
* If so, what specific steps should we take to recreate this bug?

This will help us to find and resolve the problem.

Changed in dbusmenu:
status: Confirmed → Incomplete
Charles Kerr (charlesk) on 2012-04-09
Changed in dbusmenu:
assignee: Ted Gould (ted) → Charles Kerr (charlesk)
Charles Kerr (charlesk) on 2012-04-09
Changed in dbusmenu:
status: Incomplete → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libdbusmenu - 0.5.99-0ubuntu2

---------------
libdbusmenu (0.5.99-0ubuntu2) precise; urgency=low

  * libdbusmenu-glib/server.c
    - Cherry picked a fix for a regression in about-to-show grouping
  * libdbusmenu-gtk/genericmenuitem.c
    - Fixed: underscore on menu items change on switching focus (LP: #903200)
  * libdbusmenu-gtk/parser.c
    - Fixed: nautilus crashed with SIGSEGV in
      dbusmenu_menuitem_property_remove() (LP: #959821)
 -- Ken VanDine <email address hidden> Mon, 09 Apr 2012 16:29:34 -0400

Changed in libdbusmenu (Ubuntu):
status: Confirmed → Fix Released
Charles Kerr (charlesk) on 2012-04-12
Changed in dbusmenu:
status: Fix Committed → Fix Released
Charles Kerr (charlesk) on 2012-04-12
Changed in dbusmenu:
milestone: none → 0.6.0
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers