libdbusmenu-gtk crash in parser.c theme_changed_cb()

Bug #953509 reported by Pierre Couillard on 2012-03-12
620
This bug affects 77 people
Affects Status Importance Assigned to Milestone
DBus Menu
Fix Released
High
Charles Kerr
libdbusmenu (Ubuntu)
High
Unassigned

Bug Description

Unity crashed

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: nautilus 1:3.3.91-0ubuntu4
ProcVersionSignature: Ubuntu 3.2.0-18.29-generic-pae 3.2.9
Uname: Linux 3.2.0-18-generic-pae i686
NonfreeKernelModules: nvidia
ApportVersion: 1.94.1-0ubuntu2
Architecture: i386
Date: Mon Mar 12 18:42:15 2012
ExecutablePath: /usr/bin/nautilus
GsettingsChanges:
 org.gnome.nautilus.window-state geometry '800x550+187+52'
 org.gnome.nautilus.window-state sidebar-width 199
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386 (20120312)
ProcCmdline: nautilus -n
ProcEnviron:
 LANGUAGE=fr_CA:fr
 LANG=fr_CA.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0xb6b150c8 <g_type_check_instance_cast+56>: mov (%eax),%ebp
 PC (0xb6b150c8) ok
 source "(%eax)" (0x0000a88a) not located in a known VMA region (needed readable region)!
 destination "%ebp" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: nautilus
StacktraceTop:
 g_type_check_instance_cast () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
 ?? () from /usr/lib/i386-linux-gnu/libdbusmenu-gtk3.so.4
 g_cclosure_marshal_VOID__VOID () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
 g_closure_invoke () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
 ?? () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
Title: nautilus crashed with SIGSEGV in g_type_check_instance_cast()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Related branches

Pierre Couillard (pcouillard) wrote :

This crash has the same stack trace characteristics as bug #951561. However, the latter was already fixed in an earlier package version than the one in this report. This might be a regression or because the problem is in a dependent package.

tags: added: regression-retracer

StacktraceTop:
 g_type_check_instance_cast (type_instance=0x93f0ae0, iface_type=150636320) at /build/buildd/glib2.0-2.31.20/./gobject/gtype.c:3999
 theme_changed_cb (theme=0x8ec0140, data=0x93f0ae0) at /build/buildd/libdbusmenu-0.5.94/./libdbusmenu-gtk/parser.c:1295
 g_cclosure_marshal_VOID__VOID (closure=0x95fd238, return_value=0x0, n_param_values=1, param_values=0x9479838, invocation_hint=0xbfd98960, marshal_data=0x0) at /build/buildd/glib2.0-2.31.20/./gobject/gmarshal.c:85
 g_closure_invoke (closure=0x95fd238, return_value=0x0, n_param_values=1, param_values=0x9479838, invocation_hint=0xbfd98960) at /build/buildd/glib2.0-2.31.20/./gobject/gclosure.c:777
 signal_emit_unlocked_R (node=0x8f60640, detail=0, instance=0x8ec0140, emission_return=0x0, instance_and_params=0x9479838) at /build/buildd/glib2.0-2.31.20/./gobject/gsignal.c:3547

Changed in nautilus (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus (Ubuntu):
status: New → Confirmed
tags: added: bugpattern-needed
visibility: private → public
Changed in nautilus (Ubuntu):
importance: Medium → High
affects: nautilus (Ubuntu) → libdbusmenu (Ubuntu)
Changed in dbusmenu:
importance: Undecided → High
status: New → Confirmed
Charles Kerr (charlesk) on 2012-03-18
summary: - nautilus crashed with SIGSEGV in g_type_check_instance_cast()
+ libdbusmenu-gtk crash in parser.c theme_changed_cb()
Changed in dbusmenu:
assignee: nobody → Charles Kerr (charlesk)
status: Confirmed → In Progress
crtm (carlosrtm) wrote :

Crashed after try to unmount a Kingston Pendrive

Charles Kerr (charlesk) wrote :

crtm: thanks for the extra info, it was very helpful in testing :)

Changed in dbusmenu:
status: In Progress → Fix Committed
Changed in libdbusmenu (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libdbusmenu - 0.5.94-0ubuntu2

---------------
libdbusmenu (0.5.94-0ubuntu2) precise; urgency=low

  * Backported to r388 to fix a frequent segfault issue (lp: #953509)
 -- Sebastien Bacher <email address hidden> Wed, 21 Mar 2012 17:23:24 +0100

Changed in libdbusmenu (Ubuntu):
status: Fix Committed → Fix Released
Ted Gould (ted) on 2012-03-21
Changed in dbusmenu:
status: Fix Committed → Fix Released
milestone: none → 0.5.95
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers