g_value_get_object: assertion `G_VALUE_HOLDS_OBJECT (value)' failed ) spam in nautilus

Bug #870742 reported by Richard Wonka on 2011-10-08
196
This bug affects 67 people
Affects Status Importance Assigned to Milestone
DBus Menu
Fix Released
Undecided
Ted Gould
0.5
Fix Committed
Undecided
Unassigned
0.6
Fix Released
Undecided
Ted Gould
libdbusmenu (Ubuntu)
High
Unassigned

Bug Description

.xsession errors is filled with entries like this:

(nautilus:1708): GLib-GObject-CRITICAL **: g_value_get_object: assertion `G_VALUE_HOLDS_OBJECT (value)' failed

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: nautilus 1:3.2.0-0ubuntu5
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
ApportVersion: 1.23-0ubuntu2
Architecture: amd64
Date: Sat Oct 8 21:26:23 2011
SourcePackage: nautilus
UpgradeStatus: Upgraded to oneiric on 2011-10-08 (0 days ago)

Related branches

Richard Wonka (richard-wonka) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please try to obtain a backtrace following the instructions at http://wiki.ubuntu.com/DebuggingProgramCrash and upload the backtrace (as an attachment) to the bug report. This will greatly help us in tracking down your problem.

Changed in nautilus (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
affects: nautilus (Ubuntu) → libdbusmenu (Ubuntu)
Changed in libdbusmenu (Ubuntu):
importance: Low → High
status: Incomplete → Confirmed
assignee: nobody → Ted Gould (ted)
Sebastien Bacher (seb128) wrote :

The warning is coming from libdbusmenu

#2 0x00c0e609 in g_value_get_object ()
   from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#3 0x01edf9df in widget_notify_cb (widget=0x8483638, pspec=0x82da520,
    data=0x86f9a00)
    at /build/buildd/libdbusmenu-0.5.0/./libdbusmenu-gtk/parser.c:1066
#4 0x00c05b03 in g_cclosure_marshal_VOID__PARAM ()
   from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0

summary: - Nautilus and unity 3d unusable in oneiric ((nautilus:1708): GLib-
- GObject-CRITICAL **: g_value_get_object: assertion `G_VALUE_HOLDS_OBJECT
- (value)' failed )
+ g_value_get_object: assertion `G_VALUE_HOLDS_OBJECT (value)' failed )
+ spam in nautilus
Ted Gould (ted) on 2011-10-13
Changed in dbusmenu:
status: New → In Progress
milestone: none → 0.5.2
assignee: nobody → Ted Gould (ted)
Sebastien Bacher (seb128) wrote :

Ken, could you maybe look at backporting that commit if you do an upload of dbusmenu for Oneiric? There is quite some log spam which seems to bother some users

Changed in libdbusmenu (Ubuntu):
assignee: Ted Gould (ted) → Ken VanDine (ken-vandine)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libdbusmenu - 0.5.1-0ubuntu2

---------------
libdbusmenu (0.5.1-0ubuntu2) precise; urgency=low

  * libdbusmenu-gtk/parser.c
    - Don't try to get objects from boolean values. Handle the
      'always show image' property by getting the image from the object
      and using that (LP: #870742)
 -- Ken VanDine <email address hidden> Thu, 01 Dec 2011 11:07:36 -0500

Changed in libdbusmenu (Ubuntu):
status: Confirmed → Fix Released
Ted Gould (ted) on 2011-12-01
Changed in dbusmenu:
status: In Progress → Fix Committed
Forage (forage) wrote :

I'm one of those users who is "bothered" by this issue. Not necessarily because of the errors itself, but it renders the file .xsession-errors basically useless. The amount and frequency of the errors flooding the file makes it almost impossible to track other issues.

Could it please be backported to Oneiric?

rajesh (harjes11) on 2012-01-14
Changed in libdbusmenu (Ubuntu):
assignee: Ken VanDine (ken-vandine) → nobody
tekstr1der (tekstr1der) wrote :

I'm not sure how, or why, @rajesh (does not seem to be an active launchpad user) was able to modify the assignee on this bug.

This bug is affecting the current release of Ubuntu 11.10.

As requested by @Forage, can this fix please be backported to Oneiric?

Changed in oneiric-backports:
status: New → Confirmed
Dmitry Shachnev (mitya57) wrote :

Oneiric-Backports is not a right place to request
bugfixes backporting.

From https://wiki.ubuntu.com/UbuntuBackports
:
> This generally makes backports an inappropriate avenue for fixing bugs. If a package in an Ubuntu release has a bug, it should be fixed either through the Security Update or the Stable Release Update process, as appropriate.

Changed in oneiric-backports:
status: Confirmed → Invalid
tekstr1der (tekstr1der) wrote :

I realize that, but the ever-more-frustrating-to-use Launchpad tracking system seems to no longer allow the nominating of a release series. I am trying to get this back on the radar.

Obviously, as the bug is filed against 11.10, and that is the current release, it should still have the status of confirmed or triaged. The fix, so far, is only applied to pre-release version 12.04. Hence the request for backporting.

Can someone with the ability to do so please nominate this bug/fix for Oneiric so it's not lost in the shuffle with the misleading tag of "Fix Released".

no longer affects: oneiric-backports
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers